-
-
Notifications
You must be signed in to change notification settings - Fork 26
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Add: GLFW Builds of Ghostty, Changes to Main Specs For Compatibility (#…
…2788) (#2797) * Add: GLFW builds of Ghostty, edit existing builds for shared deps, add build deps to be explicitly called (just in case), some cleanup * Add: Add warning about GLFW builds possibly being unstable * Fix: Removed duplicate text (thanks mouse) * Update ghostty-nightly.spec Signed-off-by: Gil <rockgrub@protonmail.com> * Cleanup: Removed unused build deps, removed unused patches (for now?) * Fix: New icon size in Tip GTK (will need to be done in stable in 1.0.1), minor changes to summaries * Resolve: Date conflict --------- Signed-off-by: Gil <rockgrub@protonmail.com> (cherry picked from commit d990cae) Co-authored-by: Gil <rockgrub@protonmail.com>
- Loading branch information
Showing
14 changed files
with
255 additions
and
97 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
project pkg { | ||
rpm { | ||
spec = "ghostty-glfw-nightly.spec" | ||
} | ||
labels { | ||
nightly = 1 | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,88 @@ | ||
%global commit 478fe3917c2882a1c321f9d1eec808b71698974d | ||
%global shortcommit %(c=%{commit}; echo ${c:0:7}) | ||
%global commit_date 20241231 | ||
|
||
Name: ghostty-glfw-nightly | ||
Version: %{commit_date}.%{shortcommit} | ||
Release: 1%{?dist} | ||
Summary: A fast, native terminal emulator written in Zig; this is the Tip (nightly) build using the GLFW rendering library. | ||
License: MIT | ||
URL: https://ghostty.org/ | ||
Source0: https://github.com/ghostty-org/ghostty/archive/%{commit}/ghostty-%{commit}.tar.gz | ||
Patch0: no-strip.diff | ||
BuildRequires: glfw-devel | ||
BuildRequires: ncurses | ||
BuildRequires: ncurses-devel | ||
BuildRequires: pandoc-cli | ||
BuildRequires: zig | ||
Requires: ghostty-nightly-terminfo = %{version}-%{release} | ||
Requires: ghostty-nightly-shell-integration = %{version}-%{release} | ||
Requires: fontconfig | ||
Requires: freetype | ||
Requires: glib2 | ||
Requires: glfw | ||
Requires: harfbuzz | ||
Requires: libpng | ||
Requires: oniguruma | ||
Requires: pixman | ||
Requires: zlib-ng | ||
Conflicts: ghostty | ||
Conflicts: ghostty-nightly | ||
Conflicts: ghostty-glfw | ||
Provides: ghostty-tip-glfw = %{version}-%{release} | ||
Provides: ghostty-glfw-tip = %{version}-%{release} | ||
Packager: ShinyGil <rockgrub@protonmail.com> | ||
|
||
%description | ||
👻 Ghostty is a fast, feature-rich, and cross-platform terminal emulator that uses platform-native UI and GPU acceleration. | ||
|
||
Please note GLFW builds are intended for developer use, they may be buggy and lack features. Use at your own risk. | ||
|
||
%prep | ||
%autosetup -n ghostty-%{commit} -p1 | ||
|
||
%build | ||
|
||
%install | ||
zig build \ | ||
--summary all \ | ||
-Doptimize=ReleaseFast --release=fast \ | ||
--prefix %{buildroot}%{_prefix} --verbose \ | ||
-Dpie=true \ | ||
-Dapp-runtime=glfw \ | ||
-Demit-docs | ||
rm -rf %{buildroot}%{bash_completions_dir}/ghostty.bash \ | ||
%{buildroot}%{fish_completions_dir}/ghostty.fish \ | ||
%{buildroot}%{zsh_completions_dir}/_ghostty \ | ||
%{buildroot}%{_datadir}/ghostty/shell-integration \ | ||
%{buildroot}%{_datadir}/terminfo/* | ||
|
||
%files | ||
%doc README.md | ||
%license LICENSE | ||
%_bindir/ghostty | ||
%_datadir/applications/com.mitchellh.ghostty.desktop | ||
%_datadir/bat/syntaxes/ghostty.sublime-syntax | ||
%_datadir/ghostty/ | ||
%_datadir/kio/servicemenus/com.mitchellh.ghostty.desktop | ||
%_datadir/nvim/site/ftdetect/ghostty.vim | ||
%_datadir/nvim/site/ftplugin/ghostty.vim | ||
%_datadir/nvim/site/syntax/ghostty.vim | ||
%_datadir/vim/vimfiles/ftdetect/ghostty.vim | ||
%_datadir/vim/vimfiles/ftplugin/ghostty.vim | ||
%_datadir/vim/vimfiles/syntax/ghostty.vim | ||
%_iconsdir/hicolor/16x16/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/16x16@2/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/32x32/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/32x32@2/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/128x128/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/128x128@2/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/256x256/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/256x256@2/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/512x512/apps/com.mitchellh.ghostty.png | ||
%_mandir/man1/ghostty.1.gz | ||
%_mandir/man5/ghostty.5.gz | ||
|
||
%changelog | ||
* Sun Dec 29 2024 ShinyGil <rockgrub@protonmail.com> | ||
- Initial package |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
diff --git a/build.zig b/build.zig | ||
index c3f7302..a0ecf25 100644 | ||
--- a/build.zig | ||
+++ b/build.zig | ||
@@ -295,11 +295,7 @@ pub fn build(b: *std.Build) !void { | ||
.root_source_file = b.path("src/main.zig"), | ||
.target = target, | ||
.optimize = optimize, | ||
- .strip = switch (optimize) { | ||
- .Debug => false, | ||
- .ReleaseSafe => false, | ||
- .ReleaseFast, .ReleaseSmall => true, | ||
- }, | ||
+ .strip = false, | ||
}) else null; | ||
|
||
// Exe |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
rpm.global("commit", gh_commit("ghostty-org/ghostty")); | ||
if rpm.changed() { | ||
rpm.release(); | ||
rpm.global("commit_date", date()); | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
project pkg { | ||
rpm { | ||
spec = "ghostty-glfw.spec" | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,82 @@ | ||
Name: ghostty-glfw | ||
Version: 1.0.0 | ||
Release: 1%{?dist} | ||
Summary: A fast, native terminal emulator written in Zig; this version uses the GLFW rendering library. | ||
License: MIT | ||
URL: https://ghostty.org/ | ||
Source0: https://release.files.ghostty.org/%{version}/ghostty-source.tar.gz | ||
Patch0: no-strip.diff | ||
BuildRequires: glfw-devel | ||
BuildRequires: ncurses | ||
BuildRequires: ncurses-devel | ||
BuildRequires: pandoc-cli | ||
BuildRequires: zig | ||
Requires: ghostty-terminfo = %{version}-%{release} | ||
Requires: ghostty-shell-integration = %{version}-%{release} | ||
Requires: fontconfig | ||
Requires: freetype | ||
Requires: glib2 | ||
Requires: glfw | ||
Requires: harfbuzz | ||
Requires: libpng | ||
Requires: oniguruma | ||
Requires: pixman | ||
Requires: zlib-ng | ||
Conflicts: ghostty | ||
Conflicts: ghostty-nightly | ||
Conflicts: ghostty-glfw-nightly | ||
Packager: ShinyGil <rockgrub@protonmail.com> | ||
|
||
%description | ||
👻 Ghostty is a fast, feature-rich, and cross-platform terminal emulator that uses platform-native UI and GPU acceleration. | ||
|
||
Please note GLFW builds are intended for developer use, they may be buggy and lack features. Use at your own risk. | ||
|
||
%prep | ||
%autosetup -n ghostty-source -p1 | ||
|
||
%build | ||
|
||
%install | ||
zig build \ | ||
--summary all \ | ||
-Doptimize=ReleaseFast --release=fast \ | ||
--prefix %{buildroot}%{_prefix} --verbose \ | ||
-Dpie=true \ | ||
-Dapp-runtime=glfw \ | ||
-Demit-docs | ||
rm -rf %{buildroot}%{bash_completions_dir}/ghostty.bash \ | ||
%{buildroot}%{fish_completions_dir}/ghostty.fish \ | ||
%{buildroot}%{zsh_completions_dir}/_ghostty \ | ||
%{buildroot}%{_datadir}/ghostty/shell-integration \ | ||
%{buildroot}%{_datadir}/terminfo/* | ||
|
||
%files | ||
%doc README.md | ||
%license LICENSE | ||
%_bindir/ghostty | ||
%_datadir/applications/com.mitchellh.ghostty.desktop | ||
%_datadir/bat/syntaxes/ghostty.sublime-syntax | ||
%_datadir/ghostty/ | ||
%_datadir/kio/servicemenus/com.mitchellh.ghostty.desktop | ||
%_datadir/nvim/site/ftdetect/ghostty.vim | ||
%_datadir/nvim/site/ftplugin/ghostty.vim | ||
%_datadir/nvim/site/syntax/ghostty.vim | ||
%_datadir/vim/vimfiles/ftdetect/ghostty.vim | ||
%_datadir/vim/vimfiles/ftplugin/ghostty.vim | ||
%_datadir/vim/vimfiles/syntax/ghostty.vim | ||
%_iconsdir/hicolor/16x16/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/16x16@2/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/32x32/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/32x32@2/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/128x128/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/128x128@2/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/256x256/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/256x256@2/apps/com.mitchellh.ghostty.png | ||
%_iconsdir/hicolor/512x512/apps/com.mitchellh.ghostty.png | ||
%_mandir/man1/ghostty.1.gz | ||
%_mandir/man5/ghostty.5.gz | ||
|
||
%changelog | ||
* Sun Dec 29 2024 ShinyGil <rockgrub@protonmail.com> | ||
- Initial package |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
diff --git a/build.zig b/build.zig | ||
index c3f7302..a0ecf25 100644 | ||
--- a/build.zig | ||
+++ b/build.zig | ||
@@ -295,11 +295,7 @@ pub fn build(b: *std.Build) !void { | ||
.root_source_file = b.path("src/main.zig"), | ||
.target = target, | ||
.optimize = optimize, | ||
- .strip = switch (optimize) { | ||
- .Debug => false, | ||
- .ReleaseSafe => false, | ||
- .ReleaseFast, .ReleaseSmall => true, | ||
- }, | ||
+ .strip = false, | ||
}) else null; | ||
|
||
// Exe |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
rpm.version(gh_tag("ghostty-org/ghostty")); |
Oops, something went wrong.