Skip to content

Commit

Permalink
webos: com.webos.service.tts: CMakeLists.txt: use C++17
Browse files Browse the repository at this point in the history
:Release Notes:
Switch from C++14 to C++17, because C++17 is now needed after abseil-cpp
dropped -DCMAKE_CXX_STANDARD=14 in:
https://git.openembedded.org/meta-openembedded/commit/?id=190f7b50ac3d7d30cf9d31167fb74f7146c3c8ff

:Detailed Notes:
Fixes:
http://gecko.lge.com:8000/Errors/Details/745187

TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/com.webos.service.tts/1.0.0-28/recipe-sysroot/usr/include/google/protobuf/descriptor.h:2019:53: error: invalid conversion from 'int' to 'const char*' [-fpermissive]
 2019 |       AddWarning(std::string(filename), std::string(element_name), descriptor,
      |                                                     ^~~~~~~~~~~~
      |                                                     |
      |                                                     int

TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/com.webos.service.tts/1.0.0-28/recipe-sysroot/usr/include/google/protobuf/descriptor.h:2293:3: error: invalid conversion from 'const char*' to 'int' [-fpermissive]
 2293 |   ABSL_DCHECK(index < real_oneof_decl_count());
      |   ^~~~~~~~~~~
      |   |
      |   const char*

TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/com.webos.service.tts/1.0.0-28/recipe-sysroot/usr/include/google/protobuf/generated_enum_reflection.h: At global scope:
TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/com.webos.service.tts/1.0.0-28/recipe-sysroot/usr/include/google/protobuf/generated_enum_reflection.h:76:43: error: 'absl::string_view' has not been declared
   76 |                                     absl::string_view name, int* value);
      |                                           ^~~~~~~~~~~
TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/com.webos.service.tts/1.0.0-28/recipe-sysroot/usr/include/google/protobuf/generated_enum_reflection.h:79:61: error: 'absl::string_view' has not been declared
   79 | bool ParseNamedEnum(const EnumDescriptor* descriptor, absl::string_view name,
      |                                                             ^~~~~~~~~~~

...

:Testing Performed:
Only build tested.

:QA Notes:
No change to image.

:Issues Addressed:
[WRQ-504] Create GPVB with Yocto 5.0 Scarthgap

Change-Id: I251345d11427c9867f5fadc8570bf961518f0f88
  • Loading branch information
shr-project committed Mar 10, 2024
1 parent fded3e9 commit b1ad118
Show file tree
Hide file tree
Showing 3 changed files with 73 additions and 5 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -24,6 +24,7 @@ inherit webos_system_bus

SRC_URI = "${WEBOSOSE_GIT_REPO_COMPLETE} \
file://0001-google-add-gpr-lib-to-TTS_ENGINE-call.patch \
file://0002-CMakeLists.txt-use-C-17.patch \
"
S = "${WORKDIR}/git"

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From e9b1243f14689a312489da2de5d47b4554425f0b Mon Sep 17 00:00:00 2001
From bcb22a3fe1391a97777a8ce57e77f0538f1def08 Mon Sep 17 00:00:00 2001
From: Martin Jansa <martin2.jansa@lgepartner.com>
Date: Fri, 29 Sep 2023 20:40:25 +0200
Subject: [PATCH] google: add gpr lib to TTS_ENGINE call
Expand Down Expand Up @@ -61,14 +61,16 @@ No change to image.

:Issues Addressed:
[WRP-310] Apply .patch files for hot-fix to corresponding repositories

Change-Id: I33403d27378896e2ab879899f0b4d071307a192b
---
Upstream-Status: Pending
Upstream-Status: Submitted [http://gpro.lge.com/c/webosose/com.webos.service.tts/+/383766 google: add gpr lib to TTS_ENGINE call]

src/engines/tts/google/CMakeLists.txt | 8 ++++++++
1 file changed, 8 insertions(+)
src/engines/tts/google/CMakeLists.txt | 9 +++++++++
1 file changed, 9 insertions(+)

diff --git a/src/engines/tts/google/CMakeLists.txt b/src/engines/tts/google/CMakeLists.txt
index f04a47d..9b17f2d 100755
index f04a47d..bcfdbac 100755
--- a/src/engines/tts/google/CMakeLists.txt
+++ b/src/engines/tts/google/CMakeLists.txt
@@ -26,6 +26,15 @@ set(src ${CMAKE_CURRENT_SOURCE_DIR}/GoogleTTSEngine.cpp
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
From 8284e55ad70dc5680fde8498f01380b045af64b1 Mon Sep 17 00:00:00 2001
From: Martin Jansa <martin2.jansa@lgepartner.com>
Date: Wed, 13 Dec 2023 17:58:43 +0100
Subject: [PATCH] CMakeLists.txt: use C++17

:Release Notes:
Switch from C++14 to C++17, because C++17 is now needed after abseil-cpp
dropped -DCMAKE_CXX_STANDARD=14 in:
https://git.openembedded.org/meta-openembedded/commit/?id=190f7b50ac3d7d30cf9d31167fb74f7146c3c8ff

:Detailed Notes:
Fixes:
http://gecko.lge.com:8000/Errors/Details/745187

TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/com.webos.service.tts/1.0.0-28/recipe-sysroot/usr/include/google/protobuf/descriptor.h:2019:53: error: invalid conversion from 'int' to 'const char*' [-fpermissive]
2019 | AddWarning(std::string(filename), std::string(element_name), descriptor,
| ^~~~~~~~~~~~
| |
| int

TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/com.webos.service.tts/1.0.0-28/recipe-sysroot/usr/include/google/protobuf/descriptor.h:2293:3: error: invalid conversion from 'const char*' to 'int' [-fpermissive]
2293 | ABSL_DCHECK(index < real_oneof_decl_count());
| ^~~~~~~~~~~
| |
| const char*

TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/com.webos.service.tts/1.0.0-28/recipe-sysroot/usr/include/google/protobuf/generated_enum_reflection.h: At global scope:
TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/com.webos.service.tts/1.0.0-28/recipe-sysroot/usr/include/google/protobuf/generated_enum_reflection.h:76:43: error: 'absl::string_view' has not been declared
76 | absl::string_view name, int* value);
| ^~~~~~~~~~~
TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/com.webos.service.tts/1.0.0-28/recipe-sysroot/usr/include/google/protobuf/generated_enum_reflection.h:79:61: error: 'absl::string_view' has not been declared
79 | bool ParseNamedEnum(const EnumDescriptor* descriptor, absl::string_view name,
| ^~~~~~~~~~~

...

:Testing Performed:
Only build tested.

:QA Notes:
No change to image.

:Issues Addressed:
[WRP-29491] Create GPVB with Yocto 5.0 Scarthgap

Change-Id: Ia5a6a7dbb2ad2e36682ed2f19b935d888ac9eb3b
---
Upstream-Status: Submitted [http://gpro.lge.com/c/webosose/com.webos.service.tts/+/383767 CMakeLists.txt: use C++17]

CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c28c7b..1ce45cb 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,7 +80,7 @@ include_directories(src/include)
include_directories(src/utils)


-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14 -Wall")
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++17 -Wall")

file(GLOB TTS_SOURCE
${CMAKE_SOURCE_DIR}/src/core/*.cpp

0 comments on commit b1ad118

Please sign in to comment.