Skip to content

Commit

Permalink
sdl2: get rid of libunwind for good
Browse files Browse the repository at this point in the history
Previous attempts to prevent linking against libunwind were incomplete.
Simply don't call CheckLibUnwind macro.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  • Loading branch information
dangowrt committed Dec 8, 2024
1 parent d91f0b4 commit 88bf142
Showing 1 changed file with 8 additions and 8 deletions.
16 changes: 8 additions & 8 deletions libs/sdl2/patches/110-tests-no-libunwind.patch
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
--- a/cmake/sdlchecks.cmake
+++ b/cmake/sdlchecks.cmake
@@ -1406,7 +1406,4 @@ macro(CheckLibUnwind)
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1622,7 +1622,6 @@ elseif(UNIX AND NOT APPLE AND NOT RISCOS
endif()

endif()
endif()
- CheckLibUnwind()

- if(found_libunwind)
- set(HAVE_LIBUNWIND_H TRUE)
- endif()
endmacro()
if(HAVE_DBUS_DBUS_H)
list(APPEND SOURCE_FILES "${SDL2_SOURCE_DIR}/src/core/linux/SDL_dbus.c")

0 comments on commit 88bf142

Please sign in to comment.