Skip to content

Commit

Permalink
zerotier: update to 1.14.1
Browse files Browse the repository at this point in the history
Signed-off-by: Moritz Warning <moritzwarning@web.de>
  • Loading branch information
mwarning committed Sep 18, 2024
1 parent 22dd9a0 commit e459525
Show file tree
Hide file tree
Showing 6 changed files with 45 additions and 36 deletions.
6 changes: 3 additions & 3 deletions net/zerotier/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=zerotier
PKG_VERSION:=1.14.0
PKG_RELEASE:=2
PKG_VERSION:=1.14.1
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)?
PKG_HASH:=7191623a81b0d1b552b9431e8864dd3420783ee518394ac1376cee6aaf033291
PKG_HASH:=4f9f40b27c5a78389ed3f3216c850921f6298749e5819e9f2edabb2672ce9ca0
PKG_BUILD_DIR:=$(BUILD_DIR)/ZeroTierOne-$(PKG_VERSION)

PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
Expand Down
Original file line number Diff line number Diff line change
@@ -1,13 +1,14 @@
From f53004bd22365900a1dbb120dae62ce8b614d31d Mon Sep 17 00:00:00 2001
From ec02787ae7c5b6e906ab50bcebcd676d4219c812 Mon Sep 17 00:00:00 2001
From: Moritz Warning <moritzwarning@web.de>
Date: Mon, 6 May 2024 22:31:57 +0200
Subject: [PATCH 1/5] fix miniupnpc/natpmp include paths
Date: Tue, 17 Sep 2024 14:17:08 +0200
Subject: [PATCH 1/5] fix miniupnpc natpmp include path

Signed-off-by: Moritz Warning <moritzwarning@web.de>
---
make-linux.mk | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/make-linux.mk b/make-linux.mk
index efc1badf..d2e1714f 100644
--- a/make-linux.mk
+++ b/make-linux.mk
@@ -26,8 +26,8 @@ TIMESTAMP=$(shell date +"%Y%m%d%H%M")
Expand All @@ -30,3 +31,6 @@ Signed-off-by: Moritz Warning <moritzwarning@web.de>
ONE_OBJS+=ext/libnatpmp/natpmp.o ext/libnatpmp/getgateway.o
else
LDLIBS+=-lnatpmp
--
2.46.0

25 changes: 10 additions & 15 deletions net/zerotier/patches/0002-remove-PIE-options.patch
Original file line number Diff line number Diff line change
@@ -1,24 +1,16 @@
From c10b5ed4c6c44e36178b0a5a82da9e8eaa957008 Mon Sep 17 00:00:00 2001
From 81a632c99b581790344729ad327eb473c4c05260 Mon Sep 17 00:00:00 2001
From: Moritz Warning <moritzwarning@web.de>
Date: Mon, 6 May 2024 22:34:15 +0200
Date: Tue, 17 Sep 2024 15:36:36 +0200
Subject: [PATCH 2/5] remove PIE options

Signed-off-by: Moritz Warning <moritzwarning@web.de>
---
make-linux.mk | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
make-linux.mk | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/make-linux.mk b/make-linux.mk
index d2e1714f..2551514d 100644
--- a/make-linux.mk
+++ b/make-linux.mk
@@ -71,7 +71,7 @@ else
override CFLAGS+=-Wall -Wno-deprecated -pthread $(INCLUDES) -DNDEBUG $(DEFS)
CXXFLAGS?=-O3 -fstack-protector
override CXXFLAGS+=-Wall -Wno-deprecated -std=c++17 -pthread $(INCLUDES) -DNDEBUG $(DEFS)
- LDFLAGS=-pie -Wl,-z,relro,-z,now
+ LDFLAGS=-Wl,-z,relro,-z,now
ZT_CARGO_FLAGS=--release
endif

@@ -333,7 +333,7 @@ ifeq ($(ZT_CONTROLLER),1)
endif

Expand All @@ -38,4 +30,7 @@ Signed-off-by: Moritz Warning <moritzwarning@web.de>
+#override CXXFLAGS+=-fPIC -fPIE

# Non-executable stack
override ASFLAGS+=--noexecstack
override LDFLAGS+=-Wl,-z,noexecstack
--
2.46.0

Original file line number Diff line number Diff line change
@@ -1,15 +1,14 @@
From fee674d5a5c7cc847d7e1925ddf41eea89d915c4 Mon Sep 17 00:00:00 2001
From 71ed5b791fb0f7bfe1f564726fdc979b71313fbe Mon Sep 17 00:00:00 2001
From: Moritz Warning <moritzwarning@web.de>
Date: Mon, 4 Jul 2022 00:10:52 +0200
Subject: [PATCH 3/5] fix compilation for arm_cortex-a7+neon
Date: Tue, 17 Sep 2024 15:38:01 +0200
Subject: [PATCH 3/5] fix compilation for arm_cortex a7 neon

Fixes "error: 'vrbitq_u8' was not declared in this scope"

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
node/Constants.hpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/node/Constants.hpp b/node/Constants.hpp
index 95f093b3..07c04ccc 100644
--- a/node/Constants.hpp
+++ b/node/Constants.hpp
@@ -123,7 +123,7 @@
Expand All @@ -21,3 +20,6 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
#if (defined(__APPLE__) && !defined(__LP64__)) || (defined(__ANDROID__) && defined(__arm__))
#ifdef ZT_ARCH_ARM_HAS_NEON
#undef ZT_ARCH_ARM_HAS_NEON
--
2.46.0

10 changes: 7 additions & 3 deletions net/zerotier/patches/0004-add-missing-libatomic.patch
Original file line number Diff line number Diff line change
@@ -1,13 +1,14 @@
From f8b4c4a045a9711c316a5c48b238c24cc0948da1 Mon Sep 17 00:00:00 2001
From d6197554b3f52ee9d8d81374141aa82014b4fc7b Mon Sep 17 00:00:00 2001
From: Moritz Warning <moritzwarning@web.de>
Date: Mon, 6 May 2024 22:35:41 +0200
Date: Tue, 17 Sep 2024 15:38:34 +0200
Subject: [PATCH 4/5] add missing libatomic

Signed-off-by: Moritz Warning <moritzwarning@web.de>
---
make-linux.mk | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/make-linux.mk b/make-linux.mk
index 2551514d..aa10721d 100644
--- a/make-linux.mk
+++ b/make-linux.mk
@@ -11,7 +11,7 @@ endif
Expand All @@ -19,3 +20,6 @@ Signed-off-by: Moritz Warning <moritzwarning@web.de>
DESTDIR?=
EXTRA_DEPS?=

--
2.46.0

14 changes: 9 additions & 5 deletions net/zerotier/patches/0005-remove-noexecstack.patch
Original file line number Diff line number Diff line change
@@ -1,21 +1,25 @@
From 2a5a279ac0192bc444cd1c3059169f576817d8b9 Mon Sep 17 00:00:00 2001
From 8e89af98ac00b1c9c019865faca7479fa0de6084 Mon Sep 17 00:00:00 2001
From: Moritz Warning <moritzwarning@web.de>
Date: Mon, 28 Aug 2023 09:48:28 +0200
Date: Tue, 17 Sep 2024 21:26:08 +0200
Subject: [PATCH 5/5] remove noexecstack

The compilers for arm_cortex-a9 do not recognize this argument.
---
make-linux.mk | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/make-linux.mk b/make-linux.mk
index aa10721d..680324f4 100644
--- a/make-linux.mk
+++ b/make-linux.mk
@@ -364,7 +364,7 @@ endif
#override CXXFLAGS+=-fPIC -fPIE

# Non-executable stack
-override ASFLAGS+=--noexecstack
+# override ASFLAGS+=--noexecstack
-override LDFLAGS+=-Wl,-z,noexecstack
+#override LDFLAGS+=-Wl,-z,noexecstack

.PHONY: all
all: one
--
2.46.0

0 comments on commit e459525

Please sign in to comment.