-
Notifications
You must be signed in to change notification settings - Fork 3.5k
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
(LoRa) Basicstation is an implementation of a LoRa packet forwarder and is intended to be run on the host of a LoRa-based gateway. Basicstation forwards RF packets recieved by a concentrator to a LoRaWAN network server (LNS). It also transmits RF packets received from the LNS to one or multiple LoRa end devices. Further information: https://lora-developers.semtech.com/build/ software/lora-basics/lora-basics-for-gateways Signed-off-by: Marcus Schref <mschref@web.de>
- Loading branch information
Showing
5 changed files
with
563 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,67 @@ | ||
# | ||
# Copyright (C) 2022 TDT AG <development@tdt.de> | ||
# | ||
# This is free software, licensed under the GNU General Public License v2. | ||
# See /LICENSE for more information. | ||
# | ||
# | ||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=basicstation | ||
PKG_VERSION:=2.0.6 | ||
PKG_RELEASE:=1 | ||
|
||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz | ||
PKG_SOURCE_PROTO:=git | ||
PKG_SOURCE_URL:=https://github.com/lorabasics/basicstation | ||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) | ||
PKG_SOURCE_VERSION:=ba4f85d80a438a5c2b659e568cd2d0f0de08e5a7 | ||
PKG_SOURCE_DATE:=2022-01-18 | ||
PKG_MIRROR_HASH:=d42ed480740d6cf9db0ed072626978fe88df5b42d9e19dbc447d83ff801b4d46 | ||
|
||
PKG_MAINTAINER:= Marcus Schref <mschref@tdt.de> | ||
|
||
PKG_LICENSE:=BSD-3-Clause | ||
PKG_LICENSE_FILES:=LICENSE | ||
|
||
PKG_BUILD_DEPENDS:=sx1302_hal | ||
PKG_BUILD_DEPENDS+=mbedtls | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
include $(INCLUDE_DIR)/cmake.mk | ||
|
||
define Package/basicstation | ||
SECTION:=net | ||
CATEGORY:=Network | ||
SUBMENU:=LoRaWAN | ||
TITLE:=LoRa Basic Station | ||
DEPENDS:=+kmod-usb-acm | ||
DEPENDS+=@!arc | ||
endef | ||
|
||
define Package/basicstation/description | ||
LoRa Basic Station. The LoRaWAN Gateway Software. | ||
endef | ||
|
||
define Package/basicstation/conffiles | ||
/etc/config/basicstation | ||
endef | ||
|
||
define Build/Prepare | ||
$(call Build/Prepare/Default) | ||
rm -rf $(PKG_BUILD_DIR)/deps/ | ||
rm -f $(PKG_BUILD_DIR)/makefile | ||
rm -f $(PKG_BUILD_DIR)/makefile.s2core | ||
rm -f $(PKG_BUILD_DIR)/setup.gmk | ||
endef | ||
|
||
define Package/basicstation/install | ||
$(INSTALL_DIR) $(1)/usr/bin | ||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/station $(1)/usr/bin | ||
$(INSTALL_DIR) $(1)/etc/config | ||
$(INSTALL_BIN) ./files/etc/config/basicstation $(1)/etc/config/basicstation | ||
$(INSTALL_DIR) $(1)/etc/init.d | ||
$(INSTALL_BIN) ./files/etc/init.d/basicstation $(1)/etc/init.d/basicstation | ||
endef | ||
|
||
$(eval $(call BuildPackage,basicstation)) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,146 @@ | ||
config auth 'auth' | ||
option cred '' | ||
option mode '' | ||
option addr '' | ||
option port '' | ||
option token '' | ||
option key '' | ||
option crt '' | ||
option trust '' | ||
|
||
config sx130x 'sx130x' | ||
option comif '' | ||
option devpath '' | ||
option pps '' | ||
option public '' | ||
option clksrc '' | ||
option radio0 '' | ||
option radio1 '' | ||
|
||
config rfconf 'rfconf0' | ||
option type 'SX1250' | ||
option txEnable '1' | ||
option freq '' | ||
option antennaGain '3' | ||
option rssiOffset '-215.4' | ||
option useRssiTcomp 'std' | ||
|
||
config rfconf 'rfconf1' | ||
option type 'SX1250' | ||
option txEnable '0' | ||
option freq '' | ||
option antennaGain '3' | ||
option rssiOffset '-215.4' | ||
option useRssiTcomp 'std' | ||
|
||
config rssitcomp 'std' | ||
option coeff_a '0' | ||
option coeff_b '0' | ||
option coeff_c '20.41' | ||
option coeff_d '2162.56' | ||
option coeff_e '0' | ||
|
||
config txlut | ||
option rfPower '12' | ||
option paGain '0' | ||
option pwrIdx '15' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '13' | ||
option paGain '0' | ||
option pwrIdx '16' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '14' | ||
option paGain '0' | ||
option pwrIdx '17' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '15' | ||
option paGain '0' | ||
option pwrIdx '19' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '16' | ||
option paGain '0' | ||
option pwrIdx '20' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '17' | ||
option paGain '0' | ||
option pwrIdx '22' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '18' | ||
option paGain '1' | ||
option pwrIdx '1' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '19' | ||
option paGain '1' | ||
option pwrIdx '2' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '20' | ||
option paGain '1' | ||
option pwrIdx '3' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '21' | ||
option paGain '1' | ||
option pwrIdx '4' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '22' | ||
option paGain '1' | ||
option pwrIdx '5' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '23' | ||
option paGain '1' | ||
option pwrIdx '6' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '24' | ||
option paGain '1' | ||
option pwrIdx '7' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '25' | ||
option paGain '1' | ||
option pwrIdx '9' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '26' | ||
option paGain '1' | ||
option pwrIdx '11' | ||
list usedBy 'rfconf0' | ||
|
||
config txlut | ||
option rfPower '27' | ||
option paGain '1' | ||
option pwrIdx '14' | ||
list usedBy 'rfconf0' | ||
|
||
config station 'station' | ||
option idGenIf '' | ||
option routerid '' | ||
option stationid '' | ||
option logFile '' | ||
option logLevel '' | ||
option logSize '' | ||
option logRotate '' |
Oops, something went wrong.