-
Notifications
You must be signed in to change notification settings - Fork 139
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
feat: add support for jetson orin nx
- Loading branch information
Showing
3 changed files
with
238 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,19 @@ | ||
header: | ||
version: 14 | ||
includes: | ||
- kas/include/mender-full.yml | ||
- kas/include/tegra-jetpack6.yml | ||
|
||
machine: p3768-0000-p3767-0000 | ||
|
||
local_conf_header: | ||
AB-upgrades: | | ||
UBOOT_EXTLINUX = "1" | ||
USE_REDUNDANT_FLASH_LAYOUT_DEFAULT = "1" | ||
eMMC: | | ||
# equivalent: EMMC_SIZE = "32 * 1024 * 1024 * 1024" | ||
EMMC_SIZE = "34359738368" | ||
# Not needed with the custom partition layout | ||
MENDER_FEATURES_DISABLE:append = " mender-growfs-data" | ||
MENDER_DATA_PART_NUMBER = "17" | ||
MENDER_STORAGE_DEVICE = "/dev/nvme0n1" |
212 changes: 212 additions & 0 deletions
212
...r-tegra/recipes-bsp/tegra-binaries/tegra-storage-layout/flash_l4t_t234_nvme_rootfs_ab.xml
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,212 @@ | ||
<?xml version="1.0"?> | ||
|
||
<!-- | ||
# SPDX-FileCopyrightText: Copyright (c) 2023-2024 NVIDIA CORPORATION & AFFILIATES. | ||
# All rights reserved. | ||
# SPDX-License-Identifier: LicenseRef-NvidiaProprietary | ||
# | ||
# NVIDIA CORPORATION, its affiliates and licensors retain all intellectual | ||
# property and proprietary rights in and to this material, related | ||
# documentation and any modifications thereto. Any use, reproduction, | ||
# disclosure or distribution of this material and related documentation | ||
# without an express license agreement from NVIDIA CORPORATION or | ||
# its affiliates is strictly prohibited. | ||
--> | ||
|
||
<!-- Nvidia Tegra Partition Layout Version 1.0.0 --> | ||
<partition_layout version="01.00.0000"> | ||
<device type="external" instance="0" sector_size="512" num_sectors="EXT_NUM_SECTORS" > | ||
<partition name="master_boot_record" type="protective_master_boot_record"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 512 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
</partition> | ||
<partition name="primary_gpt" type="primary_gpt"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 19968 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
</partition> | ||
<partition name="A_kernel" id="3" type="kernel"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 134217728 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
<filename> LNXFILE </filename> | ||
</partition> | ||
<partition name="A_kernel-dtb" type="kernel_dtb"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 786432 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
<filename> DTB_FILE </filename> | ||
</partition> | ||
<partition name="A_reserved_on_user" type="data"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 33161216 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
</partition> | ||
<partition name="B_kernel" type="kernel"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 134217728 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
<filename> LNXFILE_b </filename> | ||
</partition> | ||
<partition name="B_kernel-dtb" type="kernel_dtb"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 786432 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
<filename> DTB_FILE </filename> | ||
</partition> | ||
<partition name="B_reserved_on_user" type="data"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 33161216 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
</partition> | ||
<partition name="RECNAME" type="kernel"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> RECSIZE </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
<filename> RECFILE </filename> | ||
</partition> | ||
<partition name="RECDTB-NAME" type="kernel_dtb"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 524288 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
<filename> RECDTB-FILE </filename> | ||
</partition> | ||
<partition name="esp" type="data"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 67108864 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 0x8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
<filename> ESP_FILE </filename> | ||
<partition_type_guid> C12A7328-F81F-11D2-BA4B-00A0C93EC93B </partition_type_guid> | ||
<description> **Required.** EFI system partition with L4T Launcher. </description> | ||
</partition> | ||
<partition name="RECNAME_alt" type="kernel"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> RECSIZE </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
</partition> | ||
<partition name="RECDTB-NAME_alt" type="kernel_dtb"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 524288 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
</partition> | ||
<partition name="esp_alt" type="data"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 67108864 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 0x8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
<description> **Required.** EFI system partition for fail-safe ESP update. </description> | ||
</partition> | ||
<partition name="UDA" type="data"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 419430400 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
<align_boundary> 16384 </align_boundary> | ||
<description> **Required.** This partition may be mounted and used to store user | ||
data. </description> | ||
</partition> | ||
<partition name="reserved" type="data"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 502792192 </size> <!-- Recalculate the size if RECSIZE changed --> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
<description> **Required.** Reserve space in case there is any partition change | ||
required in the future, for example, adding new partitions or increasing size | ||
of some partitions. </description> | ||
</partition> | ||
<partition name="APP" id="1" type="data"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> APPSIZE </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 0x8 </allocation_attribute> | ||
<align_boundary> 16384 </align_boundary> | ||
<percent_reserved> 0 </percent_reserved> | ||
<unique_guid> APPUUID </unique_guid> | ||
<filename> APPFILE </filename> | ||
<description> **Required.** Contains the rootfs. This partition must be assigned | ||
the "1" for id as it is physically put to the end of the device, so that it | ||
can be accessed as the fixed known special device `/dev/nvme0n1p1`. </description> | ||
</partition> | ||
<partition name="APP_b" id="2" type="data"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> APPSIZE </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 0x8 </allocation_attribute> | ||
<align_boundary> 16384 </align_boundary> | ||
<percent_reserved> 0 </percent_reserved> | ||
<unique_guid> APPUUID_b </unique_guid> | ||
<filename> APPFILE_b </filename> | ||
<description> **Required.** Contains the rootfs. This partition must be assigned | ||
the "2" for id as it is physically put to the end of the device, so that it | ||
can be accessed as the fixed known special device `/dev/nvme0n1p2`. </description> | ||
</partition> | ||
<partition name="permanet_user_storage" id= "17" type="data"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 419430400 </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 0x808 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
<align_boundary> 16384 </align_boundary> | ||
<filename> DATAFILE </filename> | ||
<description> **Required.** This partition is used to store permanent user | ||
and device data between A/B updates</description> | ||
</partition> | ||
<partition name="secondary_gpt" type="secondary_gpt"> | ||
<allocation_policy> sequential </allocation_policy> | ||
<filesystem_type> basic </filesystem_type> | ||
<size> 0xFFFFFFFFFFFFFFFF </size> | ||
<file_system_attribute> 0 </file_system_attribute> | ||
<allocation_attribute> 8 </allocation_attribute> | ||
<percent_reserved> 0 </percent_reserved> | ||
</partition> | ||
</device> | ||
</partition_layout> |
7 changes: 7 additions & 0 deletions
7
meta-mender-tegra/recipes-bsp/tegra-binaries/tegra-storage-layout_%.bbappend
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | ||
|
||
SRC_URI:append = " \ | ||
file://flash_l4t_t234_nvme_rootfs_ab.xml \ | ||
" | ||
|
||
PARTITION_FILE_EXTERNAL = "${WORKDIR}/flash_l4t_t234_nvme_rootfs_ab.xml" |