- Declare all Folders and devices in one file
- Peers are automagically configured
- Use a default path
- Overwrite paths for one peer
- sensible defaults
As of now the services.syncthing module can NOT be configured to use files to store your ids
This is a security flaw, as your globally unique Identifier used to add your device is stored wordreadable in the nix store. I am planning to fix this at some point. For now the only solution is to disable autoAccept for devices to at least stop someone from getting hold of your data.
On my personal dotfiles I am using a pre-commit hook to make sure I don't commit this file by accident
You can easily set other options directly by using services.syncthing
You can take a look at my dotfiles or more specifically at my base.nix
This Code is far from perfect...
This flake arose because I wanted to share parts of my config to friends, as well as the world.
If you want to contribute just open a PR or Issue and make sure to run nixfmt before you submit your code.