-
Notifications
You must be signed in to change notification settings - Fork 127
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sci-misc/llama-cpp: support OpenBLAS or BLIS backends
A significant speed up in some workflows when running on a CPU Signed-off-by: Alexey Korepanov <kaikaikai@yandex.ru>
- Loading branch information
Showing
4 changed files
with
64 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
cmake does not properly configure linking against OpenBLAS or BLIS | ||
https://github.com/ggerganov/llama.cpp/pull/11741 | ||
|
||
diff --git a/ggml/src/ggml-blas/CMakeLists.txt b/ggml/src/ggml-blas/CMakeLists.txt | ||
index 0bf3c05d93a89..117416b988665 100644 | ||
--- a/ggml/src/ggml-blas/CMakeLists.txt | ||
+++ b/ggml/src/ggml-blas/CMakeLists.txt | ||
@@ -54,6 +54,8 @@ if (BLAS_FOUND) | ||
endif() | ||
if (DepBLAS_FOUND) | ||
set(BLAS_INCLUDE_DIRS ${DepBLAS_INCLUDE_DIRS}) | ||
+ set(BLAS_LIBRARIES ${DepBLAS_LIBRARIES}) | ||
+ set(BLAS_LINKER_FLAGS ${DepBLAS_LINKER_FLAGS}) | ||
else() | ||
message(WARNING "BLAS_INCLUDE_DIRS neither been provided nor been automatically" | ||
" detected by pkgconfig, trying to find cblas.h from possible paths...") |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters