Skip to content

Commit

Permalink
pypi-pillow: Autospec creation for update from version 9.2.0 to versi…
Browse files Browse the repository at this point in the history
…on 9.3.0

Alexander Piskun (2):
      fixing xmp tag orientation generated by exiftool
      fixing typo in filetest name

Andrew Murray (197):
      Updated codecov action to v3
      Document where to find other codecs
      Fallback to python3
      Fixed typo
      Update CHANGES.rst [ci skip]
      Updated macOS tested Pillow versions [ci skip]
      Updated redirected URL
      Updated link for more information about SPIDER
      Fixed PSDraw rectangle
      Corrected CHANGES.rst [ci skip]
      Changed second rectangle parameter to distance from bottom
      Simplified rectangle command
      Raise ValueError if PNG sRGB chunk is truncated
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Reordered SUPPORTED to match MASK_MODES
      Added ABGR MASK_MODE
      Install libxcb-shape0
      Updated libwebp to 1.2.3
      Update CHANGES.rst [ci skip]
      Support saving multiple MPO frames
      Fixed set_variation_by_name offset
      Do not quote Pillow version for setuptools >= 60
      Restored unimplemented DXGI format test
      Added release notes
      Update CHANGES.rst [ci skip]
      Updated libimagequant to 4.0.1
      Do not clear tile if not updating the image when seeking
      Moved code into separate function
      Rename format to BC6H and BC6HS
      Simplified code
      Switch to GitHub Actions artifacts for Windows wheels
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Simplified code
      Sorted formats by n
      Simplified test code
      Check that orientation is still absent after reloading Exif
      Update CHANGES.rst [ci skip]
      Added release notes for #6457
      Update CHANGES.rst [ci skip]
      Updated harfbuzz to 5.1.0
      Save 1 mode PDF using CCITTFaxDecode filter
      Added strip_size as TIFF encoder argument
      Updated Valgrind job to Jammy
      Document that orientation data is removed by exif_transpose()
      Document that exif_transpose() does not change orientations of 1
      Increased tolerance to allow for libtiff with libjpeg-turbo
      Added support for RGBA PSD images
      Updated libwebp to 1.2.4
      Changed "font" to class variable
      Note to Windows users that FreeType will keep the font file open
      Document workaround
      Update CHANGES.rst [ci skip]
      Added documentation
      Fixed writing bytes as ASCII tag
      Updated libjpeg-turbo to 2.1.4
      Open 1 bit EPS in mode 1
      Corrected palette size when saving
      Simplified code
      Do not install test-image-results on GitHub Actions
      Allow RGB and RGBA values for PA image putpixel
      Fixed formatting
      Added pa2p
      Copy palette when converting from P to PA
      Update CHANGES.rst [ci skip]
      Fallback to not using mmap if buffer is not large enough
      Ubuntu dependencies also apply to Jammy [ci skip]
      Round box position to integer when pasting embedded color
      Do not use CCITTFaxDecode filter if libtiff is not available
      Updated libimagequant to 4.0.2
      Temporarily skip valgrind failure
      Parametrize tests
      Renamed argument
      Qt4 is no longer supported
      Further parametrizations
      Build lcms2 VC2022
      Added test
      Round position in pad()
      Updated libimagequant to 4.0.4
      NumPy now supports Python 3.11
      Do not call load() before draft()
      Set top-level permissions for remaining GitHub Actions
      Replaced Codecov bash uploader with GitHub Action
      Fixed typo
      Removed requirement for 256 palette entries
      Documented TGA keyword arguments when saving
      Fixed remapping to palette with duplicate entries
      Simplified code
      Removed support for Python before interpaddr()
      Update CHANGES.rst [ci skip]
      Updated environment list [ci skip]
      Update CHANGES.rst [ci skip]
      Use constants
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Improved documentation of return values
      Simplified enum references
      Updated return values to match ImageFont
      Added examples for updating code
      Apply transparency to P images before passing to tkinter.PhotoImage
      Use target
      Rearranged text
      Rearranged text
      Added renovate.json to MANIFEST
      Defer parsing of palette into colors
      Added reading of TIFF child images
      Parametrized test
      Update CHANGES.rst [ci skip]
      Fixed pasting an L frame onto an RGB(A) GIF
      Corrected BMP palette size when saving
      Pad IM palette to 768 bytes when saving
      Removed EXIF prefix when saving
      Update CHANGES.rst [ci skip]
      Updated harfbuzz to 5.2.0
      If first frame has transparency for RGB_ALWAYS, use RGBA
      Corrected dictionary name
      Raise a warning if NumPy will not raise an error during conversion
      Removed unnecessary palette copy
      Use getpalette() in ImageOps
      Copy palette in expand() for PA
      Update CHANGES.rst [ci skip]
      Updated Ghostscript to 10.0.0
      Consider all frames when selecting mode for PNG save_all
      Show all frames in ImageShow
      Ensure dependencies are installed when building docs
      Updated redirected URLs
      Replaced Codecov bash uploader with GitHub Action
      Install dependencies always, but quietly
      Moved olefile install to docs Makefile
      Removed broken URL
      Corrected broken URLs
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Added IMT tests
      Only read a maximum of 100 bytes at a time
      Allow palette chunk to not be first
      Corrected docstring
      Added enums
      Added headings before listing options
      Document the default layout engine
      Document that basic layout is faster than raqm
      Update CHANGES.rst [ci skip]
      Removed duplicate test
      Parametrized tests
      Enabled test
      Do not import PIL.Image
      High bit depth multichannel images are not yet supported
      Changed mode to I;16
      If palette is present but not needed, do not use global palette
      Do not attempt normalization if image is already normal
      Added conversion between RGB/RGBA/RGBX and LAB
      Updated BC6H test images
      Updated harfbuzz to 5.3.0
      Moved mode check outside of loops
      Recommend raqm for non-English text
      Corrected test
      Updated error message
      Update CHANGES.rst [ci skip]
      Removed gamma correction
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Removed print statement
      Added GPS tags
      Image channel is used when converting PA with an RGBA palette
      Updated zlib to 1.2.13
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Added release notes for #6449 [ci skip]
      Added release notes for #6611 [ci skip]
      Updated harfbuzz to 5.3.1
      Corrected BMP compression setting [ci skip]
      Combined BMP RLE decoders
      Removed blank line
      Write in binary format
      Decode JPEG compressed BLP1 data in original mode
      Update CHANGES.rst [ci skip]
      Added release notes for #6678
      Only use existing test image
      Moved comment back [ci skip]
      Update CHANGES.rst [ci skip]
      Note when the security issue was introduced
      Do not modify previous frame when calculating delta
      Update CHANGES.rst [ci skip]
      Added release notes for #6630
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Update CHANGES.rst [ci skip]
      Initialize libtiff buffer
      Revert "Temporarily skip valgrind failure"
      Added release notes

Bibin Hashley (1):
      ImageOps.contain function finding new size issue

Christoph Gohlke (4):
      DOC: fix image-file-formats.rst
      Fix malloc in _imagingft.c:font_setvaraxes
      Only use ASCII characters in C source file
      Remove backup implementation of Round for Windows platforms

David Walker (1):
      Improve documentation for ImageDraw.rectangle and rounded_rectangle

Eric Soroos (3):
      Don't reassign crc on close
      Prevent DOS with large SAMPLESPERPIXEL in Tiff IFD
      Tighter test case

Hugo van Kemenade (24):
      9.3.0.dev0 version bump
      Replace version tables with RST csv-table
      Add Python 3.11 for Pillow >= 9.3
      Rebalance version tables
      Add support for Python 3.11
      Docs: Allow setting Python interpreter via command line
      Omit ":widths: auto"
      Add label to Dependabot PRs
      Group GHA updates into a single PR
      Create update PRs on the first day of the month
      Avoid release days to keep the CI free
      Move some static config to setup.cfg
      Add OpenSSF Best Practices badge
      Fix Renovate config
      Fix Renovate config
      Test Python 3.11.0 final
      Update release notes for 9.3.0
      Double quotes for old CPython on Windows
      Document 3.11 wheels in 9.3.0 release notes
      Hide UserWarning in logs
      Fix linting
      Add to release notes
      9.3.0 version bump
      Update CHANGES.rst [ci skip]

Jay-Jay Aslan (1):
      added support for 16 bit integer tiffs

João S. O. Bueno (1):
      Fix #6652: Handle translucent color used in RGB ImagePallete

Mark Harfouche (1):
      Release the GIL when applying matrix conversion to images

Mark Mayo (1):
      some pylint warnings

Nathanael Gentry (4):
      BMP: Add 4-bit RLE decoder
      Add tests for 4-bit RLE decoder
      Update documentation for 4-bit RLE decoder
      Revert unintentional change

Ondrej Baranovič (2):
      simplify code, make test more generic
      Use pytest.param for consistency

REDxEYE (4):
      Fix BC6H_SF decoding error.
      Add support for ATI1/2(BC4/BC5) DDS files
      Add test and test files for ATI1 pixel format and fix image mode for ATI1
      Replace test files with images with compatible license

Santiago Castro (1):
      Fix when `sys.executable` is empty or null

ShadelessFox (6):
      Fix BC6 block decoder
      Fix BC6H_SF decoder
      Add BC6 tests
      Code cleanup
      Rename remaining occurrences of BC6S -> BC6HS
      Minimize unnecessary code changes

Sitcebelly (2):
      Put palette into the new pad image
      fix bug

Tim Gates (1):
      docs: fix simple typo, unpredicatable -> unpredictable

Yay295 (11):
      parametrize Tests/test_image_paste.py
      make @pytest.mark.parametrize annotations one line
      parametrize tests
      parametrize tests
      parametrize tests
      remove unused asserts
      parametrize test_rankfilter_error()
      remove unused variable
      Apply suggestions from code review
      Apply suggestions from code review
      add "concurrency" to GitHub actions so that old workflows are cancelled in favor of new runs

neilnaveen (1):
      chore: Set permissions for GitHub actions

nulano (19):
      inline fname2char to fix #6319
      add decref calls to imagingft to fix #6321
      upload fribidi.dll to GHA
      Document ImageDraw attributes
      convert TestImageFont and TestImageFont_RaqmLayout into a test fixture
      Removed support for PyPy before Python 3.6
      append dependency licenses to windows wheels on GHA
      test libtiff with lzma
      compile libtiff with liblzma on windows
      libopenjpeg has no dependencies, skip searching for dependencies of openjpeg binaries on windows
      test libtiff with webp compression
      compile libtiff with webp on windows
      skip libtiif webp test when libtiff is too old
      restore py_vcruntime_redist
      add recommended build flag for webp set to the default value
      add test using woff2 font with freetype
      build brotli on Windows
      windows: update xz to 5.2.7, update libpng to 1.6.38
      GHA: use GITHUB_OUTPUT instead of deprecated set-output

pre-commit-ci[bot] (9):
      [pre-commit.ci] pre-commit autoupdate
      [pre-commit.ci] auto fixes from pre-commit.com hooks
      [pre-commit.ci] auto fixes from pre-commit.com hooks
      [pre-commit.ci] pre-commit autoupdate
      [pre-commit.ci] auto fixes from pre-commit.com hooks
      [pre-commit.ci] auto fixes from pre-commit.com hooks
      [pre-commit.ci] pre-commit autoupdate
      [pre-commit.ci] auto fixes from pre-commit.com hooks
      [pre-commit.ci] auto fixes from pre-commit.com hooks

renovate[bot] (2):
      Add renovate.json
      Update github-actions
  • Loading branch information
fenrus75 committed Oct 31, 2022
1 parent e305f56 commit 8f4a1c2
Show file tree
Hide file tree
Showing 6 changed files with 19 additions and 19 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-pillow
URL = https://files.pythonhosted.org/packages/8c/92/2975b464d9926dc667020ed1abfa6276e68c3571dcb77e43347e15ee9eed/Pillow-9.2.0.tar.gz
URL = https://files.pythonhosted.org/packages/16/11/da8d395299ca166aa56d9436e26fe8440e5443471de16ccd9a1d06f5993a/Pillow-9.3.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
4 changes: 3 additions & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-pillow
url = https://files.pythonhosted.org/packages/8c/92/2975b464d9926dc667020ed1abfa6276e68c3571dcb77e43347e15ee9eed/Pillow-9.2.0.tar.gz
url = https://files.pythonhosted.org/packages/16/11/da8d395299ca166aa56d9436e26fe8440e5443471de16ccd9a1d06f5993a/Pillow-9.3.0.tar.gz
archives =
giturl = https://github.com/python-pillow/Pillow.git
domain =
Expand Down Expand Up @@ -35,6 +35,8 @@ insecure_build = false
keepstatic = false
# do not require autostart subpackage
no_autostart = false
# do not use the replacement pattern for file matching
no_glob = false
# do not generate debuginfo for this package
nodebug = false
# disable stripping binaries
Expand Down
26 changes: 12 additions & 14 deletions pypi-pillow.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,13 +3,13 @@
# Generated by: autospec.py
#
Name : pypi-pillow
Version : 9.2.0
Release : 100
URL : https://files.pythonhosted.org/packages/8c/92/2975b464d9926dc667020ed1abfa6276e68c3571dcb77e43347e15ee9eed/Pillow-9.2.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/8c/92/2975b464d9926dc667020ed1abfa6276e68c3571dcb77e43347e15ee9eed/Pillow-9.2.0.tar.gz
Version : 9.3.0
Release : 101
URL : https://files.pythonhosted.org/packages/16/11/da8d395299ca166aa56d9436e26fe8440e5443471de16ccd9a1d06f5993a/Pillow-9.3.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/16/11/da8d395299ca166aa56d9436e26fe8440e5443471de16ccd9a1d06f5993a/Pillow-9.3.0.tar.gz
Summary : Python Imaging Library (Fork)
Group : Development/Tools
License : Apache-2.0 HPND MIT NTP OFL-1.0
License : HPND MIT NTP OFL-1.0
Requires: pypi-pillow-filemap = %{version}-%{release}
Requires: pypi-pillow-lib = %{version}-%{release}
Requires: pypi-pillow-license = %{version}-%{release}
Expand Down Expand Up @@ -73,19 +73,19 @@ python3 components for the pypi-pillow package.


%prep
%setup -q -n Pillow-9.2.0
cd %{_builddir}/Pillow-9.2.0
%setup -q -n Pillow-9.3.0
cd %{_builddir}/Pillow-9.3.0
%patch1 -p1
pushd ..
cp -a Pillow-9.2.0 buildavx2
cp -a Pillow-9.3.0 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1657036615
export SOURCE_DATE_EPOCH=1667227768
export GCC_IGNORE_WERROR=1
export CFLAGS="$CFLAGS -fno-lto "
export FCFLAGS="$FFLAGS -fno-lto "
Expand All @@ -107,10 +107,9 @@ popd
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-pillow
cp %{_builddir}/Pillow-9.2.0/Tests/fonts/DejaVuSans/LICENSE.txt %{buildroot}/usr/share/package-licenses/pypi-pillow/3d95e2c3b731545390f6888a3214cf7b51fb7971
cp %{_builddir}/Pillow-9.2.0/Tests/fonts/LICENSE.txt %{buildroot}/usr/share/package-licenses/pypi-pillow/9deb27f8f5fea69a2ab1624ed0698a0c8168ed49
cp %{_builddir}/Pillow-9.2.0/Tests/icc/LICENSE.txt %{buildroot}/usr/share/package-licenses/pypi-pillow/371117588643c602bb8f15b280424e938c34c369
cp %{_builddir}/Pillow-9.2.0/src/thirdparty/raqm/COPYING %{buildroot}/usr/share/package-licenses/pypi-pillow/0e373369e12062eb1d6f4f3df0c41086f8320eb3
cp %{_builddir}/Pillow-%{version}/Tests/fonts/DejaVuSans/LICENSE.txt %{buildroot}/usr/share/package-licenses/pypi-pillow/3d95e2c3b731545390f6888a3214cf7b51fb7971 || :
cp %{_builddir}/Pillow-%{version}/Tests/icc/LICENSE.txt %{buildroot}/usr/share/package-licenses/pypi-pillow/371117588643c602bb8f15b280424e938c34c369 || :
cp %{_builddir}/Pillow-%{version}/src/thirdparty/raqm/COPYING %{buildroot}/usr/share/package-licenses/pypi-pillow/0e373369e12062eb1d6f4f3df0c41086f8320eb3 || :
python3 -tt setup.py build install --root=%{buildroot}
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
Expand Down Expand Up @@ -141,7 +140,6 @@ popd
/usr/share/package-licenses/pypi-pillow/0e373369e12062eb1d6f4f3df0c41086f8320eb3
/usr/share/package-licenses/pypi-pillow/371117588643c602bb8f15b280424e938c34c369
/usr/share/package-licenses/pypi-pillow/3d95e2c3b731545390f6888a3214cf7b51fb7971
/usr/share/package-licenses/pypi-pillow/9deb27f8f5fea69a2ab1624ed0698a0c8168ed49

%files python
%defattr(-,root,root,-)
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
100
101
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
775213ef5adf5a726a801d82d62e3f3ae72eb0ba/Pillow-9.2.0.tar.gz
08d654ff4196687969771cc67d1e391838ec1303/Pillow-9.3.0.tar.gz
2 changes: 1 addition & 1 deletion versions
Original file line number Diff line number Diff line change
@@ -1 +1 @@
9.2.0
9.3.0

0 comments on commit 8f4a1c2

Please sign in to comment.