Skip to content

Commit

Permalink
pypi-importlib_resources: Autospec creation for update from version 6…
Browse files Browse the repository at this point in the history
….1.1 to version 6.1.2

Bartosz Sławecki (1):
      Tweak coverage configuration for type checking (jaraco/skeleton#97)

Christian Clauss (2):
      Upgrade GitHub Actions checkout (jaraco/skeleton#94)
      GitHub Actions: Combine tox jobs diffcov and docs (jaraco/skeleton#95)

Dimitri Papadopoulos Orfanos (2):
      Use the ruff formatter (jaraco/skeleton#99)
      ruff: extended-ignore → ignore (jaraco/skeleton#105)

Jason R. Coombs (32):
      Remove news fragment after allowing time to be processed downstream.
      Suppress deprecation warning in dateutil. Workaround for dateutil/dateutil#1284.
      Update Github Actions badge per actions/starter-workflows#1525.
      Separate collateral jobs on different lines for easier override/extension.
      Update test_custom_loader to correctly return a Traversable (pathlib.Path) and adjust the assertions to only expect a Traversable.
      Remove skip as typing now has runtime_checkable unconditionally.
      Add note about when to drop compatibility.
      Replace compatibility code.
      Make the assertion explicit.
      Drop minimum requirement on pytest-mypy as most environments are already running much later. Closes jaraco/skeleton#96.
      Remove sole entry for branches-ignore. Workaround for and closes jaraco/skeleton#103.
      Bump year on badge
      Remove build and dist from excludes. It appears they are not needed and their presence blocks the names of packages like 'builder' and 'distutils'. Ref pypa/distutils#224.
      Exclude docs and tests directories properly per Setuptools behavior.
      Rely on default discovery for good heuristics for finding packages.
      Enable preview to enable preserving quotes.
      Use latest versions in RTD boilerplate.
      👹 Feed the hobgoblins (delint).
      Move '_ensure_traversable' to the readers module, as it's needed downstream.
      Move compatibility and future behaviors into separate packages.
      Consolidate more shared behavior across TraversableResourceLoaders.
      Update comments to reflect refreshed purpose.
      Move reader constructors into methods.
      Use a SimpleNamespace to pass the path needed by the FileReader.
      Extract method for the standard readers.
      Remove flake8 exclusion and remove unused imports.
      👹 Feed the hobgoblins (delint).
      Change the assertions for test_join_path to assert that the subdirectory is a multiplexed path to avoid touching implementation details.
      Updated the contents of the binary files in the subdirectories so there's less chance of accidentally matching one for the other.
      Added changelog
      Use bytes ranges instead of bytes literals.
      Finalize

Sviatoslav Sydorenko (1):
      Enable testing merge queues @ GitHub Actions CI/CD (jaraco/skeleton#93)

Weicheng Zhao (1):
      Fix NotADirectory error when calling files on a submodule of a zipped namespace package
  • Loading branch information
fenrus75 committed Feb 26, 2024
1 parent 855cb17 commit 407f895
Show file tree
Hide file tree
Showing 5 changed files with 28 additions and 24 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-importlib_resources
URL = https://files.pythonhosted.org/packages/d4/06/402fb5efbe634881341ff30220798c4c5e448ca57c068108c4582c692160/importlib_resources-6.1.1.tar.gz
URL = https://files.pythonhosted.org/packages/3a/31/d36ccd01aed30f0740b3e9850ff1e6bde7680e460036376cdb6071c488ac/importlib_resources-6.1.2.tar.gz
ARCHIVES =

include ../common/Makefile.common
6 changes: 5 additions & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-importlib_resources
url = https://files.pythonhosted.org/packages/d4/06/402fb5efbe634881341ff30220798c4c5e448ca57c068108c4582c692160/importlib_resources-6.1.1.tar.gz
url = https://files.pythonhosted.org/packages/3a/31/d36ccd01aed30f0740b3e9850ff1e6bde7680e460036376cdb6071c488ac/importlib_resources-6.1.2.tar.gz
archives =
giturl = https://github.com/python/importlib_resources/
domain =
Expand All @@ -9,6 +9,8 @@ alias =
[autospec]
# build 32 bit libraries
32bit = false
# allow windows executables (*.exe, *.dll) to be packaged
allow_exe = false
# allow package to build with test failures
allow_test_failures = false
# unset %build ld_as_needed variable
Expand Down Expand Up @@ -59,6 +61,8 @@ server = false
skip_tests = false
# add .so files to the lib package instead of dev
so_to_lib = false
# configure build for apx
use_apx = false
# configure build for avx2
use_avx2 = true
# configure build for avx512
Expand Down
40 changes: 20 additions & 20 deletions pypi-importlib_resources.spec
Original file line number Diff line number Diff line change
Expand Up @@ -2,14 +2,14 @@
# This file is auto-generated. DO NOT EDIT
# Generated by: autospec.py
# Using build pattern: pyproject
# autospec version: v2
# autospec commit: 250a666
# autospec version: v4
# autospec commit: da8b975
#
Name : pypi-importlib_resources
Version : 6.1.1
Release : 37
URL : https://files.pythonhosted.org/packages/d4/06/402fb5efbe634881341ff30220798c4c5e448ca57c068108c4582c692160/importlib_resources-6.1.1.tar.gz
Source0 : https://files.pythonhosted.org/packages/d4/06/402fb5efbe634881341ff30220798c4c5e448ca57c068108c4582c692160/importlib_resources-6.1.1.tar.gz
Version : 6.1.2
Release : 38
URL : https://files.pythonhosted.org/packages/3a/31/d36ccd01aed30f0740b3e9850ff1e6bde7680e460036376cdb6071c488ac/importlib_resources-6.1.2.tar.gz
Source0 : https://files.pythonhosted.org/packages/3a/31/d36ccd01aed30f0740b3e9850ff1e6bde7680e460036376cdb6071c488ac/importlib_resources-6.1.2.tar.gz
Summary : Read resources from Python packages
Group : Development/Tools
License : Apache-2.0
Expand Down Expand Up @@ -60,18 +60,18 @@ python3 components for the pypi-importlib_resources package.


%prep
%setup -q -n importlib_resources-6.1.1
cd %{_builddir}/importlib_resources-6.1.1
%setup -q -n importlib_resources-6.1.2
cd %{_builddir}/importlib_resources-6.1.2
pushd ..
cp -a importlib_resources-6.1.1 buildavx2
cp -a importlib_resources-6.1.2 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1699374917
export SOURCE_DATE_EPOCH=1708968177
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand All @@ -89,11 +89,11 @@ LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS"
export MAKEFLAGS=%{?_smp_mflags}
python3 -m build --wheel --skip-dependency-check --no-isolation
pushd ../buildavx2/
CFLAGS="$CLEAR_INTERMEDIATE_CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
CXXFLAGS="$CLEAR_INTERMEDIATE_CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
FFLAGS="$CLEAR_INTERMEDIATE_FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
FCFLAGS="$CLEAR_INTERMEDIATE_FCFLAGS -m64 -march=x86-64-v3 "
LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS -m64 -march=x86-64-v3 "
CFLAGS="$CLEAR_INTERMEDIATE_CFLAGS -march=x86-64-v3 -Wl,-z,x86-64-v3 "
CXXFLAGS="$CLEAR_INTERMEDIATE_CXXFLAGS -march=x86-64-v3 -Wl,-z,x86-64-v3 "
FFLAGS="$CLEAR_INTERMEDIATE_FFLAGS -march=x86-64-v3 -Wl,-z,x86-64-v3 "
FCFLAGS="$CLEAR_INTERMEDIATE_FCFLAGS -march=x86-64-v3 "
LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS -march=x86-64-v3 "
python3 -m build --wheel --skip-dependency-check --no-isolation

popd
Expand Down Expand Up @@ -122,11 +122,11 @@ echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
echo ----[ mark ]----
pushd ../buildavx2/
CFLAGS="$CLEAR_INTERMEDIATE_CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
CXXFLAGS="$CLEAR_INTERMEDIATE_CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
FFLAGS="$CLEAR_INTERMEDIATE_FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
FCFLAGS="$CLEAR_INTERMEDIATE_FCFLAGS -m64 -march=x86-64-v3 "
LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS -m64 -march=x86-64-v3 "
CFLAGS="$CLEAR_INTERMEDIATE_CFLAGS -march=x86-64-v3 -Wl,-z,x86-64-v3 "
CXXFLAGS="$CLEAR_INTERMEDIATE_CXXFLAGS -march=x86-64-v3 -Wl,-z,x86-64-v3 "
FFLAGS="$CLEAR_INTERMEDIATE_FFLAGS -march=x86-64-v3 -Wl,-z,x86-64-v3 "
FCFLAGS="$CLEAR_INTERMEDIATE_FCFLAGS -march=x86-64-v3 "
LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS -march=x86-64-v3 "
python3 -m installer --destdir=%{buildroot}-v3 dist/*.whl
popd
/usr/bin/elf-move.py avx2 %{buildroot}-v3 %{buildroot} %{buildroot}/usr/share/clear/filemap/filemap-%{name}
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
37
38
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
679c7f302dc724b92f2b57b4514f3d7f7ddac348/importlib_resources-6.1.1.tar.gz
36464ce99c92ee46de725e23c6948ba7ac9d7904/importlib_resources-6.1.2.tar.gz

0 comments on commit 407f895

Please sign in to comment.