Skip to content
This repository has been archived by the owner on Oct 27, 2022. It is now read-only.

Commit

Permalink
pylint: Autospec creation for update from version 2.8.3 to version 2.9.0
Browse files Browse the repository at this point in the history
Aditya Gupta (1):
      Add ignore_signatures to similarity checker (#4474)

Andrew Haigh (6):
      Update regression tests for pylint-dev/astroid#940 (#4466)
      Add regression tests of instance attribute inference on builtins.object (#4348)
      Add regression tests of inference of implicit None return (#4428)
      Additional regression tests for pylint-dev/astroid#940 (#4473)
      Add regression tests for Enum.name and .value inference (#4558)
      Add regression test from #2306 (#4570)

David Liu (1):
      Add list literal check to using-constant-test. (#4502)

Dr. Nick (1):
      Add --fail-on option (#4227) (#4398)

DudeNr33 (6):
      Issue 4430 false positive consider-using-with R1732 (#4453)
      Consider using with no assign (#4476)
      Fix improperly formatted bullet points that span multiple lines
      Issue #3747 fix example regex for snakeCase naming style.
      Omit 'checker' in verbatim name of ``ConfusingConsecutiveElifChecker`` as it renders as "Confusing-Elif-Checker Checker"
      Issue #4541: add ``ignore-paths`` option to example pylintrc file.

Fabian Damken (1):
      Add `ignore-paths` to match against the full path. (#4516)

Jacob Walls (1):
      Fix errors in block disables paragraph in User Guide (#4489)

Konstantina Saketou (3):
      Customize arguments-differ error messages (#4422)
      Create new error arguments-renamed (#4467)
      Add test cases to unused-variable message (#4540)

Lorena B (1):
      Remove docs and code associated with the removed W0623 (redefine-in-handler) checker (#4543)

Marc Mueller (47):
      Fix too-many-ancestors
      Fix broken tests (#4450)
      Fix changelog (#4442)
      Remove type check from arguments-differ (#4456)
      Change rebase-strategy dependabot (#4462)
      Tox - update pre-commit version (#4463)
      Fix additional test case
      Fix enum no-member
      Fix tests/test_func
      Add py310 as tox env
      Add sys.version_info guard to import-error (#4468)
      Workflow improvements (#4506)
      Improve build config (#4512)
      Add regression test for no-member with generic base class (#4471)
      Fix false-positive assigning-non-slot with typing.Generic base (#4522)
      Add new checker consider-using-namedtuple (#4517)
      Add new checker invalid-all-format
      Update name for consider-using-namedtuple to include dataclass (#4536)
      Bump pyupgrade to v2.19.1 (#4547)
      Improve traceback for pytest runs
      Add regression test for Pattern Matching 3.10 (#4550)
      Clarify documentation typing extension
      Update explanation
      Add additional documenation for typing extension
      Add new checker consider-using-tuple-iterator
      Fix existing code
      Fix existing tests
      Change to consider-using-tuple
      Move to new extension CodeStyleChecker
      Revert "Fix existing tests"
      Improve documentation
      Moved typing extension tests
      Renamed code_style extension test
      Add note to CodeStyleChecker
      Move remaining extension fixtures
      Documentation
      Move consider-using-namedtuple-or-dataclass to CodeStyle extension
      Documentation
      Add exclude_lines coverage (#4566)
      Fix error with slice as subscript for dict
      Update pre-commit-config
      Add additional typing requirements
      Add global mypy config
      Remove deprecated astroid.Ellipsis node (#4567)
      Remove deprecated astroid.Index and astroid.ExtSlice nodes (#4568)
      Recognize cached_property as property (#4594)
      Bump cache version

Mark Byrne (1):
      Add type annotations to pyreverse (#4551)

Markus Siebenhaar (1):
      Handle floats when parsing pyproject.toml (#4518) (#4520)

Matus Valo (11):
      Add support for checking deprecated class arguments. (#4425)
      Add deprecated methods, classes and arguments to stdlib checker (#4424)
      warn deprecated x argument of int(), bool(), float() in all python versions (#4435)
      Add Deprecated Class unittests (#4448)
      Moved stdlib module deprecation from imports checker to stdlib checker (#4454)
      Added deprecated decorators check (#4513)
      Added support for deprecated method alias
      Updated whatsnew and changelog
      Fixed failing unittests
      Added various deprecated functions/methods for python 3.10, 3.7, 3.6 and 3.3
      Updated Changelog and whatsnew

Peter Kolbus (1):
      Fix issues with Python 3.6.0 (#4446)

Pierre Sassoulas (51):
      Fix link to the logo in README.rst
      Logo visible in readme using RST syntax
      Revert "Logo visible in readme using RST syntax"
      Fix retrocompatbility of numversion
      Add pre-commit CI in continuous integration (#4423)
      Add python 3.10 dev in the CI
      Fix test failing because python 10 got better
      Strangely a new legacy test case appeared ?
      Add security.md for Tidelift coordinated disclosure plan (#4493)
      Require astroid 2.5.7
      Fix invalid value returned in len
      Fix warning expected on logger class created from renamed import
      Upgrade release.md following the decision to pin astroid
      Add the changelog for 2.8.3
      Add typing in pylint.messages
      Refactor register_message_definition to prevent circular import
      Upgrade to astroid 2.5.8
      Add documentation in order to prevent error in the future
      Add test case from issue #119 for easier resolution
      Add handle_message in BaseReporter and add typing
      Add unit tests for OutputLine
      Remove dead code, always return the confidence
      Use a NamedTuple from typing directly
      Refactor the json reporter so handle message work the same way
      Special case for python < 3.8 with worse AST handling
      Remove appveyor.yml replaced by Github actions
      Upgrade astroid to 2.6.0-dev0 (#4581)
      Add a release step in Github Actions
      Add tbump script for bumbing version
      Migration from setuptools_scm to tbump
      Add alias for bots in copyrite aliases
      Bump pylint to 2.9.0-dev1, update changelog
      Fix update a functional test with no expected output
      No crash on bad plugin provided in configuration file
      Add a test for too-many-statements when modified by configuration
      Upgrade astroid to 2.6.0 (#4602)
      Add code analysis provided by GitHub(#4605)
      Fix a crash when a test function is decorated with ``@pytest.fixture`` (#4613)
      Add regression tests for issue #2913
      Add a '__repr__' function in Docstring
      Fix useless-type-doc false positive when args exist in the docstring
      Make a smarter check to avoid 'useless-type-doc' false positive
      Fix a syntax error in unittest_deprecated.py test code
      Add a functional test for deprecated_methods
      Add a regression test following issue #4610
      Upgrade astroid to 2.6.1
      Upgrade the release script using what was done in astroid
      Upgrade the copyrite alias with Mark Bryne
      Normalize the changelog and fix old oversight
      Upgrade documentation for the new release script
      Bump pylint to 2.9.0, update changelog, add python 3.10 to package meta

Sergei Lebedev (1):
      VariableChecker now accounts for attribute lookups in type comments (#4604)

Stanislav Levin (1):
      tests: Sort for comparison in test_expand_modules

dependabot[bot] (25):
      Bump pyupgrade from 2.11.0 to 2.14.0 (#4432)
      Bump black from 21.4b0 to 21.4b2 (#4433)
      Bump python-docs-theme from 2020.12 to 2021.5 (#4460)
      Bump sphinx from 3.5.4 to 4.0.0 (#4461)
      Bump flake8 from 3.9.0 to 3.9.2 (#4459)
      Bump black from 21.4b2 to 21.5b0 (#4458)
      Bump pyupgrade from 2.14.0 to 2.15.0 (#4457)
      Update pytest-cov requirement from ~=2.11 to ~=2.12 (#4479)
      Bump sphinx from 4.0.0 to 4.0.1 (#4478)
      Bump pyupgrade from 2.15.0 to 2.16.0 (#4477)
      Update pre-commit requirement from ~=2.12 to ~=2.13 (#4495)
      Bump pyupgrade from 2.16.0 to 2.18.1 (#4496)
      Bump sphinx from 4.0.1 to 4.0.2 (#4494)
      Bump actions/cache from 2.1.5 to 2.1.6
      Update coveralls requirement from ~=3.0 to ~=3.1
      Bump black from 21.5b1 to 21.5b2
      Bump black from 21.5b2 to 21.6b0 (#4572)
      Bump mypy from 0.812 to 0.902
      Bump types-toml from 0.1.2 to 0.1.3 (#4599)
      Bump isort from 5.8.0 to 5.9.0 (#4598)
      Bump actions/upload-artifact from 2.2.3 to 2.2.4 (#4596)
      Bump actions/download-artifact from 2.0.9 to 2.0.10 (#4595)
      Update pytest-xdist requirement from ~=2.2 to ~=2.3 (#4597)
      Bump types-pkg-resources from 0.1.2 to 0.1.3 (#4600)
      Bump mypy from 0.902 to 0.910 (#4621)

pre-commit-ci[bot] (9):
      [pre-commit.ci] pre-commit autoupdate (#4438)
      [pre-commit.ci] pre-commit autoupdate (#4465)
      [pre-commit.ci] pre-commit autoupdate (#4481)
      [pre-commit.ci] pre-commit autoupdate (#4501)
      [pre-commit.ci] pre-commit autoupdate
      [pre-commit.ci] pre-commit autoupdate
      [pre-commit.ci] pre-commit autoupdate
      [pre-commit.ci] pre-commit autoupdate (#4601)
      [pre-commit.ci] pre-commit autoupdate (#4622)

ruro (1):
      Multiple `output-format` support (#4492)

victor (1):
      Add new warning ``deprecated-class`` #4388 (#4419)

yushao2 (13):
      Implemented new check consider-using-dict-items (#4445)
      Removed redundant logic from consider-using-dict-items (#4486)
      Implemented new check use-maxsplit-arg (#4469)
      Implemented new check unnecessary-dict-index-lookup (#4485)
      Implemented new check consider-using-from-import (#4491)
      Implemented ``unused-private-member`` checker (#4504)
      Added suggestion in helptext for ``unnecessary-comprehension`` checker (#4500)
      Fixed false-positive on ``unused-private-member`` (#4507)
      Fixed minor doc formatting (#4511)
      Fixed false negative of consider-using-enumerate on attributes (#4508)
      Implemented new checker invalid-class-object (#4510)
      Minor refactoring of ``tests/functional/a`` directory (#4515)
      Implemented new checker await-outside-async (#4514)
  • Loading branch information
phmccarty authored and clrpackages committed Jul 1, 2021
1 parent ba862b7 commit f6df6cd
Show file tree
Hide file tree
Showing 9 changed files with 14 additions and 41 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pylint
URL = https://files.pythonhosted.org/packages/18/a7/2bf9363ec428818abd27a64ec44c84b13bf1c10df01c402f08391aa1d07c/pylint-2.8.3.tar.gz
URL = https://files.pythonhosted.org/packages/75/f7/a2596f06f8233c533003671954961aaacff5f866801aaf54b032c92d9361/pylint-2.9.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 0 additions & 2 deletions buildreq_cache

This file was deleted.

19 changes: 0 additions & 19 deletions deps.patch

This file was deleted.

2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pylint
url = https://files.pythonhosted.org/packages/18/a7/2bf9363ec428818abd27a64ec44c84b13bf1c10df01c402f08391aa1d07c/pylint-2.8.3.tar.gz
url = https://files.pythonhosted.org/packages/75/f7/a2596f06f8233c533003671954961aaacff5f866801aaf54b032c92d9361/pylint-2.9.0.tar.gz
archives =
giturl = https://github.com/PyCQA/pylint.git
domain =
Expand Down
23 changes: 9 additions & 14 deletions pylint.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,10 +3,10 @@
# Generated by: autospec.py
#
Name : pylint
Version : 2.8.3
Release : 101
URL : https://files.pythonhosted.org/packages/18/a7/2bf9363ec428818abd27a64ec44c84b13bf1c10df01c402f08391aa1d07c/pylint-2.8.3.tar.gz
Source0 : https://files.pythonhosted.org/packages/18/a7/2bf9363ec428818abd27a64ec44c84b13bf1c10df01c402f08391aa1d07c/pylint-2.8.3.tar.gz
Version : 2.9.0
Release : 102
URL : https://files.pythonhosted.org/packages/75/f7/a2596f06f8233c533003671954961aaacff5f866801aaf54b032c92d9361/pylint-2.9.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/75/f7/a2596f06f8233c533003671954961aaacff5f866801aaf54b032c92d9361/pylint-2.9.0.tar.gz
Summary : python code static checker
Group : Development/Tools
License : GPL-2.0 GPL-2.0+
Expand All @@ -24,14 +24,10 @@ BuildRequires : buildreq-distutils3
BuildRequires : colorama
BuildRequires : isort
BuildRequires : mccabe
BuildRequires : setuptools_scm-python
BuildRequires : toml
Patch1: deps.patch

%description
=============================================
.. image:: https://github.com/PyCQA/pylint/actions/workflows/ci.yaml/badge.svg?branch=master
:target: https://github.com/PyCQA/pylint/actions
No detailed description available

%package bin
Summary: bin components for the pylint package.
Expand Down Expand Up @@ -74,16 +70,15 @@ python3 components for the pylint package.


%prep
%setup -q -n pylint-2.8.3
cd %{_builddir}/pylint-2.8.3
%patch1 -p1
%setup -q -n pylint-2.9.0
cd %{_builddir}/pylint-2.9.0

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1622566724
export SOURCE_DATE_EPOCH=1625011941
export GCC_IGNORE_WERROR=1
export CFLAGS="$CFLAGS -fno-lto "
export FCFLAGS="$FFLAGS -fno-lto "
Expand All @@ -96,7 +91,7 @@ python3 setup.py build
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/pylint
cp %{_builddir}/pylint-2.8.3/LICENSE %{buildroot}/usr/share/package-licenses/pylint/909b58c9b803acb8d063ac6b2147e56afc8055f6
cp %{_builddir}/pylint-2.9.0/LICENSE %{buildroot}/usr/share/package-licenses/pylint/909b58c9b803acb8d063ac6b2147e56afc8055f6
python3 -tt setup.py build install --root=%{buildroot}
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
101
102
1 change: 0 additions & 1 deletion series

This file was deleted.

2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
a17bfe3b938da9c73d1a937c104baa5dee4f56bd/pylint-2.8.3.tar.gz
81a54016a373aef3185275b96e0dc26f26e0a2cc/pylint-2.9.0.tar.gz
2 changes: 1 addition & 1 deletion versions
Original file line number Diff line number Diff line change
@@ -1 +1 @@
2.8.3
2.9.0

0 comments on commit f6df6cd

Please sign in to comment.