Skip to content
This repository has been archived by the owner on Oct 25, 2022. It is now read-only.

Commit

Permalink
ldc: Autospec creation for update from version 1.25.1 to version 1.27.0
Browse files Browse the repository at this point in the history
Hiroki Noda (3):
      Fix comments in abi-aarch-64.h (#3707)
      Use new OpenFlags enumeration (#3710)
      Travis CI: fix cache directory name (#3776)

Johan Engelen (8):
      Fix Github workflow Lit install: use Python 3.x (#3725)
      Fix Circle CI: use python 3 (#3727)
      Fix Cirrus build: use python3 (#3726)
      Switch to using Python 3 and move from Ubuntu 16.04 to 18.04 on Azure (#3728)
      Add MSan compiler-rt library to LDC install and add it to linkerline for --fsanitize=memory (#3751)
      Update druntime to get the fix for core.bitop.ror/rol inlining (#3752)
      Add -cov-increment option to specify the type of increment instruction. Add atomic, non-atomic, and boolean increment types. (#3724)
      CMake: Add `ALTERNATIVE_MALLOC_O` option for user to link LDC with a malloc-overriding allocator like mimalloc.o (#3758)

Martin Kinkelin (171):
      Upgrade frontend & libs to v2.096.0-beta.1+ (dlang/dmd@0c2d8bd2ab)
      Fix little C++ header regressions
      Add support for 'noreturn' type
      Phobos: Fix little std.math regressions
      Adapt to expression-less `synchronized` statement change (with GC-backed critical section)
      Fix ICE for ref/out params of opaque structs
      druntime: Adapt coverage integration test to work on Windows
      dmd-testsuite: Slightly adapt some new tests for LDC
      GitHub Actions: Disable new @LiVe tests for ltsmaster job
      Fix orphaned CondExp __cond variable refs in codegen AST
      Fix TypeInfo_Interface.info regression
      CI: Use `-k0` for ninja cmdlines potentially running into out-of-memory errors
      CI: Fix pip download URL after annoying change
      -i: Exclude ldc.* modules by default (#3679)
      SysV x64 ABI: Add support for new magic __c_complex_real enum
      x86 ABI: Add support for new magic __c_complex_{float,double,real} enums
      Merge upstream stable (dlang/dmd@75fe50f497)
      dmd-testsuite: Minimally adapt runnable/test42.d
      Bump versions of bundled dlang tools & dub
      dmd-testsuite: Make runnable_cxx/extra-files/test21515.cpp compile with clang too
      CMake: Work around issue #3690 by disabling -linkonce-templates for D executables
      Treat temporaries as rvalue expressions when ABI-rewriting function call arguments
      dmd-testsuite: Minimally relax compilable/ctfe_math.d for quadruple real precision
      Don't enforce the frame pointer for functions with GCC-style inline asm (#3685)
      Win64: Relax tests/dynamiccompile/bind_opt.d due to issue #3695
      Merge upstream stable (dlang/dmd@128d40a86b)
      Skip tests/driver/cleanup_obj_gh3643.d if x86 LLVM backend is missing
      CMake: Compile druntime with -transition=complex too
      Fix overzealous toBasetype'ing for debuginfo types
      DI: Emit delegate `funcptr` member as function *pointer*
      DI: Emit enums with floating-point base type as typedefs
      Remove superfluous DIBuilder::CreateCompositeTypeDescription
      DI: Fix up a few names
      DI: Remove 2 more superfluous helpers
      Merge upstream stable (dlang/dmd@655278312e)
      druntime: Cherry-pick dlang/druntime#3432 and dlang/druntime#3428
      ldmd2: Add support for new -gdwarf=<version>
      Cirrus CI: Work around strange FreeBSD std.experimental.allocator unittest regression (#3696)
      Fix insufficient alignment of BaseBitcastABIRewrite allocas (#3698)
      Adapt to Windows-specific LLVM 12 API change (#3697)
      Merge upstream stable (dlang/dmd@37b74d7219) (#3706)
      LLVM 12: Add type information to sret and byval parameter attributes
      Cirrus CI: Adapt to Ubuntu rolling now shipping with LLVM 12
      GitHub Actions: Add LLVM 12 job
      Changelog: Add v1.26
      Windows: Make -fvisibility=public export all defined symbols
      Windows: Try to make implicit dllimport work for data symbols
      Windows: Only export all external and weak_odr symbols with -fvisibility=public
      Windows: Don't bother with dllimport/dllexport for thread-local globals
      (Optimize if-chain order)
      Windows: Disable @weak emulation for dllexported functions
      Windows: Dllimport aggregate globals too
      Windows: Dllexport ModuleInfos with -fvisibility=public
      Add manual dllimport 'relocation' pass for static data initializers
      Fix dllimport relocation pass wrt. multiple definitions
      Windows: Default to dllexport with -shared, and enforce dllimport with -link-defaultlib-shared
      CMake: Run the druntime integration tests in debug mode too
      DI: Streamline file path components ('filename', 'directory') with clang
      druntime: Add -L--export-dynamic for a few exceptions integration tests
      druntime: Adapt 'shared' integration test for recent macOS versions
      GitHub Actions Mac: Disable druntime-test-exceptions-debug (requires LDC-LLVM)
      Work around race condition for debug/release coverage druntime integration tests
      Merge pull request #3734 from kinke/travis
      dmd-testsuite: Cherry-pick fix for recent GDB versions
      Adapt tests/debuginfo/print_gdb.d for recent GDB versions
      DI: Don't use a forward declaration for base class inheritance info
      DI: Try switching module parent from CU to source file
      Azure CI Linux: Downgrade gdb from v10.2 to v8.1
      Merge pull request #3712 from kinke/sections_shared
      Cirrus CI: Fix little regression for Mac jobs
      CMake: Support BUILD_SHARED_LIBS for Windows too
      CMake: Link Windows druntime & Phobos DLLs against *dynamic* MSVCRT
      Windows: Link against dynamic MSVCRT when linking against shared druntime/Phobos
      CMake: Get shared test runners to link on Windows
      CMake: Install shared .dll/.pdb files into bin dir
      CMake: Link special rt.dso_windows module into Phobos DLL and shared test runner executables
      CMake: Make sure shared Phobos test runners on Windows depend on/load the Phobos unittest DLL
      CMake: Copy & install special dso_windows.obj object file to lib dir
      Windows: Link rt.dso_windows object file automatically into each binary linked against shared druntime
      Windows: Default to dllexport with -shared, and enforce dllimport with -link-defaultlib-shared
      CMake: Compile rt.dso_windows separately to enable binaries without any exports with -link-defaultlib-shared
      Azure CI: Add druntime/Phobos DLL dir to PATH to fix dmd-testsuite's dshell/dll.d
      druntime: Fix test/shared integration test on Windows
      CMake: Enforce .pdb generation for debug druntime/Phobos DLLs
      Azure CI: Fix shared libs integration test for Win32
      druntime: Fix race condition for debug/release 'shared' integration tests
      Phobos: Fix std.format.internal.write for druntime DLL
      Azure CI Windows: Add shared libs smoke test for multilib package
      druntime: Generalize 'shared' integration tests to include Windows
      druntime: Use debug druntime for debug integration tests
      druntime: Fix rt.dso_windows not unregistering the DSO from druntime
      druntime: Disable/adapt remaining 2 'shared' integration test failures on Windows
      druntime: Adapt/simplify core.sys.windows.dll for shared druntime DLL
      druntime: Implement little Windows TODO in 'shared/load' integration test
      CI: Make curl downloads more robust (#3740)
      Upgrade frontend & libs to early v2.097.0 (dlang/dmd@cb0457daf3)
      Adapt to upstream global.params.* -> target.* shuffling
      Fix upstream regression wrt. mutual init dependency of Type and Target
      Phobos: Fix regressions after std.math split-up
      Adapt to user-defined init symbol declarations
      Adapt lit-test codegen/inlining_stdlib.d to std.math split-up
      Merge upstream stable (dlang/dmd@2adf6ff4f6)
      Move target `real` selection from ir/irtype.cpp to gen/target.cpp
      CI: Ship reggae with prebuilt packages (#3739)
      Cherry-pick upstream support for enforcing ANSI colors for redirected stderr on Windows (#3744)
      druntime: Add support for vectors in core.internal.dassert.miniFormat()
      dmd-testsuite: Adapt a few LDC-specific tests wrt. new deprecations
      druntime: Add missing core.sys.posix.stdio.flockfile() etc. for Android/Bionic
      ldmd2: Add support for -check=on|off
      Exclude `assert(0)` from lines coverage
      Support type `noreturn` in return statements codegen
      Support type `noreturn` in ternary expressions (CondExp)
      dmd-testsuite: Disable/adapt 2 new tests for LDC
      Phobos: Revert 'faster' pow implementation for integral exponents
      dmd.expression: Remove obsolete?/problematic LDC specificum wrt. overriding lambda function type
      Phobos: Slightly revise std.math.operations.extractBitpattern()
      Phobos: Minimally relax a pow() unittest for targets with 64-bit real
      Phobos: Minimally relax 2 std.complex unittests for targets with 64-bit real
      GitHub Actions: Disable new __traits(getOverloads) test with ltsmaster host compiler
      Phobos: Restore compilability of std.format.internal.floats unittests for targets with quadruple real precision
      Phobos: Disable std.math.traits.signbit(-NaN) CTFE tests for AArch64
      dmd-testsuite: Fix compilable/test21672.d for non-x86 targets
      Phobos: Restore compilability of std.stdio unittests for iOS
      Merge upstream stable (dlang/dmd@bffc721251)
      Bump bundled dub & dlang tools versions
      CI: Bump LDC-LLVM to v12.0.0
      CI: Bump LDC-LLVM to v12.0.0 final
      Minimally adapt lit-test PGO/indirect_calls.d for LLVM 12
      Phobos: Avoid undefined bytes in std.conv.toChars() results for radix 10
      Cirrus CI: Bump FreeBSD to v12.2
      GitHub Actions: Bump Ubuntu to 18.04
      Cirrus CI: Allow Ubuntu rolling job to fail (gdb v10)
      CI: Bump LDC-LLVM to v12.0.0 for remaining Darwin jobs (#3749)
      Travis CI: Pin host compiler to v1.26.0 (#3754)
      Bump bundled dub, allowing for longer paths on Windows (#3756)
      CMake: Compile shared druntime/Phobos libs to a single object file
      CMake: Revert to multiple object files for shared druntime
      druntime: Fix teardown of DLLs with static druntime using the .exe GC (#3755)
      Windows: Make implicit dllimport more selective
      Add -dllimport CLI option for explicitly controlling implicit dllimports
      Azure CI: Build and bundle shared libs for iOS too (#3764)
      isDefaultLibSymbol(): Recognize std.package module as Phobos module
      isDefaultLibSymbol(): Exclude all instantiated symbols with -linkonce-templates
      Phobos: Add std.getopt TLS workaround for Windows Phobos DLL
      isDefaultLibSymbol(): Add ugly special case for std.io dub package
      Refactoring: Push/pop FuncGenState for naked asm functions in DtoDefineFunction() too
      Fix bad assumption of FuncGenStates stack reflecting lexical parent/child relationships
      Refactoring: Add little dllimportSymbol() helper
      README: Add latest release badge, incl. prereleases
      README: Update notes about prebuilt packages
      Azure CI: Use mimalloc for Linux and macOS x64 packages
      Azure CI: Use mimalloc for macOS arm64 package
      README: Move cross-compilation section out of 'Installation' section
      Fix DtoCreateNestedContextType() for -linkonce-templates (#3766)
      Merge upstream stable (dlang/dmd@5f214609d9) (#3770)
      README: Add Alpine distro package
      README: Remove Shippable badge
      druntime: Merge upstream stable (#3771)
      Add __traits(initSymbol, <aggregate type>) (#3774)
      druntime: Prefer __traits(initSymbol) over TypeInfo.initializer() (#3775)
      CMake: Export zlib symbols from Phobos DLL on Windows (#3782)
      Merge upstream stable (dlang/dmd@f2fbdcacaa) (#3790)
      Make sure special struct TypeInfo members are semantically analyzed before emitting the TypeInfo (#3783)
      Fix #3778 - in-place construct <temporary>.ctor(args) (#3779)
      CI: Bump LDC-LLVM to v12.0.1 (#3789)
      Fix lit 12.0.1 installation regression (#3791)
      Merge upstream stable (dlang/dmd@f9e8117fd7) (#3794)
      Merge upstream stable (dlang/dmd@9337377c8a) (#3796)
      Merge upstream stable (dlang/dmd@d03f144b07)
      Bump bundled dub & dlang tools versions
      Changelog: Add v1.27

Mathias LANG (1):
      Driver: Use CppRuntime_Gcc by default with Musl (#3769)

Nicholas Wilson (1):
      Fix compilation on MacOS with read-only root filesystems

bcarneal (2):
      extend valid_cuda_versions thru 800
      accept i1 types as dlang bool
  • Loading branch information
fenrus75 committed Aug 3, 2021
1 parent f34c5d7 commit ead3ead
Show file tree
Hide file tree
Showing 8 changed files with 8,220 additions and 8,292 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := ldc
URL = https://github.com/ldc-developers/ldc/releases/download/v1.25.1/ldc-1.25.1-src.tar.gz
URL = https://github.com/ldc-developers/ldc/releases/download/v1.27.0/ldc-1.27.0-src.tar.gz
ARCHIVES =

include ../common/Makefile.common
88 changes: 66 additions & 22 deletions ldc.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,10 +3,10 @@
# Generated by: autospec.py
#
Name : ldc
Version : 1.25.1
Release : 35
URL : https://github.com/ldc-developers/ldc/releases/download/v1.25.1/ldc-1.25.1-src.tar.gz
Source0 : https://github.com/ldc-developers/ldc/releases/download/v1.25.1/ldc-1.25.1-src.tar.gz
Version : 1.27.0
Release : 36
URL : https://github.com/ldc-developers/ldc/releases/download/v1.27.0/ldc-1.27.0-src.tar.gz
Source0 : https://github.com/ldc-developers/ldc/releases/download/v1.27.0/ldc-1.27.0-src.tar.gz
Summary : No detailed summary available
Group : Development/Tools
License : Apache-2.0 Artistic-1.0-Perl BSD-3-Clause BSL-1.0 GPL-1.0+ MIT
Expand All @@ -28,8 +28,11 @@ Patch1: 0001-Fixups-for-packaging-and-stateless-config.patch
Patch2: 0002-Don-t-force-the-use-of-gold-linker.patch

%description
This is a standalone (DMD-style) binary package for LDC, the LLVM-based D
compiler.
Building druntime/Phobos for D2
---
LDC currently needs custom forks of druntime and Phobos. They are integrated
with the main repository using Git submodules. To build them, make sure you
have up-to-date copies of the submodules in your local repository:

%package bin
Summary: bin components for the ldc package.
Expand Down Expand Up @@ -81,8 +84,8 @@ license components for the ldc package.


%prep
%setup -q -n ldc-1.25.1-src
cd %{_builddir}/ldc-1.25.1-src
%setup -q -n ldc-1.27.0-src
cd %{_builddir}/ldc-1.27.0-src
%patch1 -p1
%patch2 -p1

Expand All @@ -100,7 +103,7 @@ export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1618943387
export SOURCE_DATE_EPOCH=1628005989
mkdir -p clr-build
pushd clr-build
export GCC_IGNORE_WERROR=1
Expand Down Expand Up @@ -128,11 +131,11 @@ make %{?_smp_mflags}
popd

%install
export SOURCE_DATE_EPOCH=1618943387
export SOURCE_DATE_EPOCH=1628005989
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/ldc
cp %{_builddir}/ldc-1.25.1-src/runtime/druntime/LICENSE.txt %{buildroot}/usr/share/package-licenses/ldc/3cba29011be2b9d59f6204d6fa0a386b1b2dbd90
cp %{_builddir}/ldc-1.25.1-src/runtime/phobos/LICENSE_1_0.txt %{buildroot}/usr/share/package-licenses/ldc/3cba29011be2b9d59f6204d6fa0a386b1b2dbd90
cp %{_builddir}/ldc-1.27.0-src/runtime/druntime/LICENSE.txt %{buildroot}/usr/share/package-licenses/ldc/3cba29011be2b9d59f6204d6fa0a386b1b2dbd90
cp %{_builddir}/ldc-1.27.0-src/runtime/phobos/LICENSE_1_0.txt %{buildroot}/usr/share/package-licenses/ldc/3cba29011be2b9d59f6204d6fa0a386b1b2dbd90
pushd clr-build
%make_install
popd
Expand Down Expand Up @@ -161,6 +164,7 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/atomic.d
/usr/include/d/core/attribute.d
/usr/include/d/core/bitop.d
/usr/include/d/core/builtins.d
/usr/include/d/core/checkedint.d
/usr/include/d/core/cpuid.d
/usr/include/d/core/demangle.d
Expand All @@ -185,6 +189,7 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/internal/backtrace/handler.d
/usr/include/d/core/internal/backtrace/libunwind.d
/usr/include/d/core/internal/backtrace/macho.d
/usr/include/d/core/internal/backtrace/unwind.d
/usr/include/d/core/internal/container/array.d
/usr/include/d/core/internal/container/common.d
/usr/include/d/core/internal/container/hashtab.d
Expand All @@ -196,6 +201,13 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/internal/elf/io.d
/usr/include/d/core/internal/entrypoint.d
/usr/include/d/core/internal/execinfo.d
/usr/include/d/core/internal/gc/bits.d
/usr/include/d/core/internal/gc/impl/conservative/gc.d
/usr/include/d/core/internal/gc/impl/manual/gc.d
/usr/include/d/core/internal/gc/impl/proto/gc.d
/usr/include/d/core/internal/gc/os.d
/usr/include/d/core/internal/gc/pooltable.d
/usr/include/d/core/internal/gc/proxy.d
/usr/include/d/core/internal/hash.d
/usr/include/d/core/internal/lifetime.d
/usr/include/d/core/internal/moving.d
Expand All @@ -208,6 +220,7 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/internal/traits.d
/usr/include/d/core/internal/utf.d
/usr/include/d/core/internal/util/array.d
/usr/include/d/core/internal/util/math.d
/usr/include/d/core/internal/vararg/aarch64.d
/usr/include/d/core/internal/vararg/sysv_x64.d
/usr/include/d/core/lifetime.d
Expand Down Expand Up @@ -259,12 +272,14 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/sync/semaphore.d
/usr/include/d/core/sys/bionic/err.d
/usr/include/d/core/sys/bionic/fcntl.d
/usr/include/d/core/sys/bionic/stdlib.d
/usr/include/d/core/sys/bionic/string.d
/usr/include/d/core/sys/bionic/unistd.d
/usr/include/d/core/sys/darwin/crt_externs.d
/usr/include/d/core/sys/darwin/dlfcn.d
/usr/include/d/core/sys/darwin/err.d
/usr/include/d/core/sys/darwin/execinfo.d
/usr/include/d/core/sys/darwin/fcntl.d
/usr/include/d/core/sys/darwin/ifaddrs.d
/usr/include/d/core/sys/darwin/mach/dyld.d
/usr/include/d/core/sys/darwin/mach/getsect.d
Expand All @@ -277,16 +292,19 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/sys/darwin/mach/thread_act.d
/usr/include/d/core/sys/darwin/netinet/in_.d
/usr/include/d/core/sys/darwin/pthread.d
/usr/include/d/core/sys/darwin/stdlib.d
/usr/include/d/core/sys/darwin/string.d
/usr/include/d/core/sys/darwin/sys/attr.d
/usr/include/d/core/sys/darwin/sys/cdefs.d
/usr/include/d/core/sys/darwin/sys/event.d
/usr/include/d/core/sys/darwin/sys/mman.d
/usr/include/d/core/sys/darwin/sys/sysctl.d
/usr/include/d/core/sys/dragonflybsd/dlfcn.d
/usr/include/d/core/sys/dragonflybsd/err.d
/usr/include/d/core/sys/dragonflybsd/execinfo.d
/usr/include/d/core/sys/dragonflybsd/netinet/in_.d
/usr/include/d/core/sys/dragonflybsd/pthread_np.d
/usr/include/d/core/sys/dragonflybsd/stdlib.d
/usr/include/d/core/sys/dragonflybsd/string.d
/usr/include/d/core/sys/dragonflybsd/sys/_bitset.d
/usr/include/d/core/sys/dragonflybsd/sys/_cpuset.d
Expand All @@ -299,13 +317,15 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/sys/dragonflybsd/sys/link_elf.d
/usr/include/d/core/sys/dragonflybsd/sys/mman.d
/usr/include/d/core/sys/dragonflybsd/sys/socket.d
/usr/include/d/core/sys/dragonflybsd/sys/sysctl.d
/usr/include/d/core/sys/dragonflybsd/time.d
/usr/include/d/core/sys/freebsd/config.d
/usr/include/d/core/sys/freebsd/dlfcn.d
/usr/include/d/core/sys/freebsd/err.d
/usr/include/d/core/sys/freebsd/execinfo.d
/usr/include/d/core/sys/freebsd/netinet/in_.d
/usr/include/d/core/sys/freebsd/pthread_np.d
/usr/include/d/core/sys/freebsd/stdlib.d
/usr/include/d/core/sys/freebsd/string.d
/usr/include/d/core/sys/freebsd/sys/_bitset.d
/usr/include/d/core/sys/freebsd/sys/_cpuset.d
Expand All @@ -318,6 +338,7 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/sys/freebsd/sys/link_elf.d
/usr/include/d/core/sys/freebsd/sys/mman.d
/usr/include/d/core/sys/freebsd/sys/mount.d
/usr/include/d/core/sys/freebsd/sys/sysctl.d
/usr/include/d/core/sys/freebsd/time.d
/usr/include/d/core/sys/freebsd/unistd.d
/usr/include/d/core/sys/linux/config.d
Expand Down Expand Up @@ -354,6 +375,7 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/sys/netbsd/dlfcn.d
/usr/include/d/core/sys/netbsd/err.d
/usr/include/d/core/sys/netbsd/execinfo.d
/usr/include/d/core/sys/netbsd/stdlib.d
/usr/include/d/core/sys/netbsd/string.d
/usr/include/d/core/sys/netbsd/sys/elf.d
/usr/include/d/core/sys/netbsd/sys/elf32.d
Expand All @@ -363,9 +385,11 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/sys/netbsd/sys/featuretest.d
/usr/include/d/core/sys/netbsd/sys/link_elf.d
/usr/include/d/core/sys/netbsd/sys/mman.d
/usr/include/d/core/sys/netbsd/sys/sysctl.d
/usr/include/d/core/sys/netbsd/time.d
/usr/include/d/core/sys/openbsd/dlfcn.d
/usr/include/d/core/sys/openbsd/err.d
/usr/include/d/core/sys/openbsd/stdlib.d
/usr/include/d/core/sys/openbsd/string.d
/usr/include/d/core/sys/openbsd/sys/cdefs.d
/usr/include/d/core/sys/openbsd/sys/elf.d
Expand All @@ -374,7 +398,9 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/sys/openbsd/sys/elf_common.d
/usr/include/d/core/sys/openbsd/sys/link_elf.d
/usr/include/d/core/sys/openbsd/sys/mman.d
/usr/include/d/core/sys/openbsd/sys/sysctl.d
/usr/include/d/core/sys/openbsd/time.d
/usr/include/d/core/sys/openbsd/unistd.d
/usr/include/d/core/sys/posix/aio.d
/usr/include/d/core/sys/posix/arpa/inet.d
/usr/include/d/core/sys/posix/config.d
Expand Down Expand Up @@ -435,6 +461,7 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/sys/solaris/execinfo.d
/usr/include/d/core/sys/solaris/libelf.d
/usr/include/d/core/sys/solaris/link.d
/usr/include/d/core/sys/solaris/stdlib.d
/usr/include/d/core/sys/solaris/sys/elf.d
/usr/include/d/core/sys/solaris/sys/elf_386.d
/usr/include/d/core/sys/solaris/sys/elf_SPARC.d
Expand Down Expand Up @@ -580,6 +607,7 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/core/sys/windows/sspi.d
/usr/include/d/core/sys/windows/stacktrace.d
/usr/include/d/core/sys/windows/stat.d
/usr/include/d/core/sys/windows/stdc/malloc.d
/usr/include/d/core/sys/windows/stdc/time.d
/usr/include/d/core/sys/windows/subauth.d
/usr/include/d/core/sys/windows/threadaux.d
Expand Down Expand Up @@ -725,7 +753,13 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/std/experimental/logger/package.d
/usr/include/d/std/experimental/typecons.d
/usr/include/d/std/file.d
/usr/include/d/std/format.d
/usr/include/d/std/format/internal/floats.d
/usr/include/d/std/format/internal/read.d
/usr/include/d/std/format/internal/write.d
/usr/include/d/std/format/package.d
/usr/include/d/std/format/read.d
/usr/include/d/std/format/spec.d
/usr/include/d/std/format/write.d
/usr/include/d/std/functional.d
/usr/include/d/std/getopt.d
/usr/include/d/std/internal/attributes.d
Expand All @@ -749,7 +783,16 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/std/internal/unicode_tables.d
/usr/include/d/std/internal/windows/advapi32.d
/usr/include/d/std/json.d
/usr/include/d/std/math.d
/usr/include/d/std/math/algebraic.d
/usr/include/d/std/math/constants.d
/usr/include/d/std/math/exponential.d
/usr/include/d/std/math/hardware.d
/usr/include/d/std/math/operations.d
/usr/include/d/std/math/package.d
/usr/include/d/std/math/remainder.d
/usr/include/d/std/math/rounding.d
/usr/include/d/std/math/traits.d
/usr/include/d/std/math/trigonometry.d
/usr/include/d/std/mathspecial.d
/usr/include/d/std/meta.d
/usr/include/d/std/mmfile.d
Expand Down Expand Up @@ -779,6 +822,7 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s
/usr/include/d/std/stdint.d
/usr/include/d/std/stdio.d
/usr/include/d/std/string.d
/usr/include/d/std/sumtype.d
/usr/include/d/std/system.d
/usr/include/d/std/traits.d
/usr/include/d/std/typecons.d
Expand All @@ -801,14 +845,14 @@ mv %{buildroot}/usr/share/defaults/etc/bash_completion.d/ldc2 %{buildroot}/usr/s

%files lib
%defattr(-,root,root,-)
/usr/lib64/libdruntime-ldc-debug-shared.so.2.0.95
/usr/lib64/libdruntime-ldc-debug-shared.so.95
/usr/lib64/libdruntime-ldc-shared.so.2.0.95
/usr/lib64/libdruntime-ldc-shared.so.95
/usr/lib64/libphobos2-ldc-debug-shared.so.2.0.95
/usr/lib64/libphobos2-ldc-debug-shared.so.95
/usr/lib64/libphobos2-ldc-shared.so.2.0.95
/usr/lib64/libphobos2-ldc-shared.so.95
/usr/lib64/libdruntime-ldc-debug-shared.so.2.0.97
/usr/lib64/libdruntime-ldc-debug-shared.so.97
/usr/lib64/libdruntime-ldc-shared.so.2.0.97
/usr/lib64/libdruntime-ldc-shared.so.97
/usr/lib64/libphobos2-ldc-debug-shared.so.2.0.97
/usr/lib64/libphobos2-ldc-debug-shared.so.97
/usr/lib64/libphobos2-ldc-shared.so.2.0.97
/usr/lib64/libphobos2-ldc-shared.so.97

%files license
%defattr(0644,root,root,0755)
Expand Down
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = ldc
url = https://github.com/ldc-developers/ldc/releases/download/v1.25.1/ldc-1.25.1-src.tar.gz
url = https://github.com/ldc-developers/ldc/releases/download/v1.27.0/ldc-1.27.0-src.tar.gz
archives =
giturl = https://github.com/ldc-developers/ldc.git
domain =
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
35
36
Loading

0 comments on commit ead3ead

Please sign in to comment.