Skip to content
This repository has been archived by the owner on Oct 27, 2022. It is now read-only.

Commit

Permalink
keyring: Autospec creation for update from version 23.2.1 to version …
Browse files Browse the repository at this point in the history
…23.3.0

Jason R. Coombs (12):
      Implement tidelift banner using a Sphinx directive implemented by jaraco.tidelift.
      Add intersphinx mappings for Python to prevent spurious nitpicky failures. Fixes jaraco/skeleton#51.
      Test on Python 3.10 (final).
      Rely on pytest 6 and drop workaround for pytest-dev/pytest#6178.
      Remove wheel from build requirements. It's implied for wheel builds. Ref pypa/setuptools#1498.
      An initial attempt to skip collection on macOS API module. Doesn't work because mac_ver doesn't work on newer macs with older Pythons. Ref #529.
      Use presence of Security.SecItemAdd to detect viable macOS API. Ref #529.
      Only run macOS backend tests when the backend is viable. Fixes #529. Fixes #547.
      Rename test to match preferred naming convention for macOS.
      Update changelog.
      Add compatibility note for macOS.
      Update changelog to replace 23.2.2 not released.

Kian-Meng, Ang (1):
      Fix typos

wwuck (2):
      Change get_credential to return generic Credential
      Update changelog and bump version.
  • Loading branch information
fenrus75 authored and clrpackages committed Dec 2, 2021
1 parent 581827d commit fcadda1
Show file tree
Hide file tree
Showing 8 changed files with 20 additions and 22 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := keyring
URL = https://files.pythonhosted.org/packages/cc/24/c5402ba0c6380cc058980e2b73f0597ab6875692f185054a94244b7161ab/keyring-23.2.1.tar.gz
URL = https://files.pythonhosted.org/packages/28/c7/a0800053712e3b9c8dc06072d71b1305239100a5d2eda5e6f183e2835837/keyring-23.3.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 2 additions & 0 deletions buildreq_cache
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
23.3.0
pypi(importlib_metadata)
27 changes: 13 additions & 14 deletions keyring.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,23 +3,22 @@
# Generated by: autospec.py
#
Name : keyring
Version : 23.2.1
Release : 107
URL : https://files.pythonhosted.org/packages/cc/24/c5402ba0c6380cc058980e2b73f0597ab6875692f185054a94244b7161ab/keyring-23.2.1.tar.gz
Source0 : https://files.pythonhosted.org/packages/cc/24/c5402ba0c6380cc058980e2b73f0597ab6875692f185054a94244b7161ab/keyring-23.2.1.tar.gz
Version : 23.3.0
Release : 108
URL : https://files.pythonhosted.org/packages/28/c7/a0800053712e3b9c8dc06072d71b1305239100a5d2eda5e6f183e2835837/keyring-23.3.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/28/c7/a0800053712e3b9c8dc06072d71b1305239100a5d2eda5e6f183e2835837/keyring-23.3.0.tar.gz
Summary : Store and access your passwords safely.
Group : Development/Tools
License : MIT Python-2.0
Requires: keyring-bin = %{version}-%{release}
Requires: keyring-license = %{version}-%{release}
Requires: keyring-python = %{version}-%{release}
Requires: keyring-python3 = %{version}-%{release}
Requires: importlib_metadata
Requires: jeepney
Requires: secretstorage
BuildRequires : buildreq-distutils3
BuildRequires : jeepney
BuildRequires : secretstorage
BuildRequires : pypi(importlib_metadata)
BuildRequires : pypi(setuptools)
BuildRequires : pypi(setuptools_scm)
BuildRequires : setuptools-python

%description
Expand Down Expand Up @@ -68,15 +67,15 @@ python3 components for the keyring package.


%prep
%setup -q -n keyring-23.2.1
cd %{_builddir}/keyring-23.2.1
%setup -q -n keyring-23.3.0
cd %{_builddir}/keyring-23.3.0

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1635746691
export SOURCE_DATE_EPOCH=1637856231
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand All @@ -86,7 +85,7 @@ export FCFLAGS="$FFLAGS -O3 -ffat-lto-objects -flto=auto "
export FFLAGS="$FFLAGS -O3 -ffat-lto-objects -flto=auto "
export CXXFLAGS="$CXXFLAGS -O3 -ffat-lto-objects -flto=auto "
export MAKEFLAGS=%{?_smp_mflags}
python3 setup.py build
python3 -m build --wheel --skip-dependency-check --no-isolation

%check
export http_proxy=http://127.0.0.1:9/
Expand All @@ -97,8 +96,8 @@ python setup.py ptr || :
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/keyring
cp %{_builddir}/keyring-23.2.1/LICENSE %{buildroot}/usr/share/package-licenses/keyring/8e6689d37f82d5617b7f7f7232c94024d41066d1
python3 -tt setup.py build install --root=%{buildroot}
cp %{_builddir}/keyring-23.3.0/LICENSE %{buildroot}/usr/share/package-licenses/keyring/8e6689d37f82d5617b7f7f7232c94024d41066d1
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
echo ----[ mark ]----
Expand Down
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = keyring
url = https://files.pythonhosted.org/packages/cc/24/c5402ba0c6380cc058980e2b73f0597ab6875692f185054a94244b7161ab/keyring-23.2.1.tar.gz
url = https://files.pythonhosted.org/packages/28/c7/a0800053712e3b9c8dc06072d71b1305239100a5d2eda5e6f183e2835837/keyring-23.3.0.tar.gz
archives =
giturl = https://github.com/jaraco/keyring.git
domain =
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
107
108
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
938e46b79fe90c2b069d7649f8ebd0389f42f191/keyring-23.2.1.tar.gz
f38eacc0d0ef8489b019877c4f96e146c77446da/keyring-23.3.0.tar.gz
2 changes: 1 addition & 1 deletion versions
Original file line number Diff line number Diff line change
@@ -1 +1 @@
23.2.1
23.3.0
3 changes: 0 additions & 3 deletions whatrequires
Original file line number Diff line number Diff line change
@@ -1,7 +1,4 @@
# This file contains recursive sources that require this package
Cura
conda
lutris
spyder-ide
twine
wheel

0 comments on commit fcadda1

Please sign in to comment.