Skip to content
This repository has been archived by the owner on Oct 27, 2022. It is now read-only.

Commit

Permalink
jaraco.text: Autospec creation for update from version 3.5.1 to versi…
Browse files Browse the repository at this point in the history
…on 3.6.0

Alan Fregtman (1):
      .editorconfig: Set max_line_length to 88 for Python files.

Jason R. Coombs (10):
      Rely on setuptools 56 and drop the explicit mention of the license file in favor of simple discovery.
      Remove workaround for python/typed_ast#156.
      Use line continuations to indicate which exclusions are for which workarounds.
      Remove blacken docs as it cannot honor Python's default repr. Ref adamchainz/blacken-docs#62.
      Drop Python 2 compatibility in FoldedCase
      Add intersphinx mappings for Python to prevent spurious nitpicky failures. Fixes jaraco/skeleton#51.
      Test on Python 3.10 (final).
      Rely on pytest 6 and drop workaround for pytest-dev/pytest#6178.
      Remove wheel from build requirements. It's implied for wheel builds. Ref pypa/setuptools#1498.
      Rely on importlib.resources traversable API. Fixes DeprecationWarning.
  • Loading branch information
fenrus75 committed Nov 1, 2021
1 parent a5e6e95 commit ebc5d34
Show file tree
Hide file tree
Showing 6 changed files with 18 additions and 15 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := jaraco.text
URL = https://files.pythonhosted.org/packages/53/d2/40ff557369eccee312b2d3ff4cb97373e8ffb25afb92294ff650a1e45795/jaraco.text-3.5.1.tar.gz
URL = https://files.pythonhosted.org/packages/08/73/05c5900892429841c6844bf8e8ef4dd4ca1df4b948bb249bfeb8b6e64dbf/jaraco.text-3.6.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
21 changes: 11 additions & 10 deletions jaraco.text.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,16 +3,17 @@
# Generated by: autospec.py
#
Name : jaraco.text
Version : 3.5.1
Release : 16
URL : https://files.pythonhosted.org/packages/53/d2/40ff557369eccee312b2d3ff4cb97373e8ffb25afb92294ff650a1e45795/jaraco.text-3.5.1.tar.gz
Source0 : https://files.pythonhosted.org/packages/53/d2/40ff557369eccee312b2d3ff4cb97373e8ffb25afb92294ff650a1e45795/jaraco.text-3.5.1.tar.gz
Version : 3.6.0
Release : 17
URL : https://files.pythonhosted.org/packages/08/73/05c5900892429841c6844bf8e8ef4dd4ca1df4b948bb249bfeb8b6e64dbf/jaraco.text-3.6.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/08/73/05c5900892429841c6844bf8e8ef4dd4ca1df4b948bb249bfeb8b6e64dbf/jaraco.text-3.6.0.tar.gz
Summary : Module for text manipulation
Group : Development/Tools
License : MIT
Requires: jaraco.text-license = %{version}-%{release}
Requires: jaraco.text-python = %{version}-%{release}
Requires: jaraco.text-python3 = %{version}-%{release}
Requires: importlib_resources
Requires: jaraco.functools
BuildRequires : buildreq-distutils3
BuildRequires : jaraco.functools
Expand Down Expand Up @@ -57,15 +58,15 @@ python3 components for the jaraco.text package.


%prep
%setup -q -n jaraco.text-3.5.1
cd %{_builddir}/jaraco.text-3.5.1
%setup -q -n jaraco.text-3.6.0
cd %{_builddir}/jaraco.text-3.6.0

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1629183207
export SOURCE_DATE_EPOCH=1635743560
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand All @@ -81,14 +82,14 @@ python3 setup.py build
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/jaraco.text
cp %{_builddir}/jaraco.text-3.5.1/LICENSE %{buildroot}/usr/share/package-licenses/jaraco.text/8e6689d37f82d5617b7f7f7232c94024d41066d1
cp %{_builddir}/jaraco.text-3.6.0/LICENSE %{buildroot}/usr/share/package-licenses/jaraco.text/8e6689d37f82d5617b7f7f7232c94024d41066d1
python3 -tt setup.py build install --root=%{buildroot}
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
echo ----[ mark ]----
## Remove excluded files
rm -f %{buildroot}/usr/lib/python3.*/site-packages/jaraco/__init__.py
rm -f %{buildroot}/usr/lib/python3.*/site-packages/jaraco/__pycache__/__init__.*
rm -f %{buildroot}*/usr/lib/python3.*/site-packages/jaraco/__init__.py
rm -f %{buildroot}*/usr/lib/python3.*/site-packages/jaraco/__pycache__/__init__.*

%files
%defattr(-,root,root,-)
Expand Down
4 changes: 3 additions & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = jaraco.text
url = https://files.pythonhosted.org/packages/53/d2/40ff557369eccee312b2d3ff4cb97373e8ffb25afb92294ff650a1e45795/jaraco.text-3.5.1.tar.gz
url = https://files.pythonhosted.org/packages/08/73/05c5900892429841c6844bf8e8ef4dd4ca1df4b948bb249bfeb8b6e64dbf/jaraco.text-3.6.0.tar.gz
archives =
giturl = https://github.com/jaraco/jaraco.text
domain =
Expand Down Expand Up @@ -47,6 +47,8 @@ optimize_size = false
pgo = false
# set flags for security-sensitive builds
security_sensitive = false
# package is only used by servers
server = false
# do not run test suite
skip_tests = false
# add .so files to the lib package instead of dev
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
16
17
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
75152eb03b72938402a0f57234e3b390d7d1fab9/jaraco.text-3.5.1.tar.gz
b2a530966d549f0cbaa239abc35d4436efc24487/jaraco.text-3.6.0.tar.gz
2 changes: 1 addition & 1 deletion versions
Original file line number Diff line number Diff line change
@@ -1 +1 @@
3.5.1
3.6.0

0 comments on commit ebc5d34

Please sign in to comment.