Skip to content
This repository has been archived by the owner on Oct 25, 2022. It is now read-only.

Commit

Permalink
[update to 8.1.1] Need to avoid .eggs in recursing dirs. Ref pypa/set…
Browse files Browse the repository at this point in the history
…uptools-scm#212.

Jason R. Coombs (65):
      Set the origin date once and forget it.
      Add python_requires directive.
      Don't bother with copyright year(s). Let the repository history track the changes and copyright years. YAGNI.
      Include the project (for docstrings). Include Sphinx (for environments where it's not an implied provision).
      Include pytest-sugar for nicer test output.
      Rely on jaraco.packaging for loading the package metadata from the package for Sphinx.
      Use single-quotes to satisfy the style nazis.
      The requirement is no longer needed for tests.
      Add readthedocs yml file
      Move requirements for docs and testing into extras
      Add appveyor script for CI testing on Windows.
      Require tox 2.4 or later; fixes #2.
      Remove namespace_packages declaration, no longer needed.
      Use a simple build number rather than prefixing with '1.0.'
      Restore support for namespace package declaration, selected on a 'nspkg_technique' setting
      Inspired by pypa/setuptools#1059, use the preferred bdist_wheel heading.
      Check the docs during tests
      Use stages in travis to have deployment depend on success in all Python versions.
      Remove 'bootstrap', artifact from setuptools
      --add doesn't work in a list
      Add a license file. Fixes jaraco/skeleton#1.
      Remove downloads shield, no longer available.
      Add documentation badge.
      Normalize indentation in docs/conf.py
      Declare 'python' factor at top level
      Correct travis syntax
      reference the license file in metadata
      Use https
      Add build-docs env in tox.
      Run only default environment by default.
      To support namespace packages, Setuptools must be 31.0.1. This change is necessary with the adoption of tox-venv, which uses Python's venv, which does not install the latest setuptools by default.
      Need to avoid .eggs in recursing dirs. Ref pypa/setuptools-scm#212.
      Use tox-venv for future compatibility.
      Disable pytest-sugar until Teemu/pytest-sugar#133 is addressed.
      Bring back pytest-sugar with a minimum version to support Pytest 3.4.
      Save the pip cache across builds. Ref pypa/setuptools#1279.
      Add workaround for build failures on Python 3.7 (yaml/pyyaml#126).
      Run flake8 with tests. Add flake8 config to ignore common exclusions. Add comments to testing and docs extras to aid with merges.
      Add appveyor badge (commented). Disable RTD by default.
      Limit workaround to affected Python
      Bump minimum pytest version
      Add pyproject.toml declaring build dependencies.
      When ignoring linter warnings, document the reason.
      Merge https://github.com/jaraco/skeleton
      Drop support for Python 2.6
      Feed the hobgoblins (delint).
      dos2unix
      Fix test failures by restoring working directory in fixtures.
      Fix test failures in checkdocs
      Remove setuptools plugin
      Use behavior from other packages
      dos2unix
      Use relative import
      Use packaging for version parsing
      Drop support for Python 2.7 and 3.4
      Revert "Remove setuptools plugin"
      Revert "Drop support for Python 2.7 and 3.4"
      Update changelog
      Use new style classes through the lib.
      Revert "Use packaging for version parsing"
      Revert "Use behavior from other packages"
      Rename util to _vendor
      Update iter_subclasses to latest version from jaraco.classes
      Update one from more_itertools
      Update changelog
  • Loading branch information
fenrus75 authored and djklimes committed May 14, 2018
1 parent 1f38163 commit 56a9e52
Show file tree
Hide file tree
Showing 7 changed files with 37 additions and 11 deletions.
23 changes: 23 additions & 0 deletions ChangeLog
Original file line number Diff line number Diff line change
@@ -1,3 +1,26 @@
8.1.1
=====

* Once again vendored dependencies to restore compatibility.

8.1
===

* Restored setuptools plugin support and Python 2.7 support to
support old packages forever.

8.0
===

* Removed setuptools plugin support. Library remains available for
programmatic control of repos.
* Drop support for Python 3.4 and earlier.

7.0
===

* Drop support for Python 2.6.

6.5
===

Expand Down
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := hgtools
URL = http://pypi.debian.net/hgtools/hgtools-6.5.2.tar.gz
URL = http://pypi.debian.net/hgtools/hgtools-8.1.1.tar.gz
ARCHIVES =

include ../common/Makefile.common
14 changes: 8 additions & 6 deletions hgtools.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,15 +3,17 @@
# Generated by: autospec.py
#
Name : hgtools
Version : 6.5.2
Release : 25
URL : http://pypi.debian.net/hgtools/hgtools-6.5.2.tar.gz
Source0 : http://pypi.debian.net/hgtools/hgtools-6.5.2.tar.gz
Version : 8.1.1
Release : 26
URL : http://pypi.debian.net/hgtools/hgtools-8.1.1.tar.gz
Source0 : http://pypi.debian.net/hgtools/hgtools-8.1.1.tar.gz
Summary : Classes and setuptools plugin for Mercurial and Git repositories
Group : Development/Tools
License : MIT
Requires: hgtools-python3
Requires: hgtools-python
Requires: Pygments
Requires: Sphinx
Requires: pytest
BuildRequires : pbr
BuildRequires : pip
Expand Down Expand Up @@ -49,14 +51,14 @@ python3 components for the hgtools package.


%prep
%setup -q -n hgtools-6.5.2
%setup -q -n hgtools-8.1.1

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C
export SOURCE_DATE_EPOCH=1519136640
export SOURCE_DATE_EPOCH=1526090190
python3 setup.py build -b py3

%install
Expand Down
4 changes: 3 additions & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = hgtools
url = http://pypi.debian.net/hgtools/hgtools-6.5.2.tar.gz
url = http://pypi.debian.net/hgtools/hgtools-8.1.1.tar.gz
archives =
giturl = https://github.com/jaraco/hgtools.git

Expand All @@ -17,6 +17,8 @@ autoupdate = false
broken_c++ = false
# disable parallelization during build
broken_parallel_build = false
# this package is a library compatability package and only ships versioned library files
compat = false
# set conservative build flags
conservative_flags = false
# pass -ffast-math to compiler
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
25
26
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
bdee1be07e29207a89914ca2fd3b73881b3a5f62/hgtools-6.5.2.tar.gz
7bc1107b0a7e946a1f830cb051108ab32aa0f4e5/hgtools-8.1.1.tar.gz
1 change: 0 additions & 1 deletion whatrequires
Original file line number Diff line number Diff line change
@@ -1,2 +1 @@
# This file contains recursive sources that require this package
keyring

0 comments on commit 56a9e52

Please sign in to comment.