-
Notifications
You must be signed in to change notification settings - Fork 86
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
amazon-kvs-producer-sdk-cpp: add PACKAGECONFIG gstreamer support, dis…
…able broken kvs_gstreamer_sample
- Loading branch information
1 parent
e1b6e10
commit 08d6203
Showing
2 changed files
with
43 additions
and
17 deletions.
There are no files selected for viewing
15 changes: 15 additions & 0 deletions
15
...dk/amazon-kvs-producer-sdk/amazon-kvs-producer-sdk-cpp/disable_kvs_gstreamer_sample.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 60ecca1..3ce58be 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -202,8 +207,8 @@ if(BUILD_GSTREAMER_PLUGIN) | ||
add_library(gstkvssink MODULE ${GST_PLUGIN_SOURCE_FILES}) | ||
target_link_libraries(gstkvssink PRIVATE ${GST_APP_LIBRARIES} KinesisVideoProducer) | ||
|
||
- add_executable(kvs_gstreamer_sample samples/kvs_gstreamer_sample.cpp) | ||
- target_link_libraries(kvs_gstreamer_sample ${GST_APP_LIBRARIES} KinesisVideoProducer) | ||
+ # add_executable(kvs_gstreamer_sample samples/kvs_gstreamer_sample.cpp) | ||
+ # target_link_libraries(kvs_gstreamer_sample ${GST_APP_LIBRARIES} KinesisVideoProducer) | ||
|
||
add_executable(kvs_gstreamer_multistream_sample samples/kvs_gstreamer_multistream_sample.cpp) | ||
target_link_libraries(kvs_gstreamer_multistream_sample ${GST_APP_LIBRARIES} KinesisVideoProducer) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters