Skip to content

Commit 32d2654

Browse files
authored
rosdistro sync, Mon Jul 24 18:24:27 2017 (#13)
* Signing the bbclasses so that we can modify stuff. * Added a temporary lunar directory * First ros-lunar recipes. (#1) * regenerate ros-lunar, Thu Jul 6 11:15:15 2017 * regenerate ros-lunar, Mon Jul 17 12:29:45 2017 (#4) * sophus: compile on x86-64 arch (resolves ros#497) This commit implements Christian Ege's suggestion in the meta-ros issue tracker to make gcc only warn on ignored template attributes. Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com> * regenerate ros-lunar, Mon Jul 17 13:43:54 2017 (#5) * regenerate ros-lunar, Thu Jul 20 10:46:00 2017 (#6) * regenerate ros-lunar, Thu Jul 20 12:28:02 2017 (#7) * Old version of geometry 2. * Old geometry build. * regenerate ros-lunar, Thu Jul 20 15:14:27 2017 (#8) * Added defusedxml bb * regenerate ros-lunar, Fri Jul 21 14:36:57 2017 (#9) * regenerate ros-lunar, Fri Jul 21 15:20:35 2017 (#10) * regenerate ros-lunar, Mon Jul 24 10:57:45 2017 (#11) * Bumped catkin version, as well as added a non-binary option for building catkin. * Necessary changes to get catkin working. * Remove extraneous recipes. * regenerate ros-lunar, Mon Jul 24 16:24:15 2017 (#12) * regenerate ros-lunar, Mon Jul 24 18:24:27 2017
1 parent 121b182 commit 32d2654

File tree

877 files changed

+14298
-13
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

877 files changed

+14298
-13
lines changed

classes/catkin.bbclass

+6-6
Original file line numberDiff line numberDiff line change
@@ -1,15 +1,15 @@
11
#
2+
# Copyright (c) 2017 Open Source Robotics Foundation, Inc.
23
# Copyright (c) 2013 Stefan Herbrechtsmeier, Bielefeld University
3-
#
4+
#
45

56
ROS_USE_PYTHON3 ??= "no"
67

78
inherit cmake ${@'distutils3-base' if bb.utils.to_boolean(d.getVar('ROS_USE_PYTHON3', True)) else 'distutils-base'} ros faulty-solibs
89

9-
DEPENDS_prepend = "${@'' if (d.getVar('BPN', True) == 'catkin') or (d.getVar('BPN', True) == 'catkin-runtime') else 'catkin-native '}"
10-
1110
EXTRA_OECMAKE_CATKIN = "\
12-
-DCMAKE_PREFIX_PATH='${STAGING_DIR_HOST}${ros_prefix};${STAGING_DIR_HOST}${prefix};${STAGING_DIR_NATIVE}${ros_prefix};${STAGING_DIR_NATIVE}${prefix}' \
11+
-DCMAKE_PREFIX_PATH='${STAGING_DIR_HOST}${ros_prefix};${STAGING_DIR_HOST}${prefix};\
12+
${STAGING_DIR_NATIVE}${ros_prefix};${STAGING_DIR_NATIVE}${prefix}' \
1313
-DCMAKE_INSTALL_PREFIX:PATH='${ros_prefix}' \
1414
"
1515

@@ -21,13 +21,13 @@ EXTRA_OECMAKE_CATKIN_class-native = "\
2121

2222
EXTRA_OECMAKE_prepend = "\
2323
${EXTRA_OECMAKE_CATKIN} \
24-
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
2524
-DSETUPTOOLS_DEB_LAYOUT=OFF \
2625
-DCATKIN_ENABLE_TESTING=0 \
26+
-DCATKIN_BUILD_BINARY_PACKAGE=${@'0' if bb.utils.to_boolean(d.getVar('CATKIN_NO_BIN', True)) else '1'} \
2727
"
2828

2929
OECMAKE_SOURCEPATH = "${S}"
30-
OECMAKE_BUILDPATH = "${S}/build"
30+
# OECMAKE_BUILDPATH = "${S}/build"
3131

3232
# Having a command like `find_package(catkin COMPONENTS roscpp)` in a package's CMakeLists.txt
3333
# leads to adding "-Wl,-rpath=${RECIPE_SYSROOT}${ros_libdir}" option to the cross-linker.

classes/faulty-solibs.bbclass

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
# Ideally, the software packages upstream should be fixed to provide dynamic
22
# libraries with version number and symlinks without version number to them.
3-
# This class sets up bitbake to handle improper set up software packages.
3+
# This class sets up bitbake to handle improper set up software packages.
44
FILES_SOLIBSDEV = ""
55
FILES_${PN} += "${libdir}/lib*${SOLIBSDEV}"

classes/ros.bbclass

+1
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,5 @@
11
#
2+
# Copyright (c) 2017 Open Source Robotics Foundation, Inc.
23
# Copyright (c) 2013 Stefan Herbrechtsmeier, Bielefeld University
34
#
45

recipes-devtools/python/python-catkin-pkg.inc

+3-3
Original file line numberDiff line numberDiff line change
@@ -4,9 +4,9 @@ LICENSE = "BSD"
44
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
55
SRCNAME = "catkin_pkg"
66

7-
SRC_URI = "https://pypi.python.org/packages/source/c/catkin_pkg/catkin_pkg-${PV}.tar.gz"
8-
SRC_URI[md5sum] = "da93566c65dddfa9f821e18944c5ee5e"
9-
SRC_URI[sha256sum] = "d4d069eaeb29d6a9ee71773b20c41515b6e0feb9ea2765ebaf3e599d0ceef050"
7+
SRC_URI = "http://download.ros.org/downloads/catkin_pkg/catkin_pkg-${PV}.tar.gz"
8+
9+
DEPENDS = "python-setuptools"
1010

1111
S = "${WORKDIR}/${SRCNAME}-${PV}"
1212

recipes-devtools/python/python-catkin-pkg_0.2.10.bb

-3
This file was deleted.
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,7 @@
1+
require python-catkin-pkg.inc
2+
3+
SRC_URI[md5sum] = "de01650bbec245d53f72682ed7ab13e5"
4+
SRC_URI[sha256sum] = "434b25fcfec016d10778297c845365de2be6d305b7eab91195d08ceb5b19d354"
5+
6+
inherit setuptools
7+
inherit distutils
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,13 @@
1+
DESCRIPTION = "XML bomb protection for Python stdlib modules"
2+
SECTION = "devel/python"
3+
LICENSE = "PSFL"
4+
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=a560e172e996ab553d352ccff41c7d20"
5+
SRCNAME = "defusedxml"
6+
7+
SRC_URI = "http://pypi.python.org/packages/source/d/defusedxml/defusedxml-${PV}.tar.gz"
8+
SRC_URI[md5sum] = "230a5eff64f878b392478e30376d673a"
9+
SRC_URI[sha256sum] = "cd551d5a518b745407635bb85116eb813818ecaf182e773c35b36239fc3f2478"
10+
11+
S = "${WORKDIR}/${SRCNAME}-${PV}"
12+
13+
inherit setuptools
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
# Copyright 2017 Open Source Robotics Foundation
2+
# Distributed under the terms of the BSD license
3+
4+
DESCRIPTION = "ROS messages for robots using Ackermann steering."
5+
AUTHOR = "OSRF"
6+
SECTION = "devel"
7+
LICENSE = "BSD"
8+
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
9+
10+
DEPENDS = "catkin-native message-generation message-runtime std-msgs"
11+
SRC_URI = "https://github.com/ros-drivers-gbp/ackermann_msgs-release/archive/release/lunar/ackermann_msgs/1.0.1-0.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
12+
13+
SRC_URI[md5sum] = "f5ea5b7da256fa43368bc83815e7615e"
14+
SRC_URI[sha256sum] = "8b8598ad6531461ad8f7e352a64277c94dbc0a243ecd14f5c6fe1723554af40b"
15+
S = "${WORKDIR}/ackermann_msgs-release-release-lunar-ackermann_msgs-1.0.1-0"
16+
17+
inherit catkin
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
# Copyright 2017 Open Source Robotics Foundation
2+
# Distributed under the terms of the BSD license
3+
4+
DESCRIPTION = "actionlib_lisp is a native implementation of the famous actionlib in Common L"
5+
AUTHOR = "OSRF"
6+
SECTION = "devel"
7+
LICENSE = "BSD"
8+
LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9dedc494f5f793a6690ba5"
9+
10+
DEPENDS = "actionlib-msgs catkin-native cl-utils message-runtime roslisp"
11+
SRC_URI = "https://github.com/ros-gbp/roslisp_common-release/archive/release/lunar/actionlib_lisp/0.2.9-0.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
12+
13+
SRC_URI[md5sum] = "fcb02c9bf642d1bde36ac70a6267dfd8"
14+
SRC_URI[sha256sum] = "4a35980cab90de0cafb113adee7c74712a0787cb64af6275179c26e8f9c95c60"
15+
S = "${WORKDIR}/roslisp_common-release-release-lunar-actionlib_lisp-0.2.9-0"
16+
17+
inherit catkin
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
# Copyright 2017 Open Source Robotics Foundation
2+
# Distributed under the terms of the BSD license
3+
4+
DESCRIPTION = "actionlib_msgs defines the common messages to interact with an action serve"
5+
AUTHOR = "OSRF"
6+
SECTION = "devel"
7+
LICENSE = "BSD"
8+
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
9+
10+
DEPENDS = "catkin-native message-generation message-runtime std-msgs"
11+
SRC_URI = "https://github.com/ros-gbp/common_msgs-release/archive/release/lunar/actionlib_msgs/1.12.5-0.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
12+
13+
SRC_URI[md5sum] = "bd228335e40175348acad1bf68b9aa80"
14+
SRC_URI[sha256sum] = "8b427fc6c67668de43bd07b0dbd5e6c800b38a8e4b5542cdf1a1cf591e475957"
15+
S = "${WORKDIR}/common_msgs-release-release-lunar-actionlib_msgs-1.12.5-0"
16+
17+
inherit catkin
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
# Copyright 2017 Open Source Robotics Foundation
2+
# Distributed under the terms of the BSD license
3+
4+
DESCRIPTION = "The actionlib_tutorials package"
5+
AUTHOR = "OSRF"
6+
SECTION = "devel"
7+
LICENSE = "BSD"
8+
LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
9+
10+
DEPENDS = "actionlib actionlib-msgs catkin-native message-generation message-runtime roscpp std-msgs"
11+
SRC_URI = "https://github.com/ros-gbp/common_tutorials-release/archive/release/lunar/actionlib_tutorials/0.1.10-0.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
12+
13+
SRC_URI[md5sum] = "c62eb2b3ec9265ca6e79ba90fce76317"
14+
SRC_URI[sha256sum] = "3b060785dae27b5af99636cfebe5f72b91ac9a98ab2e2dec977378fbc6ccf4c1"
15+
S = "${WORKDIR}/common_tutorials-release-release-lunar-actionlib_tutorials-0.1.10-0"
16+
17+
inherit catkin
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
# Copyright 2017 Open Source Robotics Foundation
2+
# Distributed under the terms of the BSD license
3+
4+
DESCRIPTION = "The actionlib stack provides a standardized interface for interfacing with p"
5+
AUTHOR = "OSRF"
6+
SECTION = "devel"
7+
LICENSE = "BSD"
8+
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
9+
10+
DEPENDS = "actionlib-msgs boost catkin-native message-generation message-runtime roscpp rospy rostest std-msgs"
11+
SRC_URI = "https://github.com/ros-gbp/actionlib-release/archive/release/lunar/actionlib/1.11.9-0.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
12+
13+
SRC_URI[md5sum] = "fb49a284ef56bb7f6a39f3ef027f3c7b"
14+
SRC_URI[sha256sum] = "fb0081a243e50a7514f8b4da04125386b65bad59aa6183502001ec9345177c30"
15+
S = "${WORKDIR}/actionlib-release-release-lunar-actionlib-1.11.9-0"
16+
17+
inherit catkin

recipes-ros-lunar/amcl/amcl_1.14.0.bb

+17
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
# Copyright 2017 Open Source Robotics Foundation
2+
# Distributed under the terms of the BSD license
3+
4+
DESCRIPTION = "None"
5+
AUTHOR = "OSRF"
6+
SECTION = "devel"
7+
LICENSE = "LGPL"
8+
LIC_FILES_CHKSUM = "file://package.xml;beginline=21;endline=21;md5=58d727014cda5ed405b7fb52666a1f97"
9+
10+
DEPENDS = "catkin-native dynamic-reconfigure message-filters nav-msgs rosbag roscpp rostest std-srvs tf"
11+
SRC_URI = "https://github.com/ros-gbp/navigation-release/archive/release/lunar/amcl/1.14.0-0.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
12+
13+
SRC_URI[md5sum] = "394f34809182b91b257fc94770fa2ad9"
14+
SRC_URI[sha256sum] = "000c8ca8526ac126fb93ca6bcb3f24c94f062e6ec40c6308e3d641ab6d1fb579"
15+
S = "${WORKDIR}/navigation-release-release-lunar-amcl-1.14.0-0"
16+
17+
inherit catkin
+17
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
# Copyright 2017 Open Source Robotics Foundation
2+
# Distributed under the terms of the BSD license
3+
4+
DESCRIPTION = "This package provides a set of simple math utilities to work with angles"
5+
AUTHOR = "OSRF"
6+
SECTION = "devel"
7+
LICENSE = "BSD"
8+
LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9dedc494f5f793a6690ba5"
9+
10+
DEPENDS = "catkin-native"
11+
SRC_URI = "https://github.com/ros-gbp/geometry_angles_utils-release/archive/release/lunar/angles/1.9.11-0.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
12+
13+
SRC_URI[md5sum] = "7defdab86e662fac81aca7605ccfea7e"
14+
SRC_URI[sha256sum] = "e8deedc60c1f06c276cc1cd26017bdb4a651ff60f2a542584d28f8d493f02cea"
15+
S = "${WORKDIR}/geometry_angles_utils-release-release-lunar-angles-1.9.11-0"
16+
17+
inherit catkin
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,14 @@
1+
DESCRIPTION = "This package is a ROS wrapper for Alvar, an open source AR tag tracking library."
2+
SECTION = "devel"
3+
LICENSE = "BSD"
4+
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
5+
6+
DEPENDS = "message-generation geometry-msgs std-msgs"
7+
8+
SRC_URI = "https://github.com/sniekum/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
9+
SRC_URI[md5sum] = "c82bf63ab8ab5630fedc29e872138fc9"
10+
SRC_URI[sha256sum] = "27e4ebed675c79b41a545614f5a95798c1740e487b65fc45ac356c7298330a80"
11+
12+
S = "${WORKDIR}/${ROS_SP}"
13+
14+
inherit catkin
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
# Copyright 2017 Open Source Robotics Foundation
2+
# Distributed under the terms of the BSD license
3+
4+
DESCRIPTION = "This package is a ROS wrapper for Alvar, an open source AR tag tracking library."
5+
AUTHOR = "OSRF"
6+
SECTION = "devel"
7+
LICENSE = "BSD"
8+
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
9+
10+
DEPENDS = "catkin-native geometry-msgs message-generation message-runtime std-msgs"
11+
SRC_URI = "https://github.com/ros-gbp/ar_track_alvar-release/archive/release/lunar/ar_track_alvar_msgs/0.7.1-0.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
12+
13+
SRC_URI[md5sum] = "4667142f331b86e49c94e43d38f8cf4d"
14+
SRC_URI[sha256sum] = "c0682bbc76d3ca88e8b58a15d474d7c5a048b877c45e8751765fd39352fd8139"
15+
S = "${WORKDIR}/ar_track_alvar-release-release-lunar-ar_track_alvar_msgs-0.7.1-0"
16+
17+
inherit catkin
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,14 @@
1+
DESCRIPTION = "This package is a ROS wrapper for Alvar, an open source AR tag tracking library."
2+
SECTION = "devel"
3+
LICENSE = "LGPL-2.1"
4+
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=061abe8dc89f326789675967c8760541"
5+
6+
DEPENDS = "ar-track-alvar-msgs cmake-modules cv-bridge image-transport libtinyxml pcl-ros resource-retriever roscpp tf visualization-msgs"
7+
8+
SRC_URI = "https://github.com/sniekum/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
9+
SRC_URI[md5sum] = "e293fe0ffc37232beca6494ef76ae5ea"
10+
SRC_URI[sha256sum] = "c34ff4358fb167edccc4357d74425e3370691f04be1f8971f5258aa25dd6ff9b"
11+
12+
S = "${WORKDIR}/${ROS_SP}"
13+
14+
inherit catkin
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
# Copyright 2017 Open Source Robotics Foundation
2+
# Distributed under the terms of the BSD license
3+
4+
DESCRIPTION = "This package is a ROS wrapper for Alvar, an open source AR tag tracking library."
5+
AUTHOR = "OSRF"
6+
SECTION = "devel"
7+
LICENSE = "LGPL-2.1"
8+
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=061abe8dc89f326789675967c8760541"
9+
10+
DEPENDS = "ar-track-alvar-msgs catkin-native cmake-modules cv-bridge dynamic-reconfigure geometry-msgs image-transport message-generation message-runtime pcl-conversions pcl-ros resource-retriever roscpp rospy sensor-msgs std-msgs tf tf2 libtinyxml visualization-msgs"
11+
SRC_URI = "https://github.com/ros-gbp/ar_track_alvar-release/archive/release/lunar/ar_track_alvar/0.7.1-0.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
12+
13+
SRC_URI[md5sum] = "312e5236aa915958300193c05670cee8"
14+
SRC_URI[sha256sum] = "d2700ee96bcf3a7fcdc90ed098e8724cd1a01bf3ec973782f3c8ee7d5294b9b2"
15+
S = "${WORKDIR}/ar_track_alvar-release-release-lunar-ar_track_alvar-0.7.1-0"
16+
17+
inherit catkin
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,10 @@
1+
DESCRIPTION = "Messages for transmitting audio via ROS"
2+
SECTION = "devel"
3+
LICENSE = "BSD"
4+
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=a3ae2ba3f0f44e61270955e8cd98afcf"
5+
6+
DEPENDS += "message-generation"
7+
8+
require audio-common.inc
9+
10+
RRECOMMENDS_${PN} += "message-runtime"
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,9 @@
1+
SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
2+
SRC_URI[md5sum] = "93f710014398298bdd8403cd7cf2d084"
3+
SRC_URI[sha256sum] = "c1cdb8cbf999020fb6c97f45de1ddb39fc4712dd7cf48e6a296e5b3a8695d336"
4+
5+
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
6+
7+
inherit catkin
8+
9+
ROS_SPN = "audio_common"
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,35 @@
1+
From ecdde483c81fb89e35f025ee3aacba7cd45528ab Mon Sep 17 00:00:00 2001
2+
From: Alexis Ballier <aballier@gentoo.org>
3+
Date: Fri, 4 Dec 2015 12:38:42 +0100
4+
Subject: [PATCH 2/2] sound_play: Fix build with -DCATKIN_ENABLE_TESTING=OFF.
5+
6+
https://bugs.gentoo.org/show_bug.cgi?id=567466
7+
8+
Upstream-Status: Backport [commit ecdde483c81fb89e35f025ee3aacba7cd45528ab]
9+
10+
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
11+
---
12+
sound_play/CMakeLists.txt | 6 ++++--
13+
1 file changed, 4 insertions(+), 2 deletions(-)
14+
15+
diff --git a/sound_play/CMakeLists.txt b/sound_play/CMakeLists.txt
16+
index ada0b07..3f9604c 100644
17+
--- a/sound_play/CMakeLists.txt
18+
+++ b/sound_play/CMakeLists.txt
19+
@@ -16,9 +16,11 @@ generate_messages(DEPENDENCIES actionlib_msgs)
20+
catkin_package(CATKIN_DEPENDS message_runtime actionlib_msgs
21+
INCLUDE_DIRS include)
22+
23+
-catkin_add_nosetests(scripts/test)
24+
+if(CATKIN_ENABLE_TESTING)
25+
+ catkin_add_nosetests(scripts/test)
26+
27+
-add_subdirectory(test)
28+
+ add_subdirectory(test)
29+
+endif()
30+
31+
install(PROGRAMS
32+
scripts/playbuiltin.py
33+
--
34+
2.4.3
35+
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,16 @@
1+
DESCRIPTION = "sound_play provides a ROS node that translates commands on a ROS topic \
2+
(<tt>robotsound</tt>) into sounds. The node supports built-in sounds, playing OGG/WAV files, \
3+
and doing speech synthesis via festival. C++ and Python bindings allow this node to be used \
4+
without understanding the details of the message format, allowing faster development and \
5+
resilience to message format changes."
6+
SECTION = "devel"
7+
LICENSE = "BSD"
8+
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=a3ae2ba3f0f44e61270955e8cd98afcf"
9+
10+
DEPENDS += "roscpp roslib audio-common-msgs diagnostic-msgs"
11+
12+
require audio-common.inc
13+
14+
SRC_URI += "file://0002-sound_play-Fix-build-with-DCATKIN_ENABLE_TESTING-OFF.patch;striplevel=2"
15+
16+
RRECOMMENDS_${PN} += "roscpp roslib audio-common-msgs diagnostic-msgs gst-plugins-base gst-plugins-ugly gst-plugins-good rospy festival python-gst gst-meta-audio"
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
# Copyright 2017 Open Source Robotics Foundation
2+
# Distributed under the terms of the BSD license
3+
4+
DESCRIPTION = "This package provides message types commonly used with Autonomous Underwater Veh"
5+
AUTHOR = "OSRF"
6+
SECTION = "devel"
7+
LICENSE = "BSD"
8+
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
9+
10+
DEPENDS = "catkin-native geographic-msgs geometry-msgs message-generation message-runtime sensor-msgs std-msgs"
11+
SRC_URI = "https://github.com/oceansystemslab/auv_msgs-release/archive/release/lunar/auv_msgs/0.0.1-0.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
12+
13+
SRC_URI[md5sum] = "e037a7998c06d5be63563072ddfd1cc0"
14+
SRC_URI[sha256sum] = "b2f400971dce22133722a0b5a6d0615659823e921d0f011de22ee32e1bea5b26"
15+
S = "${WORKDIR}/auv_msgs-release-release-lunar-auv_msgs-0.0.1-0"
16+
17+
inherit catkin
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
# Copyright 2017 Open Source Robotics Foundation
2+
# Distributed under the terms of the BSD license
3+
4+
DESCRIPTION = "This package provides implementations of the Trajectory Rollout and Dynamic Wind"
5+
AUTHOR = "OSRF"
6+
SECTION = "devel"
7+
LICENSE = "BSD"
8+
LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=01c2bc31767ccb3a68e12f02612b2a97"
9+
10+
DEPENDS = "angles catkin-native cmake-modules costmap-2d dynamic-reconfigure eigen geometry-msgs message-generation nav-core nav-msgs pcl-conversions pcl-ros pluginlib rosconsole roscpp rospy std-msgs tf visualization-msgs voxel-grid"
11+
SRC_URI = "https://github.com/ros-gbp/navigation-release/archive/release/lunar/base_local_planner/1.14.0-0.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
12+
13+
SRC_URI[md5sum] = "b34b8657b699af53380427ace05e3ede"
14+
SRC_URI[sha256sum] = "8c3978ada988b04ec547aafaf1532bd56104ed7549e974913f6c042c406d4c9a"
15+
S = "${WORKDIR}/navigation-release-release-lunar-base_local_planner-1.14.0-0"
16+
17+
inherit catkin

0 commit comments

Comments
 (0)