Skip to content

Commit

Permalink
linux-raspberrypi-4.4: Add the pitft22 overlay from adafruit
Browse files Browse the repository at this point in the history
Upgrade to 4.4.6

Signed-off-by: Khem Raj <raj.khem@gmail.com>
  • Loading branch information
kraj authored and agherzan committed Mar 28, 2016
1 parent 38ab74b commit 75efa69
Show file tree
Hide file tree
Showing 2 changed files with 113 additions and 3 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,106 @@
From a28bd410022b32a64e208f04b45add6326990332 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petter=20Mab=C3=A4cker?= <petter@technux.se>
Date: Fri, 8 Jan 2016 09:02:44 +0100
Subject: [PATCH] dts: add overlay for pitft22
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Upstream-Status: Pending

Add the pitft22 overlay from adafruit Adafruit-Pi-Kernel-o-Matic repo:
https://github.com/adafruit/Adafruit-Pi-Kernel-o-Matic

Signed-off-by: Petter Mabäcker <petter@technux.se>
---
arch/arm/boot/dts/overlays/Makefile | 1 +
arch/arm/boot/dts/overlays/pitft22-overlay.dts | 69 ++++++++++++++++++++++++++
2 files changed, 70 insertions(+)
create mode 100755 arch/arm/boot/dts/overlays/pitft22-overlay.dts

Index: kernel-source/arch/arm/boot/dts/overlays/pitft22-overlay.dts
===================================================================
--- /dev/null
+++ kernel-source/arch/arm/boot/dts/overlays/pitft22-overlay.dts
@@ -0,0 +1,69 @@
+/*
+ * Device Tree overlay for pitft by Adafruit
+ *
+ */
+
+/dts-v1/;
+/plugin/;
+
+/ {
+ compatible = "brcm,bcm2835", "brcm,bcm2708", "brcm,bcm2709";
+
+ fragment@0 {
+ target = <&spi0>;
+ __overlay__ {
+ status = "okay";
+
+ spidev@0{
+ status = "disabled";
+ };
+
+ spidev@1{
+ status = "disabled";
+ };
+ };
+ };
+
+ fragment@1 {
+ target = <&gpio>;
+ __overlay__ {
+ pitft_pins: pitft_pins {
+ brcm,pins = <25>;
+ brcm,function = <1>; /* out */
+ brcm,pull = <0>; /* none */
+ };
+ };
+ };
+
+ fragment@2 {
+ target = <&spi0>;
+ __overlay__ {
+ /* needed to avoid dtc warning */
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ pitft: pitft@0{
+ compatible = "ilitek,ili9340";
+ reg = <0>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&pitft_pins>;
+
+ spi-max-frequency = <32000000>;
+ rotate = <90>;
+ fps = <25>;
+ bgr;
+ buswidth = <8>;
+ dc-gpios = <&gpio 25 0>;
+ debug = <0>;
+ };
+
+ };
+ };
+
+ __overrides__ {
+ speed = <&pitft>,"spi-max-frequency:0";
+ rotate = <&pitft>,"rotate:0";
+ fps = <&pitft>,"fps:0";
+ debug = <&pitft>,"debug:0";
+ };
+};
Index: kernel-source/arch/arm/boot/dts/overlays/Makefile
===================================================================
--- kernel-source.orig/arch/arm/boot/dts/overlays/Makefile
+++ kernel-source/arch/arm/boot/dts/overlays/Makefile
@@ -43,6 +43,7 @@ dtbo-$(RPI_DT_OVERLAYS) += pi3-disable-b
dtbo-$(RPI_DT_OVERLAYS) += pi3-miniuart-bt.dtbo
dtbo-$(RPI_DT_OVERLAYS) += piscreen.dtbo
dtbo-$(RPI_DT_OVERLAYS) += piscreen2r.dtbo
+dtbo-$(RPI_DT_OVERLAYS) += pitft22-overlay.dtbo
dtbo-$(RPI_DT_OVERLAYS) += pitft28-capacitive.dtbo
dtbo-$(RPI_DT_OVERLAYS) += pitft28-resistive.dtbo
dtbo-$(RPI_DT_OVERLAYS) += pps-gpio.dtbo
10 changes: 7 additions & 3 deletions recipes-kernel/linux/linux-raspberrypi_4.4.bb
Original file line number Diff line number Diff line change
@@ -1,6 +1,10 @@
LINUX_VERSION ?= "4.4.3"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"

SRCREV = "36babd89241c85258acebe06616f1f1a58356f8e"
SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=rpi-4.4.y"
LINUX_VERSION ?= "4.4.6"

SRCREV = "2faaa2ccef9e4c595bd26f14285c225ceea6097e"
SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=rpi-4.4.y \
file://0001-dts-add-overlay-for-pitft22.patch \
"

require linux-raspberrypi.inc

0 comments on commit 75efa69

Please sign in to comment.