Skip to content

Commit

Permalink
webkitgtk3: Fix build with ICU-76+
Browse files Browse the repository at this point in the history
Signed-off-by: Khem Raj <raj.khem@gmail.com>
  • Loading branch information
kraj committed Nov 23, 2024
1 parent 5ecf9e7 commit 9d1fa63
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
From 57b80aa00be614218552fda67b2bf8d535b4f4cf Mon Sep 17 00:00:00 2001
From: Jason Schonberg <schonm@gmail.com>
Date: Wed, 20 Nov 2024 11:05:52 -0500
Subject: [PATCH] Support ICU 76.1 build

https://bugs.webkit.org/show_bug.cgi?id=282120

Reviewed by Yusuke Suzuki.

In ICU 76.1 an additional macro `U_SHOW_CPLUSPLUS_HEADER_API` was added to
control visibility of the C++ API within ICU. Set this value to `0` since WebKit
wants to only use the C API.

* Source/WTF/wtf/Platform.h:

Canonical link: https://commits.webkit.org/285727@main

Upstream-Status: Backport [ from webkitgtk-2.47.1 https://github.com/WebKit/WebKit/commit/63f7badbada070ebaadd318b2801818ecf7e7ea0 ]

Signed-off-by: Jason Schonberg <schonm@gmail.com>
---
Source/WTF/wtf/Platform.h | 1 +
1 file changed, 1 insertion(+)

diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
index 23070df2..51a8dce9 100644
--- a/Source/WTF/wtf/Platform.h
+++ b/Source/WTF/wtf/Platform.h
@@ -115,6 +115,7 @@
/* ICU configuration. Some of these match ICU defaults on some platforms, but we would like them consistently set everywhere we build WebKit. */
#define U_HIDE_DEPRECATED_API 1
#define U_SHOW_CPLUSPLUS_API 0
+#define U_SHOW_CPLUSPLUS_HEADER_API 0
#ifdef __cplusplus
#define UCHAR_TYPE char16_t
#endif
1 change: 1 addition & 0 deletions meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.3.bb
Original file line number Diff line number Diff line change
Expand Up @@ -17,6 +17,7 @@ SRC_URI = "https://www.webkitgtk.org/releases/webkitgtk-${PV}.tar.xz \
file://30e1d5e22213fdaca2a29ec3400c927d710a37a8.patch \
file://0001-Fix-build-issues-with-latest-Clang.patch \
file://fff1b1773bff2ef7c3b867ab019d69faa36c010d.patch \
file://0001-Support-ICU-76.1-build.patch \
"
SRC_URI[sha256sum] = "dc82d042ecaca981a4852357c06e5235743319cf10a94cd36ad41b97883a0b54"

Expand Down

0 comments on commit 9d1fa63

Please sign in to comment.