Skip to content

Commit

Permalink
pistache : add initial recipe
Browse files Browse the repository at this point in the history
Signed-off-by: Khem Raj <raj.khem@gmail.com>
  • Loading branch information
embetrix authored and kraj committed Jan 14, 2025
1 parent feb01f2 commit 137ad12
Showing 1 changed file with 35 additions and 0 deletions.
35 changes: 35 additions & 0 deletions meta-oe/recipes-devtools/pistache/pistache_0.4.26.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
SUMMARY = "A high-performance REST toolkit written in C++"
HOMEPAGE = "https://pistacheio.github.io/pistache"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"

SRC_URI = "git://github.com/pistacheio/pistache.git;branch=master;protocol=https"
# SRCREV tagged 0.4.26
SRCREV = "ddffda861aa49012dcda28f1362d0339e718cd52"

S = "${WORKDIR}/git"

DEPENDS = "openssl brotli zlib zstd rapidjson"

inherit pkgconfig meson

PACKAGECONFIG ?= "openssl brotli deflate zstd examples"
PACKAGECONFIG[openssl] = "-DPISTACHE_USE_SSL=true, -DPISTACHE_USE_SSL=false"
PACKAGECONFIG[brotli] = "-DPISTACHE_USE_CONTENT_ENCODING_BROTLI=true, -DPISTACHE_USE_CONTENT_ENCODING_BROTLI=false"
PACKAGECONFIG[deflate] = "-DPISTACHE_USE_CONTENT_ENCODING_DEFLATE=true, -DPISTACHE_USE_CONTENT_ENCODING_DEFLATE=false"
PACKAGECONFIG[zstd] = "-DPISTACHE_USE_CONTENT_ENCODING_ZSTD=true, -DPISTACHE_USE_CONTENT_ENCODING_ZSTD=false"
PACKAGECONFIG[examples] = "-DPISTACHE_BUILD_EXAMPLES=true, -DPISTACHE_BUILD_EXAMPLES=false"
PACKAGECONFIG[test] = "-DPISTACHE_BUILD_TESTS=true, -DPISTACHE_BUILD_TESTS=false"

do_install:append () {
install -d ${D}${bindir}
rm -rf ${B}/examples/*.p/
install -m 0755 ${B}/examples/run* ${D}${bindir}/
}

PACKAGES += "${PN}-examples"
FILES:${PN}:remove = " ${bindir}/*"
RDEPENDS:${PN}-examples += "${PN}"
FILES:${PN}-examples = "${bindir}"

BBCLASSEXTEND = "native nativesdk"

0 comments on commit 137ad12

Please sign in to comment.