-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
devel/py-python-bugzilla: Fix for API key leak
From Ricardo Branco in PR pkg/58213. Fixes #138.
- Loading branch information
Showing
3 changed files
with
30 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,6 @@ | ||
$NetBSD: distinfo,v 1.5 2022/07/08 14:01:33 wiz Exp $ | ||
$NetBSD: distinfo,v 1.6 2024/04/29 18:57:35 bsiegert Exp $ | ||
|
||
BLAKE2s (python-bugzilla-3.2.0.tar.gz) = d92cf6d3e3defd7f44349756507f631041851581395b3a303159d692201f441d | ||
SHA512 (python-bugzilla-3.2.0.tar.gz) = 215945a0ffd637be5567839303a738a0eef74427838bf0074a5f0ab6022306f47fc0dd5c43a3513b627fb458711f38046321ee9c2c3d43b61ffc577d6dd12375 | ||
Size (python-bugzilla-3.2.0.tar.gz) = 114279 bytes | ||
SHA1 (patch-bugzilla___session.py) = 134ed66dae860195941dfc9c908b525a11112246 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
$NetBSD: patch-bugzilla___session.py,v 1.1 2024/04/29 18:57:35 bsiegert Exp $ | ||
|
||
Fix for API key leak, https://github.com/python-bugzilla/python-bugzilla/issues/187 | ||
--- bugzilla/_session.py.orig 2021-10-05 20:49:16.000000000 +0000 | ||
+++ bugzilla/_session.py | ||
@@ -97,14 +97,14 @@ class _BugzillaSession(object): | ||
if "timeout" not in kwargs: | ||
kwargs["timeout"] = timeout | ||
|
||
- response = self._session.request(*args, **kwargs) | ||
+ try: | ||
+ response = self._session.request(*args, **kwargs) | ||
|
||
- if self._is_xmlrpc: | ||
- # Yes this still appears to matter for properly decoding unicode | ||
- # code points in bugzilla.redhat.com content | ||
- response.encoding = "UTF-8" | ||
+ if self._is_xmlrpc: | ||
+ # Yes this still appears to matter for properly decoding unicode | ||
+ # code points in bugzilla.redhat.com content | ||
+ response.encoding = "UTF-8" | ||
|
||
- try: | ||
response.raise_for_status() | ||
except Exception as e: | ||
# Scrape the api key out of the returned exception string |