Skip to content

Commit

Permalink
(www/R-gh) Updated 1.3.0 to 1.4.1, make test passed
Browse files Browse the repository at this point in the history
# gh 1.4.1

* `gh_next()`, `gh_prev()`, `gh_first()` and `gh_last()`
  now work correctly again (#181).

* When the user sets `.destfile` to write the response to disk, gh now
  writes the output to a temporary file, which is then renamed to
  `.destfile` after performing the request, or deleted on error (#178).

# gh 1.4.0

* `gh()` gains a new `.max_rate` parameter that sets the maximum number of
  requests per second.

* gh is now powered by httr2. This should generally have little impact on normal
  operation but if a request fails, you can use `httr2::last_response()` and
  `httr2::last_request()` to debug.

* `gh()` gains a new `.max_wait` argument which gives the maximum number of
  minutes to wait if you are rate limited (#67).

* New `gh_rate_limits()` function reports on all rate limits for the active
  user.

* gh can now validate GitHub

  [fine-grained](https://github.blog/2022-10-18-introducing-fine-grained-personal-access-tokens-for-github/)
  personal access tokens (@jvstein, #171).

# gh 1.3.1

* gh now accepts lower-case methods i.e. both `gh::gh("get /users/hadley/repos")` and `gh::gh("GET /users/hadley/repos")` work (@maelle, #167).

* Response headers (`"response_headers"`) and response content
  (`"response_content")` are now returned in error conditions so that error
  handlers can use information, such as the rate limit reset header, when
  handling `github_error`s (@gadenbuie, #117).
  • Loading branch information
mef committed Dec 30, 2024
1 parent 762e58e commit c0c0db5
Show file tree
Hide file tree
Showing 2 changed files with 17 additions and 9 deletions.
18 changes: 13 additions & 5 deletions www/R-gh/Makefile
Original file line number Diff line number Diff line change
@@ -1,18 +1,20 @@
# $NetBSD: Makefile,v 1.4 2021/08/31 10:39:28 mef Exp $
# $NetBSD: Makefile,v 1.5 2024/12/30 12:32:34 mef Exp $

R_PKGNAME= gh
R_PKGVER= 1.3.0
R_PKGVER= 1.4.1
CATEGORIES= www

MAINTAINER= pkgsrc-users@NetBSD.org
COMMENT= GitHub API
LICENSE= mit

DEPENDS+= R-cli>=2.0.1:../../devel/R-cli
DEPENDS+= R-gitcreds-[0-9]*:../../security/R-gitcreds
DEPENDS+= R-httr2-[0-9]*:../../www/R-httr2
DEPENDS+= R-ini>=0.3.1:../../devel/R-ini
DEPENDS+= R-jsonlite>=1.6:../../textproc/R-jsonlite
DEPENDS+= R-httr>=1.4.1:../../www/R-httr
DEPENDS+= R-gitcreds-[0-9]*:../../security/R-gitcreds
DEPENDS+= R-cli>=2.0.1:../../devel/R-cli
DEPENDS+= R-lifecycle-[0-9]*:../../devel/R-lifecycle
DEPENDS+= R-rlang-[0-9]*:../../devel/R-rlang

TEST_DEPENDS+= R-mockery-[0-9]*:../../devel/R-mockery
TEST_DEPENDS+= R-spelling-[0-9]*:../../textproc/R-spelling
Expand All @@ -22,6 +24,12 @@ TEST_DEPENDS+= R-knitr-[0-9]*:../../print/R-knitr
TEST_DEPENDS+= R-rmarkdown-[0-9]*:../../textproc/R-rmarkdown
TEST_DEPENDS+= R-withr-[0-9]*:../../devel/R-withr

TEST_DEPENDS+= tex-ec-[0-9]*:../../fonts/tex-ec
TEST_DEPENDS+= tex-inconsolata-[0-9]*:../../fonts/tex-inconsolata
TEST_DEPENDS+= tex-latex-bin-[0-9]*:../../print/tex-latex-bin
TEST_DEPENDS+= tex-url-[0-9]*:../../print/tex-url
TEST_DEPENDS+= tex-xkeyval-[0-9]*:../../print/tex-xkeyval

USE_LANGUAGES= # none

.include "../../math/R/Makefile.extension"
Expand Down
8 changes: 4 additions & 4 deletions www/R-gh/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2021/10/26 11:29:14 nia Exp $
$NetBSD: distinfo,v 1.5 2024/12/30 12:32:34 mef Exp $

BLAKE2s (R/gh_1.3.0.tar.gz) = be9bf34e0cb21e662145f9fb47bd72613a93a0693741f7147a36cb25a0218d02
SHA512 (R/gh_1.3.0.tar.gz) = 61d576923817fafc8dee522e35caa60508b29f4a6ae994b30651de01efcc3ac3caae114ffa7e85ed5f90bf5de83121ab04db5f653893c3d9e4f1d0735b4f6cf4
Size (R/gh_1.3.0.tar.gz) = 45619 bytes
BLAKE2s (R/gh_1.4.1.tar.gz) = 69847b8f8c00ffd0645d0304a5a5dc3f3c5e0bdfb393aa499ab8e9481cab2688
SHA512 (R/gh_1.4.1.tar.gz) = 8f57785397d3aa5fc7177d28a176bfff531f6f0e203f38bc83ff08e424c7697abe4f79f57d71f1c3df72039f350eea7a890ce8be39cfca4a006f7570506521c3
Size (R/gh_1.4.1.tar.gz) = 46164 bytes

0 comments on commit c0c0db5

Please sign in to comment.