Skip to content

Commit

Permalink
sysutils/lla: update to 0.3.7
Browse files Browse the repository at this point in the history
[0.3.7] - 2024-12-20
Changed

    Faster recursive directory listing with optimized traversal
    Improved fuzzy search performance and accuracy
    Enhanced tree format with more efficient rendering
    Redesigned size calculation logic for faster and more accurate results
    General stability improvements and bug fixes

[0.3.6] - 2024-12-18
Added

    Interactive fuzzy file search (Experimental - Might be unstable)
        Enabled via the new --fuzzy flag
        Designed for quick file lookups in standard-sized directories
        Future updates will optimize performance for large-scale directory structures

    Directory size integration
        New option to include directory sizes in all listing formats
        Compatible with default, sizemap, grid, and tree visualizations
        Recursive directory size calculation with calculate_dir_size
        Configurable through the include_dirs setting in configuration files
        Enhanced size bar visualization for both directories and files

    Enhanced shell integration
        Added comprehensive shell completion support for bash, zsh, fish, and elvish
        Generate completions using lla completion <shell> [path]

    Customizable fuzzy search configuration
        New listers.fuzzy.ignore_patterns setting
        Supports multiple pattern types:
            Simple substring matching
            Glob patterns
            Regular expressions

    Interactive theme management
        New lla theme command for interactive theme switching

    Advanced directory visualization
        New --recursive flag for hierarchical directory display
        Implemented RecursiveFormatter for structured output
        Flexible tree and recursive format options

Changed

    Architecture improvements
        Redesigned Args struct to accommodate shell completion, fuzzy format, and directory size features
        Enhanced command handler for improved shell integration
        Optimized file listing and formatting logic

    Dependency updates
        Added clap_complete for shell completion functionality
        Updated hermit-abi version specifications
        Integrated num_cpus for improved performance

    Search functionality enhancements
        Implemented configurable FuzzyConfig structure
        Enhanced FuzzyLister and SearchIndex components
        Improved pattern matching and file filtering capabilities

    Core system refinements
        Optimized create_lister function
        Enhanced configuration loading for fuzzy search and directory size inclusion
        Improved recursive listing implementation
        Updated SizeMapFormatter for better directory and file size visualization

[0.3.5] - 2024-12-16

    A theming system to customize the look of lla
    New configuration option theme
    An extensive theming preset library
    Add the --no-color flag to disable color output, and works will all listing formats

Fixed

    Minor fixes and improvements
    Stability improvements

What's Changed

    Support themes and more package managers and more by @triyanox in #59
    chore: remove windows temporary by @triyanox in #60
  • Loading branch information
0323pin committed Dec 24, 2024
1 parent c455ae0 commit 8a9762b
Show file tree
Hide file tree
Showing 3 changed files with 75 additions and 64 deletions.
5 changes: 2 additions & 3 deletions sysutils/lla/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.12 2024/12/14 21:10:14 pin Exp $
# $NetBSD: Makefile,v 1.13 2024/12/24 18:30:03 pin Exp $

DISTNAME= lla-0.3.3
DISTNAME= lla-0.3.7
CATEGORIES= sysutils
MASTER_SITES= https://static.crates.io/crates/lla/
EXTRACT_SUFX= .crate
Expand All @@ -22,5 +22,4 @@ RUSTFLAGS+= -C link-arg=${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.openssl}/lib

.include "../../lang/rust/cargo.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../devel/protobuf/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
33 changes: 18 additions & 15 deletions sysutils/lla/cargo-depends.mk
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
# $NetBSD: cargo-depends.mk,v 1.11 2024/12/14 21:10:14 pin Exp $
# $NetBSD: cargo-depends.mk,v 1.12 2024/12/24 18:30:03 pin Exp $

CARGO_CRATE_DEPENDS+= adler2-2.0.0
CARGO_CRATE_DEPENDS+= aho-corasick-1.1.3
CARGO_CRATE_DEPENDS+= android-tzdata-0.1.1
CARGO_CRATE_DEPENDS+= android_system_properties-0.1.5
Expand All @@ -12,22 +11,25 @@ CARGO_CRATE_DEPENDS+= base64-0.22.1
CARGO_CRATE_DEPENDS+= bitflags-1.3.2
CARGO_CRATE_DEPENDS+= bitflags-2.6.0
CARGO_CRATE_DEPENDS+= block-buffer-0.10.4
CARGO_CRATE_DEPENDS+= bstr-1.6.2
CARGO_CRATE_DEPENDS+= bumpalo-3.16.0
CARGO_CRATE_DEPENDS+= byteorder-1.5.0
CARGO_CRATE_DEPENDS+= bytes-1.9.0
CARGO_CRATE_DEPENDS+= cc-1.2.1
CARGO_CRATE_DEPENDS+= cfg-if-1.0.0
CARGO_CRATE_DEPENDS+= chrono-0.4.38
CARGO_CRATE_DEPENDS+= clap-3.2.25
CARGO_CRATE_DEPENDS+= clap_complete-3.2.5
CARGO_CRATE_DEPENDS+= clap_lex-0.2.4
CARGO_CRATE_DEPENDS+= colored-2.1.0
CARGO_CRATE_DEPENDS+= console-0.15.8
CARGO_CRATE_DEPENDS+= core-foundation-sys-0.8.7
CARGO_CRATE_DEPENDS+= cpufeatures-0.2.16
CARGO_CRATE_DEPENDS+= crc32fast-1.4.2
CARGO_CRATE_DEPENDS+= crossbeam-channel-0.5.14
CARGO_CRATE_DEPENDS+= crossbeam-deque-0.8.5
CARGO_CRATE_DEPENDS+= crossbeam-epoch-0.9.18
CARGO_CRATE_DEPENDS+= crossbeam-utils-0.8.20
CARGO_CRATE_DEPENDS+= crossterm-0.27.0
CARGO_CRATE_DEPENDS+= crossterm_winapi-0.9.1
CARGO_CRATE_DEPENDS+= crypto-common-0.1.6
CARGO_CRATE_DEPENDS+= dashmap-5.5.3
CARGO_CRATE_DEPENDS+= dialoguer-0.11.0
Expand All @@ -40,18 +42,19 @@ CARGO_CRATE_DEPENDS+= equivalent-1.0.1
CARGO_CRATE_DEPENDS+= errno-0.3.9
CARGO_CRATE_DEPENDS+= fastrand-2.2.0
CARGO_CRATE_DEPENDS+= fixedbitset-0.4.2
CARGO_CRATE_DEPENDS+= flate2-1.0.35
CARGO_CRATE_DEPENDS+= generic-array-0.14.7
CARGO_CRATE_DEPENDS+= getrandom-0.2.15
CARGO_CRATE_DEPENDS+= glob-0.3.1
CARGO_CRATE_DEPENDS+= globset-0.4.15
CARGO_CRATE_DEPENDS+= hashbrown-0.12.3
CARGO_CRATE_DEPENDS+= hashbrown-0.14.5
CARGO_CRATE_DEPENDS+= hashbrown-0.15.2
CARGO_CRATE_DEPENDS+= heck-0.5.0
CARGO_CRATE_DEPENDS+= hermit-abi-0.1.19
CARGO_CRATE_DEPENDS+= home-0.5.9
CARGO_CRATE_DEPENDS+= hermit-abi-0.3.9
CARGO_CRATE_DEPENDS+= iana-time-zone-0.1.61
CARGO_CRATE_DEPENDS+= iana-time-zone-haiku-0.1.2
CARGO_CRATE_DEPENDS+= ignore-0.4.23
CARGO_CRATE_DEPENDS+= indexmap-1.9.3
CARGO_CRATE_DEPENDS+= indexmap-2.6.0
CARGO_CRATE_DEPENDS+= indicatif-0.17.9
Expand All @@ -62,14 +65,15 @@ CARGO_CRATE_DEPENDS+= lazy_static-1.5.0
CARGO_CRATE_DEPENDS+= libc-0.2.166
CARGO_CRATE_DEPENDS+= libloading-0.8.5
CARGO_CRATE_DEPENDS+= libredox-0.1.3
CARGO_CRATE_DEPENDS+= lla_plugin_interface-0.3.3
CARGO_CRATE_DEPENDS+= lla_plugin_interface-0.3.7
CARGO_CRATE_DEPENDS+= linux-raw-sys-0.4.14
CARGO_CRATE_DEPENDS+= lock_api-0.4.12
CARGO_CRATE_DEPENDS+= log-0.4.22
CARGO_CRATE_DEPENDS+= memchr-2.7.4
CARGO_CRATE_DEPENDS+= miniz_oxide-0.8.0
CARGO_CRATE_DEPENDS+= mio-0.8.11
CARGO_CRATE_DEPENDS+= multimap-0.10.0
CARGO_CRATE_DEPENDS+= num-traits-0.2.19
CARGO_CRATE_DEPENDS+= num_cpus-1.16.0
CARGO_CRATE_DEPENDS+= number_prefix-0.4.0
CARGO_CRATE_DEPENDS+= once_cell-1.20.2
CARGO_CRATE_DEPENDS+= option-ext-0.2.0
Expand All @@ -78,17 +82,13 @@ CARGO_CRATE_DEPENDS+= parking_lot-0.12.3
CARGO_CRATE_DEPENDS+= parking_lot_core-0.9.10
CARGO_CRATE_DEPENDS+= petgraph-0.6.5
CARGO_CRATE_DEPENDS+= portable-atomic-1.10.0
CARGO_CRATE_DEPENDS+= ppv-lite86-0.2.20
CARGO_CRATE_DEPENDS+= prettyplease-0.2.25
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.92
CARGO_CRATE_DEPENDS+= prost-0.12.6
CARGO_CRATE_DEPENDS+= prost-build-0.12.6
CARGO_CRATE_DEPENDS+= prost-derive-0.12.6
CARGO_CRATE_DEPENDS+= prost-types-0.12.6
CARGO_CRATE_DEPENDS+= quote-1.0.37
CARGO_CRATE_DEPENDS+= rand-0.8.5
CARGO_CRATE_DEPENDS+= rand_chacha-0.3.1
CARGO_CRATE_DEPENDS+= rand_core-0.6.4
CARGO_CRATE_DEPENDS+= rayon-1.10.0
CARGO_CRATE_DEPENDS+= rayon-core-1.12.1
CARGO_CRATE_DEPENDS+= redox_syscall-0.5.7
Expand All @@ -109,6 +109,9 @@ CARGO_CRATE_DEPENDS+= sha1-0.10.6
CARGO_CRATE_DEPENDS+= sha2-0.10.8
CARGO_CRATE_DEPENDS+= shell-words-1.1.0
CARGO_CRATE_DEPENDS+= shlex-1.3.0
CARGO_CRATE_DEPENDS+= signal-hook-0.3.17
CARGO_CRATE_DEPENDS+= signal-hook-mio-0.2.4
CARGO_CRATE_DEPENDS+= signal-hook-registry-1.4.2
CARGO_CRATE_DEPENDS+= smallvec-1.13.2
CARGO_CRATE_DEPENDS+= spin-0.9.8
CARGO_CRATE_DEPENDS+= strip-ansi-escapes-0.1.1
Expand All @@ -120,11 +123,14 @@ CARGO_CRATE_DEPENDS+= terminal_size-0.3.0
CARGO_CRATE_DEPENDS+= textwrap-0.16.1
CARGO_CRATE_DEPENDS+= thiserror-1.0.69
CARGO_CRATE_DEPENDS+= thiserror-impl-1.0.69
CARGO_CRATE_DEPENDS+= tinyvec-1.8.0
CARGO_CRATE_DEPENDS+= tinyvec_macros-0.1.1
CARGO_CRATE_DEPENDS+= toml-0.8.19
CARGO_CRATE_DEPENDS+= toml_datetime-0.6.8
CARGO_CRATE_DEPENDS+= toml_edit-0.22.22
CARGO_CRATE_DEPENDS+= typenum-1.17.0
CARGO_CRATE_DEPENDS+= unicode-ident-1.0.14
CARGO_CRATE_DEPENDS+= unicode-normalization-0.1.24
CARGO_CRATE_DEPENDS+= unicode-width-0.1.14
CARGO_CRATE_DEPENDS+= unicode-width-0.2.0
CARGO_CRATE_DEPENDS+= untrusted-0.9.0
Expand All @@ -141,7 +147,6 @@ CARGO_CRATE_DEPENDS+= wasm-bindgen-macro-0.2.95
CARGO_CRATE_DEPENDS+= wasm-bindgen-macro-support-0.2.95
CARGO_CRATE_DEPENDS+= wasm-bindgen-shared-0.2.95
CARGO_CRATE_DEPENDS+= web-time-1.1.0
CARGO_CRATE_DEPENDS+= which-4.4.2
CARGO_CRATE_DEPENDS+= winapi-0.3.9
CARGO_CRATE_DEPENDS+= winapi-i686-pc-windows-gnu-0.4.0
CARGO_CRATE_DEPENDS+= winapi-util-0.1.9
Expand All @@ -168,6 +173,4 @@ CARGO_CRATE_DEPENDS+= windows_x86_64_gnullvm-0.52.6
CARGO_CRATE_DEPENDS+= windows_x86_64_msvc-0.48.5
CARGO_CRATE_DEPENDS+= windows_x86_64_msvc-0.52.6
CARGO_CRATE_DEPENDS+= winnow-0.6.20
CARGO_CRATE_DEPENDS+= zerocopy-0.7.35
CARGO_CRATE_DEPENDS+= zerocopy-derive-0.7.35
CARGO_CRATE_DEPENDS+= zeroize-1.8.1
Loading

0 comments on commit 8a9762b

Please sign in to comment.