Skip to content

Commit

Permalink
lang/php82: update to 8.2.20
Browse files Browse the repository at this point in the history
pkgsrc change:

Instead of patch configure, patch m4 files and use autoconf to generate
configure.

PHP 8.2.20 (2024-06-06)

- CGI:
  . Fixed buffer limit on Windows, replacing read call usage by _read.
    (David Carlier)
  . Fixed bug GHSA-3qgc-jrrr-25jv (Bypass of CVE-2012-1823, Argument Injection
    in PHP-CGI). (CVE-2024-4577) (nielsdos)

- CLI:
  . Fixed bug GH-14189 (PHP Interactive shell input state incorrectly handles
    quoted heredoc literals.). (nielsdos)

- Core:
  . Fixed bug GH-13970 (Incorrect validation of #[Attribute] flags type for
    non-compile-time expressions). (ilutov)
  . Fixed bug GH-14140 (Floating point bug in range operation on Apple Silicon
    hardware). (Derick, Saki)

- DOM:
  . Fix crashes when entity declaration is removed while still having entity
    references. (nielsdos)
  . Fix references not handled correctly in C14N. (nielsdos)
  . Fix crash when calling childNodes next() when iterator is exhausted.
    (nielsdos)
  . Fix crash in ParentNode::append() when dealing with a fragment
    containing text nodes. (nielsdos)

- FFI:
  . Fixed bug GH-14215 (Cannot use FFI::load on CRLF header file with
    apache2handler). (nielsdos)

- Filter:
  . Fixed bug GHSA-w8qr-v226-r27w (Filter bypass in filter_var FILTER_VALIDATE_URL).
    (CVE-2024-5458) (nielsdos)

- FPM:
  . Fix bug GH-14175 (Show decimal number instead of scientific notation in
    systemd status). (Benjamin Cremer)

- Hash:
  . ext/hash: Swap the checking order of `__has_builtin` and `__GNUC__`
    (Saki Takamachi)

- Intl:
  . Fixed build regression on systems without C++17 compilers. (Calvin Buckley,
    Peter Kokot)

- Ini:
  . Fixed bug GH-14100 (Corrected spelling mistake in php.ini files).
    (Marcus Xavier)

- MySQLnd:
  . Fix bug GH-14255 (mysqli_fetch_assoc reports error from
    nested query). (Kamil Tekiela)

- Opcache:
  . Fixed bug GH-14109 (Fix accidental persisting of internal class constant in
    shm). (ilutov)

- OpenSSL:
  . The openssl_private_decrypt function in PHP, when using PKCS1 padding
    (OPENSSL_PKCS1_PADDING, which is the default), is vulnerable to the Marvin Attack
    unless it is used with an OpenSSL version that includes the changes from this pull
    request: openssl/openssl#13817 (rsa_pkcs1_implicit_rejection).
    These changes are part of OpenSSL 3.2 and have also been backported to stable
    versions of various Linux distributions, as well as to the PHP builds provided for
    Windows since the previous release. All distributors and builders should ensure that
    this version is used to prevent PHP from being vulnerable. (CVE-2024-2408)

- Standard:
  . Fixed bug GHSA-9fcc-425m-g385 (Bypass of CVE-2024-1874).
    (CVE-2024-5585) (nielsdos)

- XML:
  . Fixed bug GH-14124 (Segmentation fault with XML extension under certain
    memory limit). (nielsdos)

- XMLReader:
  . Fixed bug GH-14183 (XMLReader::open() can't be overridden). (nielsdos)
  • Loading branch information
taca committed Jun 7, 2024
1 parent c69bb43 commit 63430d0
Show file tree
Hide file tree
Showing 6 changed files with 56 additions and 70 deletions.
4 changes: 2 additions & 2 deletions lang/php/phpversion.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: phpversion.mk,v 1.434 2024/06/07 13:57:24 taca Exp $
# $NetBSD: phpversion.mk,v 1.435 2024/06/07 13:58:44 taca Exp $
#
# This file selects a PHP version, based on the user's preferences and
# the installed packages. It does not add a dependency on the PHP
Expand Down Expand Up @@ -90,7 +90,7 @@ PHPVERSION_MK= defined
PHP56_VERSION= 5.6.40
PHP74_VERSION= 7.4.33
PHP81_VERSION= 8.1.29
PHP82_VERSION= 8.2.19
PHP82_VERSION= 8.2.20
PHP83_VERSION= 8.3.8

# Define API version or initial release of major version.
Expand Down
10 changes: 6 additions & 4 deletions lang/php82/Makefile
Original file line number Diff line number Diff line change
@@ -1,17 +1,16 @@
# $NetBSD: Makefile,v 1.8 2024/05/29 16:33:16 adam Exp $
# $NetBSD: Makefile,v 1.9 2024/06/07 13:58:44 taca Exp $

#
# We can't omit PKGNAME here to handle PKG_OPTIONS.
#
PKGNAME= php-${PHP_VERSION:S/RC/rc/}
PKGREVISION= 1

COMMENT= PHP Hypertext Preprocessor version 8.2
LICENSE= php

TEST_TARGET= test

USE_TOOLS+= gmake lex
USE_TOOLS+= autoconf gmake lex
LIBTOOL_OVERRIDE= # empty
PHP_CHECK_INSTALLED= No

Expand Down Expand Up @@ -46,7 +45,7 @@ REPLACE_PHP= ext/phar/phar/phar.php run-tests.php
SUBST_CLASSES+= path
SUBST_MESSAGE.path= Fixing common paths.
SUBST_STAGE.path= pre-configure
SUBST_FILES.path= configure
SUBST_FILES.path= build/php.m4
SUBST_FILES.path+= php.ini-development php.ini-production
SUBST_FILES.path+= sapi/cgi/Makefile.frag
SUBST_VARS.path= CGIDIR
Expand All @@ -66,6 +65,9 @@ INSTALL_UNSTRIPPED= yes
CFLAGS+= -DSQLITE_ENABLE_LOCKING_STYLE=0 -DSQLITE_WITHOUT_ZONEMALLOC
.endif

pre-configure:
cd ${WRKSRC} && autoconf -f

post-install:
cd ${WRKSRC}; ${INSTALL_DATA} php.ini-development php.ini-production \
${DESTDIR}${EGDIR}
Expand Down
11 changes: 6 additions & 5 deletions lang/php82/distinfo
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.21 2024/05/10 15:07:21 taca Exp $
$NetBSD: distinfo,v 1.22 2024/06/07 13:58:44 taca Exp $

BLAKE2s (php-8.2.19.tar.xz) = e5311c04070b2cb656ab95bfa8c7a136e8f729de7955515ff9d316582bf43196
SHA512 (php-8.2.19.tar.xz) = 5ba7ab4317f7880a6cea93bf6d3a48d62db6bfcb5682be7e13a6a6f7bd1fef96ca813c2cf95f6b5020756f03b298995d1722367adb2580c1db221a2f9e311038
Size (php-8.2.19.tar.xz) = 12094184 bytes
SHA1 (patch-configure) = cdda115b3e160568cc418dce5cd95cc52b5abf6b
BLAKE2s (php-8.2.20.tar.xz) = a8407aabb71ce0540f0545c0048ce5ef3744033b2b1517c51fe4c98333d4f02b
SHA512 (php-8.2.20.tar.xz) = c659ed4809b6507aa428b483c85c7322815ac9d7d8e4bfe575513a5e69c5a680b8d089fd98a19f83d3a00df3de61468809f21408455913aa24d519776e44abc5
Size (php-8.2.20.tar.xz) = 12097568 bytes
SHA1 (patch-build_php.m4) = 4743b23e479c4ac904f18def41d5577f3a965af0
SHA1 (patch-ext_enchant_enchant.c) = 7d999de1b2fde2ea11e4a6e16e7b59c085924b9b
SHA1 (patch-ext_phar_Makefile.frag) = 53ea5c58b0bc27d236118d5750a74b1cba43e5dd
SHA1 (patch-ext_standard_php__fopen__wrapper.c) = 0a2c19c18f089448a8d842e99738b292ab9e5640
Expand All @@ -12,6 +12,7 @@ SHA1 (patch-ext_xsl_php__xsl.h) = cf930c5d6d9dab29b12558d265c67d3534a006fd
SHA1 (patch-main_streams_streams.c) = d699ce7d3a300ffb39494b3f1fa5e0958f714483
SHA1 (patch-php.ini-development) = 373d76cc7a022b578f1d5e296d1f0ac88bc26b72
SHA1 (patch-php.ini-production) = 5ab7fa6bf8403907160b0a62b56c1ee527f8eda6
SHA1 (patch-sapi_apache2handler_config.m4) = 5f98557568cc2abc34fab5d3f123803c9a81c0af
SHA1 (patch-sapi_cgi_Makefile.frag) = f4cd64d334884c49787d8854115c8cd69cc79bb8
SHA1 (patch-sapi_cli_Makefile.frag) = 1cd29d09042863acbf5330e406410fdcf75d06b3
SHA1 (patch-sapi_fpm_php-fpm.conf.in) = acf9b4e70d4c5ea2b96e37e7bbf9005379ecc4d0
17 changes: 17 additions & 0 deletions lang/php82/patches/patch-build_php.m4
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
$NetBSD: patch-build_php.m4,v 1.1 2024/06/07 13:58:44 taca Exp $

Do not include "PKG_CONFIG*" in CONFIGURE_OPTIONS.

--- build/php.m4.orig 2024-06-04 13:22:51.000000000 +0000
+++ build/php.m4
@@ -2151,6 +2151,10 @@ EOF
else
break
fi
+ case "$CURRENT_ARG" in
+ \'PKG_CONFIG\=*) CURRENT_ARG="'PKG_CONFIG=@TOOLS_PATH.pkg-config@'";;
+ \'PKG_CONFIG_LIBDIR\=*) CURRENT_ARG="'PKG_CONFIG_LIBDIR=@PHP_PKGCONFIG_PATH@'";;
+ esac
AS_ECHO(["$CURRENT_ARG \\"]) >>$1
CONFIGURE_OPTIONS="$CONFIGURE_OPTIONS $CURRENT_ARG"
done
59 changes: 0 additions & 59 deletions lang/php82/patches/patch-configure

This file was deleted.

25 changes: 25 additions & 0 deletions lang/php82/patches/patch-sapi_apache2handler_config.m4
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
$NetBSD: patch-sapi_apache2handler_config.m4,v 1.1 2024/06/07 13:58:44 taca Exp $

Don't autodetect maintainer-zts.

--- sapi/apache2handler/config.m4.orig 2024-06-04 13:22:51.000000000 +0000
+++ sapi/apache2handler/config.m4
@@ -108,18 +108,6 @@ if test "$PHP_APXS2" != "no"; then
;;
esac

- if test "$APACHE_VERSION" -lt 2004001; then
- APXS_MPM=`$APXS -q MPM_NAME`
- if test "$APXS_MPM" != "prefork" && test "$APXS_MPM" != "peruser" && test "$APXS_MPM" != "itk"; then
- PHP_BUILD_THREAD_SAFE
- fi
- else
- APACHE_THREADED_MPM=`$APXS_HTTPD -V 2>/dev/null | grep 'threaded:.*yes'`
- if test -n "$APACHE_THREADED_MPM"; then
- PHP_BUILD_THREAD_SAFE
- fi
- fi
- AC_MSG_RESULT(yes)
PHP_SUBST(APXS)
else
AC_MSG_RESULT(no)

0 comments on commit 63430d0

Please sign in to comment.