Skip to content

Commit

Permalink
devel/hs-random: update to random-1.3.0
Browse files Browse the repository at this point in the history
# 1.3.0

* Improve floating point value generation and avoid degenerate cases: [#172](haskell/random#172)
* Add `Uniform` instance for `Maybe` and `Either`: [#167](haskell/random#167)
* Add `Seed`, `SeedGen`, `seedSize`, `seedSizeProxy`, `mkSeed` and `unSeed`:
  [#162](haskell/random#162)
* Add `mkSeedFromByteString`, `unSeedToByteString`, `withSeed`, `withSeedM`, `withSeedFile`,
  `seedGenTypeName`, `nonEmptyToSeed`, `nonEmptyFromSeed`, `withSeedM`, `withSeedMutableGen` and `withSeedMutableGen_`
* Add `SplitGen` and `splitGen`: [#160](haskell/random#160)
* Add `unifromShuffleList` and `unifromShuffleListM`: [#140](haskell/random#140)
* Add `uniformWordR`: [#140](haskell/random#140)
* Add `mkStdGen64`: [#155](haskell/random#155)
* Add `uniformListRM`, `uniformList`, `uniformListR`, `uniforms` and `uniformRs`:
  [#154](haskell/random#154)
* Add compatibility with recently added `ByteArray` to `base`:
  [#153](haskell/random#153)
  * Switch to using `ByteArray` for type class implementation instead of
    `ShortByteString`
  * Add `unsafeUniformFillMutableByteArray` to `RandomGen` and a helper function
    `defaultUnsafeUniformFillMutableByteArray` that makes implementation
    for most instances easier.
  * Add `uniformByteArray`, `uniformByteString` and `uniformFillMutableByteArray`
  * Deprecate `genByteString` in favor of `uniformByteString`
  * Add `uniformByteArrayM` to `StatefulGen`
  * Add `uniformByteStringM` and `uniformShortByteStringM`
  * Deprecate `System.Random.Stateful.uniformShortByteString` in favor of `uniformShortByteStringM` for
    consistent naming and a future plan of removing it from `StatefulGen`
    type class
  * Add a pure `System.Random.uniformShortByteString` generating function.
  * Deprecate `genShortByteString` in favor of `System.Random.uniformShortByteString`
  * Expose a helper function `fillByteArrayST`, that can be used for
    defining implementation for `uniformByteArrayM`
  * Deprecate `genShortByteStringST` and `genShortByteStringIO` in favor of `fillByteArrayST`
* Improve `FrozenGen` interface: [#149](haskell/random#149)
  * Move `thawGen` from `FreezeGen` into the new `ThawGen` type class. Fixes an issue with
    an unlawful instance of `StateGen` for `FreezeGen`.
  * Add `modifyGen` and `overwriteGen` to the `FrozenGen` type class
  * Switch `splitGenM` to use `SplitGen` and `FrozenGen` instead of deprecated `RandomGenM`
  * Add `splitMutableGenM`
  * Switch `randomM` and `randomRM` to use `FrozenGen` instead of `RandomGenM`
  * Deprecate `RandomGenM` in favor of a more powerful `FrozenGen`
* Add `isInRangeOrd` and `isInRangeEnum` that can be used for implementing `isInRange`:
  [#148](haskell/random#148)
* Add `isInRange` to `UniformRange`: [#78](haskell/random#78)
* Add default implementation for `uniformRM` using `Generics`:
  [#92](haskell/random#92)
  • Loading branch information
depressed-pho committed Jan 29, 2025
1 parent 91118c6 commit 2b00651
Show file tree
Hide file tree
Showing 4 changed files with 16 additions and 11 deletions.
5 changes: 2 additions & 3 deletions devel/hs-random/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.15 2024/05/09 01:32:08 pho Exp $
# $NetBSD: Makefile,v 1.16 2025/01/29 16:56:33 pho Exp $

DISTNAME= random-1.2.1.2
PKGREVISION= 1
DISTNAME= random-1.3.0
CATEGORIES= devel

MAINTAINER= pho@cielonegro.org
Expand Down
8 changes: 7 additions & 1 deletion devel/hs-random/PLIST
Original file line number Diff line number Diff line change
@@ -1,14 +1,20 @@
@comment $NetBSD: PLIST,v 1.7 2024/04/29 03:02:49 pho Exp $
@comment $NetBSD: PLIST,v 1.8 2025/01/29 16:56:33 pho Exp $
${PLIST.shlibs}lib/${HS_PLATFORM}/libHS${HS_PKGID}-${HS_VER}.so
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/System/Random.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/System/Random.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/System/Random.p_hi
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/Array.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/Array.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/Array.p_hi
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/GFinite.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/GFinite.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/GFinite.p_hi
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/Internal.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/Internal.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/Internal.p_hi
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/Seed.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/Seed.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/Seed.p_hi
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/Stateful.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/Stateful.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/System/Random/Stateful.p_hi
Expand Down
6 changes: 3 additions & 3 deletions devel/hs-random/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.16 2024/05/09 01:32:08 pho Exp $
# $NetBSD: buildlink3.mk,v 1.17 2025/01/29 16:56:33 pho Exp $

BUILDLINK_TREE+= hs-random

.if !defined(HS_RANDOM_BUILDLINK3_MK)
HS_RANDOM_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.hs-random+= hs-random>=1.2.1
BUILDLINK_ABI_DEPENDS.hs-random+= hs-random>=1.2.1.2nb1
BUILDLINK_API_DEPENDS.hs-random+= hs-random>=1.3.0
BUILDLINK_ABI_DEPENDS.hs-random+= hs-random>=1.3.0
BUILDLINK_PKGSRCDIR.hs-random?= ../../devel/hs-random

.include "../../devel/hs-splitmix/buildlink3.mk"
Expand Down
8 changes: 4 additions & 4 deletions devel/hs-random/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.10 2024/04/29 03:02:49 pho Exp $
$NetBSD: distinfo,v 1.11 2025/01/29 16:56:33 pho Exp $

BLAKE2s (random-1.2.1.2.tar.gz) = 4ba08e467084a63a1c3f2f21372c07c8d4428b518f9fd69b421708273a5c51af
SHA512 (random-1.2.1.2.tar.gz) = 04a98a5ae2baa6b4d016c7951bed7057b1c5d850c81ea7ab46d0c7fdb68e21c680914eb55ab3ff9b78e64a29d77c65b00c14601250b32758e2d5343e72708517
Size (random-1.2.1.2.tar.gz) = 47229 bytes
BLAKE2s (random-1.3.0.tar.gz) = 4620150d281372ca74059ec348d77f85e92fc507cd47870bd4185aae5df018d7
SHA512 (random-1.3.0.tar.gz) = f6ee1fb9803ca3d4cfa630f552f8c7eeb9a8e438b7540e6bd1a52df5180718e5b525c8dd26b87893456a4ec90c46c36ea42fbc44b2aaf54bb4b52654c413fd04
Size (random-1.3.0.tar.gz) = 63786 bytes

0 comments on commit 2b00651

Please sign in to comment.