Skip to content

Commit

Permalink
py-serializable: update to 2.0.0.
Browse files Browse the repository at this point in the history
v2.0.0 (2025-02-09)

Breaking

    refactor!: rename python package serializable -> py_serializable (#155)

    The python package was renamed from serializable to py_serializable.
    Therefore, you need to adjust your imports.

    The following shows a quick way to adjust imports in the most efficient way.
    OLD imports

    import serializable
    from serializable import ViewType, XmlArraySerializationType, XmlStringSerializationType
    from serializable.helpers import BaseHelper, Iso8601Date

ADJUSTED imports

import py_serializable as serializable
from py_serializable import ViewType, XmlArraySerializationType, XmlStringSerializationType
from py_serializable.helpers import BaseHelper, Iso8601Date

    see migration path: https://py-serializable.readthedocs.io/en/refactor-rename-installable-py_serializable/migration.html

Unknown

    Delete duplicate CODEOWNERS (#156)

    we have a codeowners file in root already (b64cdde)

What's Changed

    chore(deps-dev): update mypy requirement from 1.11.2 to 1.12.0 by @dependabot in #143
    chore(deps-dev): update mypy requirement from 1.12.0 to 1.13.0 by @dependabot in #145
    chore(deps-dev): update flake8-bugbear requirement from 24.8.19 to 24.10.31 by @dependabot in #146
    chore(deps-dev): update flake8-bugbear requirement from 24.10.31 to 24.12.12 by @dependabot in #150
    chore(deps-dev): update mypy requirement from 1.13.0 to 1.14.1 by @dependabot in #154
    Delete duplicate CODEOWNERS by @jkowalleck in #156
    chore(docs): chanelog contains only relevant by @jkowalleck in #157
    chore(docs): recreate changelog by @jkowalleck in #158
    chore(deps): bump actions/upload-artifact from 3 to 4 by @dependabot in #37
    refactor!: rename python package serializable -> py_serializable by @jkowalleck in #155
    chore(deps): update sphinx requirement from <8,>=7.2.6 to >=7.2.6,<9 by @dependabot in #127
  • Loading branch information
0-wiz-0 committed Feb 18, 2025
1 parent 3f3ce3f commit 1a2f6d8
Show file tree
Hide file tree
Showing 3 changed files with 23 additions and 23 deletions.
4 changes: 2 additions & 2 deletions devel/py-serializable/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.12 2024/10/03 08:43:22 adam Exp $
# $NetBSD: Makefile,v 1.13 2025/02/18 10:43:11 wiz Exp $

DISTNAME= py_serializable-1.1.2
DISTNAME= py_serializable-2.0.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/py_//}
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=p/py-serializable/}
Expand Down
34 changes: 17 additions & 17 deletions devel/py-serializable/PLIST
Original file line number Diff line number Diff line change
@@ -1,21 +1,21 @@
@comment $NetBSD: PLIST,v 1.5 2024/07/14 13:33:18 wiz Exp $
@comment $NetBSD: PLIST,v 1.6 2025/02/18 10:43:11 wiz Exp $
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/serializable/__init__.py
${PYSITELIB}/serializable/__init__.pyc
${PYSITELIB}/serializable/__init__.pyo
${PYSITELIB}/serializable/formatters.py
${PYSITELIB}/serializable/formatters.pyc
${PYSITELIB}/serializable/formatters.pyo
${PYSITELIB}/serializable/helpers.py
${PYSITELIB}/serializable/helpers.pyc
${PYSITELIB}/serializable/helpers.pyo
${PYSITELIB}/serializable/json.py
${PYSITELIB}/serializable/json.pyc
${PYSITELIB}/serializable/json.pyo
${PYSITELIB}/serializable/py.typed
${PYSITELIB}/serializable/xml.py
${PYSITELIB}/serializable/xml.pyc
${PYSITELIB}/serializable/xml.pyo
${PYSITELIB}/py_serializable/__init__.py
${PYSITELIB}/py_serializable/__init__.pyc
${PYSITELIB}/py_serializable/__init__.pyo
${PYSITELIB}/py_serializable/formatters.py
${PYSITELIB}/py_serializable/formatters.pyc
${PYSITELIB}/py_serializable/formatters.pyo
${PYSITELIB}/py_serializable/helpers.py
${PYSITELIB}/py_serializable/helpers.pyc
${PYSITELIB}/py_serializable/helpers.pyo
${PYSITELIB}/py_serializable/json.py
${PYSITELIB}/py_serializable/json.pyc
${PYSITELIB}/py_serializable/json.pyo
${PYSITELIB}/py_serializable/py.typed
${PYSITELIB}/py_serializable/xml.py
${PYSITELIB}/py_serializable/xml.pyc
${PYSITELIB}/py_serializable/xml.pyo
8 changes: 4 additions & 4 deletions devel/py-serializable/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.11 2024/10/03 08:43:22 adam Exp $
$NetBSD: distinfo,v 1.12 2025/02/18 10:43:11 wiz Exp $

BLAKE2s (py_serializable-1.1.2.tar.gz) = 6550ce4c77565d3aa231e4d89c80846a5fbb33839be24f17a139b10675b68724
SHA512 (py_serializable-1.1.2.tar.gz) = c94e91a8c19a4d7003c6e96d62473420f3b8ed01af2248509212a5b3790b9c3e5010731416aa7819305223fd2bc36e304944d99d81a6f6a334a2fbcabd689c6f
Size (py_serializable-1.1.2.tar.gz) = 55844 bytes
BLAKE2s (py_serializable-2.0.0.tar.gz) = 9704e5cdd450a9bd399a082668a6b5a599d5a042f8030bb14ad191b81b28350c
SHA512 (py_serializable-2.0.0.tar.gz) = 281ccc1b4e7a4cd556ad2c11ce4d533b9e0225e791ca76c2bc927ef689fe1af57d17ddb32159f931aea372af4dff5bb0211fbd63e972be164b1fed0b4634f7e6
Size (py_serializable-2.0.0.tar.gz) = 51617 bytes

0 comments on commit 1a2f6d8

Please sign in to comment.