Skip to content

Commit

Permalink
gotosocial: update to version 0.8.0
Browse files Browse the repository at this point in the history
Changelog (taken from https://github.com/superseriousbusiness/gotosocial/releases):

v0.8.0 Scurrilous Sloth

Hello hello! Guess what! It's time! Time for what, you say? Time for the scurrilous sloth to emerge from his tree and federate posts to all and sundry!

(In other words: this is the latest release of GoToSocial!)

We're really proud of this one, it adds some cool new stuff, and fixes a bunch of annoying bugs and performance hiccups.

Highlights of this release:

    Redesign of the settings/admin navigation bar.
    Email test endpoint + email notifications for reports.
    Pinned posts!! You can now pin and unpin posts, and your server will fetch pinned posts from remote profiles too. May take up to 48 hours to update pinned posts when they change, hang in there.
    Many performance improvements + better caching.

Migration notes
Upgrading

To upgrade to 0.8.0 from a previous release:
Binary/tar

    Stop GoToSocial
    Untar the new release, including the web assets and html templates.
    Edit your config.yaml file as necessary (see below).
    Start GoToSocial

Docker

    Stop GoToSocial.
    Pull the new docker container (superseriousbusiness/gotosocial:0.8.0 or superseriousbusiness/gotosocial:latest)
    Start GoToSocial.

config.yaml

The configuration file has changed since the previous release. We recommend copying the new file from example/config.yaml and pasting values into it from your previous config.yaml. You can see a diff of the config file here: v0.7.1...v0.8.0#diff-c071e03510b2c57e193a44503fd9528a785f0f411497cc75841a9f8d0b1ac622

Database Migrations

This release contains several database migrations which will run the first time you start up this new version. Be sure not to interrupt this migration process. This will take anywhere between a couple seconds and ten minutes (on slower hardware). Please be patient!

Detailed Changelog
Features / Performance

    0746ef7 [frontend] Settings navigation design (#1652)
    de6e3e5 [performance] refactoring + add fave / follow / request / visibility caching (#1607)
    7d09863 [feature] Add list command to admin account (#1648)
    7db81cd [feature] Email notifications for new / closed moderation reports (#1628)
    196cd88 [feature] Allow admins to send test emails (#1620)
    e323a93 [feature] Support multiple subscriptions on single websocket connection (#1489)
    a312238 [feature] Provide .well-known/host-meta endpoint (#1604)
    e397272 [feature] Discover webfinger through host-meta (#1588)
    f518f64 [feature] Add (api only) support for profile fields (#1483)
    d2f6de0 [feature] Allow loading TLS certs from disk (#1586)
    a8e6bdf [performance] cache media attachments (#1525)
    e6cde25 [feature] Advertise rich text formats, support content_type field (#1370)
    24cec4e [feature] Federate pinned posts (aka featuredCollection) in and out (#1560)
    9cfb69f [feature] Make OIDC admin groups configurable (#1555)
    c27b4d7 [feature] Client API endpoints + v. basic web view for pinned posts (#1547)

Bugfixes

    f28ed21 [bugfix] Fix single author threads not appearing in home timeline (#1679)
    fb41d2d [bugfix] warn on maxprocs error instead of failing (#1678)
    e46323c [bugfix] visibility caching and hometimeline (#1675)
    3510454 [bugfix/chore] Refactor timeline code (#1656)
    c54510b [bugfix] Normalize status content (don't parse status content as IRI) (#1665)
    4f322f5 [bugfix] Always serialize orderedItems as array (#1673)
    8d2a76c [bugfix] Add proper constraints on status faves, dedupe (#1674)
    b847af1 [bugfix] Add idempotency-key to allowed CORS headers (#1670)
    3f9b233 [bugfix/frontend] Preload css styles (#1638)
    60639a6 [bugfix] Fix multiple "updated_at" columns for media updates (#1660)
    d9bbcc6 [bugfix] Fix report serialization errors caused by user delete (#1659)
    344c7e5 [bugfix] Fix relationship not updating 'following' on accept follow request (#1658)
    6cf6613 [bugfix] Remove unique constraint on public_key (#1653)
    66bedc4 [bugfix] Use account ID host as accDomain if 2nd webfinger lookup fails (#1630)
    cb2f84e [frontend/fix] Mobile css tweaks (#1605)
    9ba35c6 [bug] Handle 410 on webfinger properly (#1601)
    d8d5818 [bugfix] internal server error on search not found (#1590)
    ef07475 use updateattachment when updating to ensure cache is invalidated (#1587)
    5be59f4 [bugfix] Federate status delete using just the URI (#1584)
    88eefd0 [bugfix] Clamp admin report limit <1 to 100 (#1583)
    29f8c51 [bugfix] Fix unpinning statuses not working (#1582)
    fe6c8b8 [bugfix] on deref new account, check db again for account on ErrAlreadyExists (#1581)
    bfccf4e [bugfix] add ON CONFLICT statements to status updates (#1580)
    689a10f [bugfix] Fix deleted status causing issues when getting bookmark (#1551)

Chores

    36a2131 [chore] Update templates license headers (#1672)
    9c209fe [chore]: Bump modernc.org/sqlite from 1.21.0 to 1.21.1 (#1669)
    839fd56 [chore]: Bump github.com/miekg/dns from 1.1.52 to 1.1.53 (#1668)
    57dc742 [chore]: Bump github.com/KimMachineGun/automemlimit from 0.2.4 to 0.2.5 (#1666)
    a5c920a bump go-store version (includes minio) (#1657)
    9e1756c [chore]: Bump github.com/tdewolff/minify/v2 from 2.12.4 to 2.12.5 (#1649)
    1603a7f [chore] License sloth logo + default avatars under CC by-sa 4.0 (#1651)
    883dc54 bump go-runners version to fix possible race in Processing{Media,Emoji} (#1646)
    e8595f0 [chore] Refactor account deleting/block logic, tidy up some other processing things (#1599)
    276d773 [chore]: Bump github.com/miekg/dns from 1.1.51 to 1.1.52 (#1636)
    78aebf5 [chore]: Bump github.com/microcosm-cc/bluemonday from 1.0.22 to 1.0.23 (#1635)
    ac74256 [chore]: Bump go.uber.org/automaxprocs from 1.5.1 to 1.5.2 (#1633)
    4096e70 [chore]: Bump github.com/go-playground/validator/v10 (#1637)
    d5529d6 [chore] fix + update swagger docs (#1622)
    19e0584 [chore]: Bump github.com/ulule/limiter/v3 from 3.11.0 to 3.11.1 (#1616)
    e448260 [chore]: Bump github.com/stretchr/testify from 1.8.1 to 1.8.2 (#1618)
    86dafa6 [chore]: Bump github.com/abema/go-mp4 from 0.10.0 to 0.10.1 (#1617)
    34f4538 [chore]: Bump golang.org/x/image from 0.5.0 to 0.6.0 (#1615)
    0a86462 [chore]: Bump codeberg.org/gruf/go-kv from 1.6.0 to 1.6.1 (#1619)
    6e10175 update license headers (#1612)
    5e2bf0b [chore] Improve copyright header handling (#1608)
    a772d4d [chore] Fix opengraph properties (#1611)
    d0dee8d [chore] improved enrichAccount() logging (#1602)
    b344c2c [chore] Update uptrace/bun and modernc/sqlite dependencies (#1598)
    24f6a44 [chore]: Bump github.com/jackc/pgx/v4 from 4.17.2 to 4.18.1 (#1595)
    9f36507 [chore]: Bump golang.org/x/oauth2 from 0.5.0 to 0.6.0 (#1597)
    b004b4d [chore]: Bump golang.org/x/crypto from 0.6.0 to 0.7.0 (#1593)
    06524ac [chore]: Bump golang.org/x/text from 0.7.0 to 0.8.0 (#1594)
    65aeeb4 [chore] Print human readable config (#1589)
    baf933c [chore] move client/federator workerpools to Workers{} (#1575)
    87c5c42 [chore/performance] simplify storage driver to use storage.Storage directly (#1576)
    e4c5f9a [chore] Improve unsupported_grant_type error (#1572)
    d550f0e [chore] Bump oauth2/v4 -> v4.6.6.6-SSB (#1571)
    4bb3f59 [chore] bump go, build, and lint version (#1570)
    8696a8c [chore]: Bump github.com/miekg/dns from 1.1.50 to 1.1.51 (#1566)
    6c2bd14 [chore] Better diff for envparsing test (#1562)
    5a45b6e [chore]: Bump golang.org/x/oauth2 from 0.4.0 to 0.5.0 (#1564)
    752c38b [chore]: Bump github.com/minio/minio-go/v7 from 7.0.48 to 7.0.49 (#1567)
    e1b704e [chore] Use latest containers when building (#1554)
    55300cb [chore] Inform user on how to get testrig (#1557)
    83be140 [chore] Update vscode launch configuration (#1556)
    ecdc837 [chore] Update gin to v1.9.0 (#1553)
    074f352 [chore] improve opengraph descripiton tag (#1550)
    b6fbdc6 [chore] Deinterface processor and subprocessors (#1501)

Documentation

    fe4ea96 [docs] Add MASH as 3rd party packaging (#1654)
    9c55c07 [docs] Update docs on how to login (#1626)
  • Loading branch information
nikkicoon committed Apr 9, 2023
1 parent 3dd41b8 commit 16b36c2
Show file tree
Hide file tree
Showing 3 changed files with 17 additions and 14 deletions.
5 changes: 2 additions & 3 deletions www/gotosocial/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.10 2023/04/05 20:47:53 bsiegert Exp $
# $NetBSD: Makefile,v 1.11 2023/04/09 16:47:44 nikita Exp $

DISTNAME= gotosocial-0.7.1-source-code
DISTNAME= gotosocial-0.8.0-source-code
PKGNAME= ${DISTNAME:S/-source-code//}
PKGREVISION= 2
MASTER_SITES= ${MASTER_SITE_GITHUB:=superseriousbusiness/}
GITHUB_RELEASE= v${PKGVERSION_NOREV}
GITHUB_PROJECT= gotosocial
Expand Down
18 changes: 11 additions & 7 deletions www/gotosocial/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2023/02/21 15:49:37 nikita Exp $
@comment $NetBSD: PLIST,v 1.5 2023/04/09 16:47:44 nikita Exp $
bin/gotosocial
share/examples/gotosocial/config.yaml
share/examples/gotosocial/docker-compose.yaml
Expand All @@ -16,6 +16,7 @@ share/examples/gotosocial/web/assets/Fork-Awesome/fonts/forkawesome-webfont.svg
share/examples/gotosocial/web/assets/Fork-Awesome/fonts/forkawesome-webfont.ttf
share/examples/gotosocial/web/assets/Fork-Awesome/fonts/forkawesome-webfont.woff
share/examples/gotosocial/web/assets/Fork-Awesome/fonts/forkawesome-webfont.woff2
share/examples/gotosocial/web/assets/LICENSE
share/examples/gotosocial/web/assets/default_avatars/GoToSocial_icon1.png
share/examples/gotosocial/web/assets/default_avatars/GoToSocial_icon2.png
share/examples/gotosocial/web/assets/default_avatars/GoToSocial_icon3.png
Expand Down Expand Up @@ -76,7 +77,7 @@ share/examples/gotosocial/web/source/settings/components/form/inputs.jsx
share/examples/gotosocial/web/source/settings/components/form/mutation-button.jsx
share/examples/gotosocial/web/source/settings/components/languages.jsx
share/examples/gotosocial/web/source/settings/components/loading.jsx
share/examples/gotosocial/web/source/settings/components/nav-button.jsx
share/examples/gotosocial/web/source/settings/components/user-logout-card.jsx
share/examples/gotosocial/web/source/settings/index.js
share/examples/gotosocial/web/source/settings/lib/domain-block.js
share/examples/gotosocial/web/source/settings/lib/form/bool.jsx
Expand All @@ -88,7 +89,9 @@ share/examples/gotosocial/web/source/settings/lib/form/index.js
share/examples/gotosocial/web/source/settings/lib/form/radio.jsx
share/examples/gotosocial/web/source/settings/lib/form/submit.js
share/examples/gotosocial/web/source/settings/lib/form/text.jsx
share/examples/gotosocial/web/source/settings/lib/get-views.js
share/examples/gotosocial/web/source/settings/lib/navigation/components.jsx
share/examples/gotosocial/web/source/settings/lib/navigation/index.js
share/examples/gotosocial/web/source/settings/lib/navigation/util.js
share/examples/gotosocial/web/source/settings/lib/query/admin/custom-emoji.js
share/examples/gotosocial/web/source/settings/lib/query/admin/import-export.js
share/examples/gotosocial/web/source/settings/lib/query/admin/index.js
Expand All @@ -109,10 +112,11 @@ share/examples/gotosocial/web/template/about.tmpl
share/examples/gotosocial/web/template/authorize.tmpl
share/examples/gotosocial/web/template/confirmed.tmpl
share/examples/gotosocial/web/template/domain-blocklist.tmpl
share/examples/gotosocial/web/template/email_confirm_html.tmpl
share/examples/gotosocial/web/template/email_confirm_text.tmpl
share/examples/gotosocial/web/template/email_reset_html.tmpl
share/examples/gotosocial/web/template/email_reset_text.tmpl
share/examples/gotosocial/web/template/email_confirm.tmpl
share/examples/gotosocial/web/template/email_new_report.tmpl
share/examples/gotosocial/web/template/email_report_closed.tmpl
share/examples/gotosocial/web/template/email_reset.tmpl
share/examples/gotosocial/web/template/email_test.tmpl
share/examples/gotosocial/web/template/error.tmpl
share/examples/gotosocial/web/template/finalize.tmpl
share/examples/gotosocial/web/template/footer.tmpl
Expand Down
8 changes: 4 additions & 4 deletions www/gotosocial/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2023/02/21 15:49:37 nikita Exp $
$NetBSD: distinfo,v 1.5 2023/04/09 16:47:44 nikita Exp $

BLAKE2s (gotosocial-0.7.1-source-code.tar.gz) = e05f0d1983b5056d63e4b2addd4480436de2b47d7762e8fcc6df5b1496c74307
SHA512 (gotosocial-0.7.1-source-code.tar.gz) = 0c3c71eb66126f8b4e3c617e9ca27cb824d181d4dd22ab0aeb2851a6a6754d736a8a8245db4da9c3f51341b73fcc863b7a482da3dfbd54f0387f9842f84e70a0
Size (gotosocial-0.7.1-source-code.tar.gz) = 50913308 bytes
BLAKE2s (gotosocial-0.8.0-source-code.tar.gz) = b39ef6195619d7499965672f6879b3ba4501738e67efe2a66c574a425dcc32c8
SHA512 (gotosocial-0.8.0-source-code.tar.gz) = b3bbb160e039ddc8e36165bd39e6d633d719d6bed49a9c8a3e0a2bd8d272c42940132126b076a8dd8998cf2497c888f033baf6f23b44901c3f270efa87db6ba4
Size (gotosocial-0.8.0-source-code.tar.gz) = 52503432 bytes

0 comments on commit 16b36c2

Please sign in to comment.