Skip to content

Commit

Permalink
[PACKAGE/DEFCONFIG] add LIBMIKMOD + FLUIDLITE to static SDKs (#71)
Browse files Browse the repository at this point in the history
* [PACKAGE] add LIBMIKMOD + FLUIDLITE

* [DEFCONFIG] update static SDKs with FLUIDLITE and LIBMIKMOD
  • Loading branch information
Apaczer authored Dec 28, 2023
1 parent 756a1d8 commit b0130e4
Show file tree
Hide file tree
Showing 9 changed files with 64 additions and 0 deletions.
2 changes: 2 additions & 0 deletions configs/miyoo_musl_static_defconfig
Original file line number Diff line number Diff line change
Expand Up @@ -30,6 +30,7 @@ BR2_PACKAGE_FFMPEG_FFPROBE=y
BR2_PACKAGE_FFMPEG_AVRESAMPLE=y
BR2_PACKAGE_FFMPEG_POSTPROC=y
BR2_PACKAGE_FLITE=y
BR2_PACKAGE_FLUIDLITE=y
BR2_PACKAGE_MIMIC=y
BR2_PACKAGE_MIMIC_AUDIO_BACKEND_ALSA=y
BR2_PACKAGE_MPG123=y
Expand Down Expand Up @@ -71,6 +72,7 @@ BR2_PACKAGE_LUA_5_1=y
BR2_PACKAGE_LIBASPLIB=y
BR2_PACKAGE_LIBID3TAG=y
BR2_PACKAGE_LIBMAD=y
BR2_PACKAGE_LIBMIKMOD=y
BR2_PACKAGE_LIBSNDFILE=y
BR2_PACKAGE_OPENAL=y
BR2_PACKAGE_OPUS=y
Expand Down
2 changes: 2 additions & 0 deletions configs/miyoo_uclibc_static_defconfig
Original file line number Diff line number Diff line change
Expand Up @@ -29,6 +29,7 @@ BR2_PACKAGE_FFMPEG_FFPLAY=y
BR2_PACKAGE_FFMPEG_FFPROBE=y
BR2_PACKAGE_FFMPEG_AVRESAMPLE=y
BR2_PACKAGE_FFMPEG_POSTPROC=y
BR2_PACKAGE_FLUIDLITE=y
BR2_PACKAGE_MPG123=y
BR2_PACKAGE_VORBIS_TOOLS=y
BR2_PACKAGE_BZIP2=y
Expand Down Expand Up @@ -63,6 +64,7 @@ BR2_PACKAGE_LUA_5_1=y
BR2_PACKAGE_LIBASPLIB=y
BR2_PACKAGE_LIBID3TAG=y
BR2_PACKAGE_LIBMAD=y
BR2_PACKAGE_LIBMIKMOD=y
BR2_PACKAGE_LIBSNDFILE=y
BR2_PACKAGE_OPENAL=y
BR2_PACKAGE_SPEEX=y
Expand Down
2 changes: 2 additions & 0 deletions package/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -24,6 +24,7 @@ menu "Audio and video applications"
source "package/flite/Config.in"
source "package/fluid-soundfont/Config.in"
source "package/fluidsynth/Config.in"
source "package/fluidlite/Config.in"
source "package/gmrender-resurrect/Config.in"
source "package/gstreamer1/Config.in"
source "package/jack1/Config.in"
Expand Down Expand Up @@ -1422,6 +1423,7 @@ menu "Audio/Sound"
source "package/liblo/Config.in"
source "package/libmad/Config.in"
source "package/libmodplug/Config.in"
source "package/libmikmod/Config.in"
source "package/libmpd/Config.in"
source "package/libmpdclient/Config.in"
source "package/libreplaygain/Config.in"
Expand Down
5 changes: 5 additions & 0 deletions package/fluidlite/Config.in
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
config BR2_PACKAGE_FLUIDLITE
bool "fluidlite"
depends on BR2_USE_MMU
help
FluidLite is a very light version of FluidSynth.
3 changes: 3 additions & 0 deletions package/fluidlite/fluidlite.hash
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
# Locally computed
sha256 ef4d008f9fe2fa9a48135505d42dd7e8e9cc4d7494a4b13d6caa13adb5c61ff8 fluidlite-1.0.tar.gz
sha256 a5564e99fd7f49e1344152a8c5bc1d420d5f973b30e010946764db0b5b9e668c LICENSE
19 changes: 19 additions & 0 deletions package/fluidlite/fluidlite.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
################################################################################
#
# FLUIDLITE
#
################################################################################

FLUIDLITE_VERSION = 1.0
FLUIDLITE_SITE = $(call github,gcw0,FluidLite,$(FLUIDLITE_VERSION))
FLUIDLITE_LICENSE = LGPL-2.1+
FLUIDLITE_LICENSE_FILES = LICENSE
FLUIDLITE_INSTALL_STAGING = YES
FLUIDLITE_DEPENDENCIES =

# Disable the shared library for static only build
ifeq ($(BR2_STATIC_LIBS),y)
FLUIDLITE_CONF_OPTS += -DFLUIDLITE_BUILD_SHARED=FALSE
endif

$(eval $(cmake-package))
7 changes: 7 additions & 0 deletions package/libmikmod/Config.in
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
config BR2_PACKAGE_LIBMIKMOD
bool "libmikmod"
help
Mikmod is a module player and library supporting many
tracker formats, including mod, s3m, it, and xm.

http://mikmod.shlomifish.org/
2 changes: 2 additions & 0 deletions package/libmikmod/libmikmod.hash
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
# Locally computed
sha256 ad9d64dfc8f83684876419ea7cd4ff4a41d8bcd8c23ef37ecb3a200a16b46d19 libmikmod-3.3.11.1.tar.gz
22 changes: 22 additions & 0 deletions package/libmikmod/libmikmod.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
################################################################################
#
# libmikmod
#
################################################################################

LIBMIKMOD_VERSION:=3.3.11.1
LIBMIKMOD_SITE:=http://sourceforge.net/projects/mikmod/files/libmikmod/$(LIBMIKMOD_VERSION)

LIBMIKMOD_CONF_OPTS = --localstatedir=/var

LIBMIKMOD_LIBTOOL_PATCH = NO
LIBMIKMOD_INSTALL_STAGING = YES

LIBMIKMOD_CONFIG_SCRIPTS = libmikmod-config

define LIBMIKMOD_REMOVE_LIBMIKMOD_CONFIG
rm -f $(TARGET_DIR)/usr/bin/libmikmod-config
endef
LIBMIKMOD_POST_INSTALL_TARGET_HOOKS += LIBMIKMOD_REMOVE_LIBMIKMOD_CONFIG

$(eval $(autotools-package))

0 comments on commit b0130e4

Please sign in to comment.