-
Notifications
You must be signed in to change notification settings - Fork 28
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Release cardano crypto version 2.2 and other updates (#952)
* Added cardano-crypto-class-2.2.0.0 From https://github.com/IntersectMBO/cardano-base at ded795b240bc86b3e71766e4e896bb4e587af679 * Added cardano-crypto-tests-2.2.0.0 From https://github.com/IntersectMBO/cardano-base at ded795b240bc86b3e71766e4e896bb4e587af679 * Added cardano-crypto-praos-2.2.0.0 From https://github.com/IntersectMBO/cardano-base at ded795b240bc86b3e71766e4e896bb4e587af679 * Add revision with upper bound relaxed for cardano-crypto-class in plutus * Add revisions for `cardano-ledger-binary` with upper bounds * Update hackage * Update haskell.nix This was merged before in #920, but it looks like it is not in `main`. * Add revisions for cardano-ledger-core with upper bound on data-default-class * Add upper bounds on quickcheck-instances <0.3.32 * Add upper bound on `data-default <0.8`. * nix flake update CHaP --------- Co-authored-by: Hamish Mackenzie <Hamish.K.Mackenzie@gmail.com>
- Loading branch information
1 parent
e8ae473
commit 74b7657
Showing
89 changed files
with
10,689 additions
and
40 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
timestamp = 2024-12-11T19:48:20Z | ||
github = { repo = "IntersectMBO/cardano-base", rev = "ded795b240bc86b3e71766e4e896bb4e587af679" } | ||
subdir = 'cardano-crypto-class' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
timestamp = 2024-12-11T19:48:20Z | ||
github = { repo = "IntersectMBO/cardano-base", rev = "ded795b240bc86b3e71766e4e896bb4e587af679" } | ||
subdir = 'cardano-crypto-praos' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
timestamp = 2024-12-11T19:48:20Z | ||
github = { repo = "IntersectMBO/cardano-base", rev = "ded795b240bc86b3e71766e4e896bb4e587af679" } | ||
subdir = 'cardano-crypto-tests' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,7 @@ | ||
timestamp = 2023-02-23T15:33:46Z | ||
github = { repo = "input-output-hk/cardano-ledger", rev = "2f5956038233e4df0a065d96db32398605603f9b" } | ||
subdir = 'libs/cardano-ledger-binary' | ||
|
||
[[revisions]] | ||
number = 1 | ||
timestamp = 2024-12-11T19:54:23Z |
171 changes: 171 additions & 0 deletions
171
_sources/cardano-ledger-binary/1.0.0.0/revisions/1.cabal
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,171 @@ | ||
cabal-version: 3.0 | ||
name: cardano-ledger-binary | ||
version: 1.0.0.0 | ||
license: Apache-2.0 | ||
maintainer: operations@iohk.io | ||
author: IOHK | ||
homepage: https://github.com/input-output-hk/cardano-ledger | ||
synopsis: Binary serialization library used throughout ledger | ||
category: Network | ||
build-type: Simple | ||
|
||
source-repository head | ||
type: git | ||
location: https://github.com/input-output-hk/cardano-ledger | ||
subdir: libs/cardano-ledger-binary | ||
|
||
library | ||
exposed-modules: | ||
Cardano.Ledger.TreeDiff | ||
Cardano.Ledger.Binary | ||
Cardano.Ledger.Binary.Coders | ||
Cardano.Ledger.Binary.Crypto | ||
Cardano.Ledger.Binary.Decoding | ||
Cardano.Ledger.Binary.Encoding | ||
Cardano.Ledger.Binary.FlatTerm | ||
Cardano.Ledger.Binary.Group | ||
Cardano.Ledger.Binary.Plain | ||
Cardano.Ledger.Binary.Version | ||
|
||
hs-source-dirs: src | ||
other-modules: | ||
Cardano.Ledger.Binary.Encoding.Coders | ||
Cardano.Ledger.Binary.Encoding.Encoder | ||
Cardano.Ledger.Binary.Encoding.EncCBOR | ||
Cardano.Ledger.Binary.Decoding.Annotated | ||
Cardano.Ledger.Binary.Decoding.Coders | ||
Cardano.Ledger.Binary.Decoding.Decoder | ||
Cardano.Ledger.Binary.Decoding.Drop | ||
Cardano.Ledger.Binary.Decoding.DecCBOR | ||
Cardano.Ledger.Binary.Decoding.Sharing | ||
Cardano.Ledger.Binary.Decoding.Sized | ||
|
||
default-language: Haskell2010 | ||
ghc-options: | ||
-Wall -Wcompat -Wincomplete-record-updates | ||
-Wincomplete-uni-patterns -Wredundant-constraints -Wunused-packages | ||
|
||
build-depends: | ||
base >=4.12 && <4.17, | ||
aeson, | ||
binary, | ||
bytestring, | ||
cardano-binary >=1.6, | ||
cardano-crypto-class ^>=2.1, | ||
cardano-crypto-praos >=2.1, | ||
cardano-slotting, | ||
cardano-strict-containers >=0.1.2, | ||
cborg, | ||
containers, | ||
data-fix, | ||
deepseq, | ||
formatting, | ||
iproute, | ||
microlens, | ||
mtl, | ||
network, | ||
nothunks, | ||
primitive, | ||
plutus-ledger-api ^>=1.1, | ||
recursion-schemes, | ||
serialise, | ||
tagged, | ||
text, | ||
time, | ||
transformers >=0.5, | ||
tree-diff, | ||
vector, | ||
vector-map >=1.0 | ||
|
||
library testlib | ||
exposed-modules: | ||
Test.Cardano.Ledger.Binary.Arbitrary | ||
Test.Cardano.Ledger.Binary.Plain.Golden | ||
Test.Cardano.Ledger.Binary.Plain.RoundTrip | ||
Test.Cardano.Ledger.Binary.Random | ||
Test.Cardano.Ledger.Binary.RoundTrip | ||
Test.Cardano.Ledger.Binary.TreeDiff | ||
Test.Cardano.Ledger.Binary.Twiddle | ||
Test.Cardano.Ledger.Binary.Vintage.Helpers | ||
Test.Cardano.Ledger.Binary.Vintage.Helpers.GoldenRoundTrip | ||
|
||
visibility: public | ||
hs-source-dirs: testlib | ||
default-language: Haskell2010 | ||
ghc-options: | ||
-Wall -Wcompat -Wincomplete-record-updates | ||
-Wincomplete-uni-patterns -Wredundant-constraints -Wunused-packages | ||
|
||
build-depends: | ||
base >=4.12 && <4.17, | ||
base, | ||
bytestring, | ||
base16-bytestring, | ||
cardano-binary, | ||
cardano-crypto-class, | ||
cardano-crypto-tests, | ||
cardano-ledger-binary, | ||
cardano-prelude-test, | ||
cardano-strict-containers, | ||
cardano-slotting, | ||
cborg, | ||
containers, | ||
formatting, | ||
tree-diff, | ||
iproute, | ||
hedgehog, | ||
hspec, | ||
pretty-show, | ||
primitive, | ||
QuickCheck, | ||
quickcheck-instances <0.3.32, | ||
tasty-hunit, | ||
random >=1.2, | ||
text, | ||
vector, | ||
vector-map | ||
|
||
test-suite tests | ||
type: exitcode-stdio-1.0 | ||
main-is: Main.hs | ||
hs-source-dirs: test | ||
other-modules: | ||
Test.Cardano.Ledger.Binary.Failure | ||
Test.Cardano.Ledger.Binary.RoundTripSpec | ||
Test.Cardano.Ledger.Binary.Vintage.Coders | ||
Test.Cardano.Ledger.Binary.Vintage.Drop | ||
Test.Cardano.Ledger.Binary.Vintage.Failure | ||
Test.Cardano.Ledger.Binary.Vintage.RoundTrip | ||
Test.Cardano.Ledger.Binary.Vintage.Serialization | ||
Test.Cardano.Ledger.Binary.Vintage.SizeBounds | ||
|
||
default-language: Haskell2010 | ||
ghc-options: | ||
-Wall -Wcompat -Wincomplete-record-updates | ||
-Wincomplete-uni-patterns -Wredundant-constraints -Wunused-packages | ||
-threaded -rtsopts -with-rtsopts=-N | ||
|
||
build-depends: | ||
base >=4.12 && <4.17, | ||
base, | ||
bytestring, | ||
cardano-ledger-binary, | ||
cardano-crypto-class, | ||
cardano-crypto-praos, | ||
cardano-prelude-test, | ||
cardano-slotting, | ||
cardano-strict-containers, | ||
cborg, | ||
containers, | ||
hedgehog, | ||
hedgehog-quickcheck, | ||
hspec, | ||
iproute, | ||
primitive, | ||
QuickCheck, | ||
tagged, | ||
text, | ||
testlib, | ||
time, | ||
vector, | ||
vector-map |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
173 changes: 173 additions & 0 deletions
173
_sources/cardano-ledger-binary/1.1.0.0/revisions/2.cabal
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,173 @@ | ||
cabal-version: 3.0 | ||
name: cardano-ledger-binary | ||
version: 1.1.0.0 | ||
license: Apache-2.0 | ||
maintainer: operations@iohk.io | ||
author: IOHK | ||
homepage: https://github.com/input-output-hk/cardano-ledger | ||
synopsis: Binary serialization library used throughout ledger | ||
category: Network | ||
build-type: Simple | ||
|
||
source-repository head | ||
type: git | ||
location: https://github.com/input-output-hk/cardano-ledger | ||
subdir: libs/cardano-ledger-binary | ||
|
||
library | ||
exposed-modules: | ||
Cardano.Ledger.TreeDiff | ||
Cardano.Ledger.Binary | ||
Cardano.Ledger.Binary.Coders | ||
Cardano.Ledger.Binary.Crypto | ||
Cardano.Ledger.Binary.Decoding | ||
Cardano.Ledger.Binary.Encoding | ||
Cardano.Ledger.Binary.FlatTerm | ||
Cardano.Ledger.Binary.Group | ||
Cardano.Ledger.Binary.Plain | ||
Cardano.Ledger.Binary.Version | ||
|
||
hs-source-dirs: src | ||
other-modules: | ||
Cardano.Ledger.Binary.Encoding.Coders | ||
Cardano.Ledger.Binary.Encoding.Encoder | ||
Cardano.Ledger.Binary.Encoding.EncCBOR | ||
Cardano.Ledger.Binary.Decoding.Annotated | ||
Cardano.Ledger.Binary.Decoding.Coders | ||
Cardano.Ledger.Binary.Decoding.Decoder | ||
Cardano.Ledger.Binary.Decoding.Drop | ||
Cardano.Ledger.Binary.Decoding.DecCBOR | ||
Cardano.Ledger.Binary.Decoding.Sharing | ||
Cardano.Ledger.Binary.Decoding.Sized | ||
|
||
default-language: Haskell2010 | ||
ghc-options: | ||
-Wall -Wcompat -Wincomplete-record-updates | ||
-Wincomplete-uni-patterns -Wredundant-constraints -Wunused-packages | ||
|
||
build-depends: | ||
base >=4.14 && <4.17, | ||
aeson, | ||
base16-bytestring, | ||
binary, | ||
bytestring, | ||
cardano-binary >=1.6, | ||
cardano-crypto-class ^>=2.1, | ||
cardano-crypto-praos >=2.1, | ||
cardano-slotting, | ||
cardano-strict-containers >=0.1.2, | ||
cborg, | ||
containers, | ||
data-fix, | ||
deepseq, | ||
formatting, | ||
iproute, | ||
microlens, | ||
mtl, | ||
network, | ||
nothunks, | ||
primitive, | ||
plutus-ledger-api >=1.1, | ||
recursion-schemes, | ||
serialise, | ||
tagged, | ||
text, | ||
time, | ||
transformers >=0.5, | ||
tree-diff, | ||
vector, | ||
vector-map >=1.0 | ||
|
||
library testlib | ||
exposed-modules: | ||
Test.Cardano.Ledger.Binary.Arbitrary | ||
Test.Cardano.Ledger.Binary.Plain.Golden | ||
Test.Cardano.Ledger.Binary.Plain.RoundTrip | ||
Test.Cardano.Ledger.Binary.Random | ||
Test.Cardano.Ledger.Binary.RoundTrip | ||
Test.Cardano.Ledger.Binary.TreeDiff | ||
Test.Cardano.Ledger.Binary.Twiddle | ||
Test.Cardano.Ledger.Binary.Vintage.Helpers | ||
Test.Cardano.Ledger.Binary.Vintage.Helpers.GoldenRoundTrip | ||
|
||
visibility: public | ||
hs-source-dirs: testlib | ||
default-language: Haskell2010 | ||
ghc-options: | ||
-Wall -Wcompat -Wincomplete-record-updates | ||
-Wincomplete-uni-patterns -Wredundant-constraints -Wunused-packages | ||
|
||
build-depends: | ||
base, | ||
bytestring, | ||
base16-bytestring, | ||
cardano-binary, | ||
cardano-crypto-class, | ||
cardano-crypto-tests, | ||
cardano-ledger-binary >=1.0, | ||
cardano-prelude-test, | ||
cardano-strict-containers, | ||
cardano-slotting, | ||
cborg, | ||
containers, | ||
formatting, | ||
tree-diff, | ||
iproute, | ||
half, | ||
hedgehog, | ||
hspec, | ||
pretty-show, | ||
primitive, | ||
QuickCheck, | ||
quickcheck-instances <0.3.32, | ||
tasty-hunit, | ||
random >=1.2, | ||
text, | ||
vector, | ||
vector-map | ||
|
||
test-suite tests | ||
type: exitcode-stdio-1.0 | ||
main-is: Main.hs | ||
hs-source-dirs: test | ||
other-modules: | ||
Test.Cardano.Ledger.Binary.Failure | ||
Test.Cardano.Ledger.Binary.PlainSpec | ||
Test.Cardano.Ledger.Binary.Success | ||
Test.Cardano.Ledger.Binary.RoundTripSpec | ||
Test.Cardano.Ledger.Binary.Vintage.Coders | ||
Test.Cardano.Ledger.Binary.Vintage.Drop | ||
Test.Cardano.Ledger.Binary.Vintage.Failure | ||
Test.Cardano.Ledger.Binary.Vintage.RoundTrip | ||
Test.Cardano.Ledger.Binary.Vintage.Serialization | ||
Test.Cardano.Ledger.Binary.Vintage.SizeBounds | ||
|
||
default-language: Haskell2010 | ||
ghc-options: | ||
-Wall -Wcompat -Wincomplete-record-updates | ||
-Wincomplete-uni-patterns -Wredundant-constraints -Wunused-packages | ||
-threaded -rtsopts -with-rtsopts=-N | ||
|
||
build-depends: | ||
base, | ||
bytestring, | ||
cardano-ledger-binary, | ||
cardano-crypto-class, | ||
cardano-crypto-praos, | ||
cardano-prelude-test, | ||
cardano-slotting, | ||
cardano-strict-containers, | ||
cborg, | ||
containers, | ||
hedgehog, | ||
hedgehog-quickcheck, | ||
hspec, | ||
iproute, | ||
primitive, | ||
QuickCheck, | ||
tagged, | ||
text, | ||
testlib, | ||
time, | ||
vector, | ||
vector-map |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,7 @@ | ||
timestamp = 2023-04-26T17:24:56Z | ||
github = { repo = "input-output-hk/cardano-ledger", rev = "55a58ad476a978a24d56e8ce28b5f4bbaa159169" } | ||
subdir = 'libs/cardano-ledger-binary' | ||
|
||
[[revisions]] | ||
number = 1 | ||
timestamp = 2024-12-11T19:54:29Z |
Oops, something went wrong.